o2 oxygen sensor problem.... - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-24-2008, 06:34 PM   #1
juansvt
Focus Rookie
 
Join Date: Mar 2008
Fan#: 54414
Location: orlando-fl
What I Drive: ford focus svt 2003

Posts: 4
FF Reputation: 1 juansvt Good Standing Member
Buy-Sell-Trade Rating: (0)
o2 oxygen sensor problem....

i have a ford focus svt 2003 i got the check engine light on....i went to advance auto parts..and autozone,,,and they plugged to into my car....anyeay the code was that my o2 oxygen sensors were bad....two of them...so i bought them,,,,changed then....when i turn my car on the check engine light was gone...but my car start to lossing power....and shaking and the rpm droops from 900 rpm to 500 rpm ....i turned of ...turned back on again the check engine light came on again...and my car starts to run fine... so i took it to autozone they plugged the thing into my car again now they said that the code came out .,that the oxygen sensor upstream was the one is bad now...they are brand new....please some help!!!!!!


juansvt is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-24-2008, 08:38 PM   #2
northof60
Focus Enthusiast
 
northof60's Avatar
 
Join Date: Mar 2008
Fan#: 54564
Location: Yellowknife, NWT, Canada
What I Drive: 2002 Pitch Black 2d SVT #4110

Posts: 72
FF Reputation: 0 northof60 Newbie
Buy-Sell-Trade Rating: (0)
Check fuse 18 under the hood. Controls both o2 sensors.
northof60 is offline  
    Reply With Quote Quick reply to this message
Old 03-24-2008, 08:48 PM   #3
Sid03SVT
Focus Addict
 
Sid03SVT's Avatar
 
Join Date: Oct 2006
Fan#: 39759
Location: CT, CT
What I Drive: 02 Explorer 4.6L, 02 CBR600 F4i

Posts: 870
FF Reputation: 8 Sid03SVT Good Standing Member
Buy-Sell-Trade Rating: (0)
another item of interest, many svt owners will say to only buy ford o2 sensors, the aftermarket ones tend to be crap, so there is an equally good chance that the o2 sensor they sold you is crap. good luck
__________________
save a cow, eat a vegan
missing my 6-speed until proven otherwise
if someone helps you out, give them a rep point
don't know how? click on the number next to "FF Reputation" and add a comment
Sid03SVT is offline  
    Reply With Quote Quick reply to this message
Old 03-24-2008, 08:49 PM   #4
northof60
Focus Enthusiast
 
northof60's Avatar
 
Join Date: Mar 2008
Fan#: 54564
Location: Yellowknife, NWT, Canada
What I Drive: 2002 Pitch Black 2d SVT #4110

Posts: 72
FF Reputation: 0 northof60 Newbie
Buy-Sell-Trade Rating: (0)
fuse for o2 sensors

sorry didn't see my frist post appear

Last edited by northof60; 03-24-2008 at 08:50 PM. Reason: posted already
northof60 is offline  
    Reply With Quote Quick reply to this message
Old 03-24-2008, 09:51 PM   #5
juansvt
Focus Rookie
 
Join Date: Mar 2008
Fan#: 54414
Location: orlando-fl
What I Drive: ford focus svt 2003

Posts: 4
FF Reputation: 1 juansvt Good Standing Member
Buy-Sell-Trade Rating: (0)
thanks guys....im going to try that....i got some friends and they told me some thing about my mass air flow sensor.....i dont know is that can help.....but im going to try checking the fuse......thanks.....anything alse?
juansvt is offline  
    Reply With Quote Quick reply to this message
Old 03-24-2008, 09:54 PM   #6
juansvt
Focus Rookie
 
Join Date: Mar 2008
Fan#: 54414
Location: orlando-fl
What I Drive: ford focus svt 2003

Posts: 4
FF Reputation: 1 juansvt Good Standing Member
Buy-Sell-Trade Rating: (0)
about the buying the sensors from ford....just wondering why the dowstream is working....the only one giving me the problem is the upstream....??? i didnt buy them from ford.....
juansvt is offline  
    Reply With Quote Quick reply to this message
Old 03-25-2008, 07:47 AM   #7
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,935
Points 50,512, Level 100
Points: 50,512, Level: 100 Points: 50,512, Level: 100 Points: 50,512, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 27%
Activity: 27% Activity: 27% Activity: 27%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
I have had no issues with using NON Ford o2 in the SVT and have changed dozens of them

I also would check the o2 fuse , if it is blown the o2heater will not come on and cause it to go lean then fail into open loop , if you had a Diablo Predator you could scan and see this

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 03-25-2008, 10:34 AM   #8
03OrangeSVT
LETS TURN DIRT!!!!
 
03OrangeSVT's Avatar
 
Join Date: Feb 2005
Fan#: 19169
Location: Piketon, OH
What I Drive: MINI Cooper S TURBO

Posts: 11,906
FF Reputation: 152 03OrangeSVT Excellent Standing Member 03OrangeSVT Excellent Standing Member
Buy-Sell-Trade Rating: (5)
I HAVE noticed a difference in using an SVT specific O2 sensor and an "off the shelf" one from autozone.

My SVT just ran better with the Ford sensor than the Bosch generic one.
__________________
[B]1951 McCormick FARMALL M
2007 MINI Cooper S Turbo... new project car
1998 Chevy 3500 Ext cab, long bed, 4x4, duelly, turbo diesel
2004 Harley V-Rod.... sex on wheels
2011 Harley Electra Glide Ultra Limited
[/b]
03OrangeSVT is offline  
    Reply With Quote Quick reply to this message
Old 03-25-2008, 11:27 AM   #9
tukaniSVT
FF PHOTOG ENTHUSIAST
 
tukaniSVT's Avatar
 
Join Date: Mar 2004
Fan#: 5521
Location: SW Houston, TX
What I Drive: 2003 SVT Focus 2009 BMW 335i

Posts: 14,969
Points 35,900, Level 100
Points: 35,900, Level: 100 Points: 35,900, Level: 100 Points: 35,900, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 34 tukaniSVT Great Standing Member
Buy-Sell-Trade Rating: (1)
When that happened to me ... it was the fuse ... Hopefully that is what it is. Good Luck finding the Culprit.
tukaniSVT is offline  
    Reply With Quote Quick reply to this message
Old 04-29-2008, 10:20 AM   #10
2003_FOCUS_SVT
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49175
Location: Bay City, MI
What I Drive: 2003 Ford Focus ZX5 SVT

Posts: 8
FF Reputation: 1 2003_FOCUS_SVT Good Standing Member
Buy-Sell-Trade Rating: (0)
O2 Sensor

I drove into a parking lot yesterday and bottomed out while entering it (kinda a steep incline). It hit pretty hard and right away my check engine light came on. I went into Autozone and the code was for the O2 sensor. Would a hit like this cause an O2 sensor to break, or could it be more serious?

Thanks
2003_FOCUS_SVT is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with this code. 9318 DomestikZx3 General Technical Chat 17 07-11-2012 09:59 AM
Every trouble code defined 03OrangeSVT General Forced Induction 9 05-25-2011 12:53 PM
Oxygen sensors Focusnewb General Technical Chat 5 03-26-2007 10:31 AM
Oxygen Sensor wire routing Quikerstop ZETEC Performance (2000-2004) 1 02-25-2007 03:54 PM
heated oxygen sensor stxsrt General Technical Chat 2 11-20-2006 02:16 PM


All times are GMT -5. The time now is 11:08 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.