Any tips on Oxygen Sensor Heating circuit? - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-04-2012, 08:57 AM   #1
jmoryl
Focus Rookie
 
Join Date: Sep 2007
Fan#: 50300
Location: New Jersey
What I Drive: 2003 SVT Focus (silver)

Posts: 24
FF Reputation: 1 jmoryl Good Standing Member
Buy-Sell-Trade Rating: (0)
Any tips on Oxygen Sensor Heating circuit?

My SVT is throwing the P0135 and P0141 CEL codes, which is a fault in the O2 sensor heater for the front and rear sensors. Checking over the wiring, and the #18 fuse (under the hood), all looks good. Since I had a new front sensor (Ford) sitting around and the car has about 90k miles, I changed that sensor, expecting that would at least clear the P0135. No such luck. Any one here have a clue where to look next? Gotta get that light out long enough to pass my state inspection!

Thanks in advance.


jmoryl is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2012, 09:16 AM   #2
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,527
FF Reputation: 153 1turbofocus Excellent Standing Member1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
Need to see what the sensor is doing , see if a local member has a xcal and do a datalog , I will be glad to look it over for you

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote
Old 03-04-2012, 11:20 AM   #3
Grinder
Banned
 
Join Date: May 2011
Fan#: 85627
Location: Minneapolis, MN
What I Drive: 2003 CD silver SVT

Posts: 497
FF Reputation: 10 Grinder Great Standing Member
Buy-Sell-Trade Rating: (0)
If you have done a proper load test of the common power circuit and didn't see high resistance its likely a bad pcm. They rarely fail but the 02 heater circuits are tested by measuring the voltage drop across a resistor inside the pcm. This resistor bridges the control circuits for both heaters so when the pcm grounds one o2 current will flow from the opposite o2 and then through the resistor. Heat will often open this resistor and make the pcm believe both heater circuits have malfunctioned. Be careful if you ever buy a reman'd pcm - this is something that seems to miss their "checks" and I've seen them have this issue out of the box.
Grinder is offline  
    Reply With Quote
Old 03-04-2012, 04:10 PM   #4
chada1208
Focus Jr. Enthusiast
 
Join Date: Sep 2008
Fan#: 58933
Location: covington
What I Drive: 2000 zx3 focus red

Posts: 48
FF Reputation: 1 chada1208 Good Standing Member
Buy-Sell-Trade Rating: (0)
I had the same thing happen to my last 02 svtf! It happened when I bottomed out and hit the exhausted! Now I have the same problem with my recent 02 svtf so what can I do to fix it? I am planning on putting an orp and full exhaust on it soon so I will not b running an 02 Senor!
chada1208 is offline  
    Reply With Quote
Old 03-04-2012, 04:20 PM   #5
Mike_Mac
Focus Addict
 
Mike_Mac's Avatar
 
Join Date: Dec 2008
Fan#: 61110
Location: Windsor, Canada
What I Drive: 04 Red/Black ZX5, 00 infared ZTS

Posts: 1,322
FF Reputation: 12 Mike_Mac Great Standing Member
Buy-Sell-Trade Rating: (7)
^^^ you NEED the front O2.
Mike_Mac is offline  
    Reply With Quote
Old 03-04-2012, 05:02 PM   #6
jmoryl
Focus Rookie
 
Join Date: Sep 2007
Fan#: 50300
Location: New Jersey
What I Drive: 2003 SVT Focus (silver)

Posts: 24
FF Reputation: 1 jmoryl Good Standing Member
Buy-Sell-Trade Rating: (0)
Tom - thanks for the offer, but I won't be anywhere near NC soon.

Grinder - is there any simple way to check if the heaters are drawing the correct current (e.g. checking the voltage being supplied, measuring the resistance of the heater)? If one of the sensors is bad could it indicate a fault in the heater circuit for both - that seems like a possibility given what you say above. Cause I think the rear sensor might be dinged.
jmoryl is offline  
    Reply With Quote
Old 03-04-2012, 06:03 PM   #7
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,527
FF Reputation: 153 1turbofocus Excellent Standing Member1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
I you have a ground and power to the plug in for the o2 then 99% chance your fine , there is a 99.99% that you dont have a bad PCM

You dont have to be clost to or in NC for me to help you just find a member with a xcal and I can help you with your problem , you could still have a bad o2 even new , Vac leak , broke wire and much more a datalog will help

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote
Old 03-05-2012, 09:55 AM   #8
JimmySVT170
Focus Enthusiast
 
JimmySVT170's Avatar
 
Join Date: Sep 2009
Fan#: 68945
Location: Morganville, NJ
What I Drive: 2003 Pitch Black SVT

Posts: 139
FF Reputation: 1 JimmySVT170 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have the same issue, I hit a massive pothole and bottomed out, now I have this code. Tom, I have the predator tuner, how can I get you a datalog?
JimmySVT170 is offline  
    Reply With Quote
Old 03-05-2012, 09:55 AM   #9
JimmySVT170
Focus Enthusiast
 
JimmySVT170's Avatar
 
Join Date: Sep 2009
Fan#: 68945
Location: Morganville, NJ
What I Drive: 2003 Pitch Black SVT

Posts: 139
FF Reputation: 1 JimmySVT170 Good Standing Member
Buy-Sell-Trade Rating: (0)
Just P0135 btw.
JimmySVT170 is offline  
    Reply With Quote
Old 03-05-2012, 03:08 PM   #10
Grinder
Banned
 
Join Date: May 2011
Fan#: 85627
Location: Minneapolis, MN
What I Drive: 2003 CD silver SVT

Posts: 497
FF Reputation: 10 Grinder Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by jmoryl View Post
Tom - thanks for the offer, but I won't be anywhere near NC soon.

Grinder - is there any simple way to check if the heaters are drawing the correct current (e.g. checking the voltage being supplied, measuring the resistance of the heater)? If one of the sensors is bad could it indicate a fault in the heater circuit for both - that seems like a possibility given what you say above. Cause I think the rear sensor might be dinged.
It's possible to meausure the current flow through the heaters but it's a tricky measurement to set up and the heaters are duty cycled controlled which will mess with your readings.

If both heater circuit codes are set, something common between the two sensors is your problem. The only thing common is the power circuit and the PCM. I agree, it's not likely the PCM but it is possible and this type of scenario is one of the common causes of their uncommon failure....

Are you SURE the fuse is good?
Grinder is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:22 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.