New SVT...completley screwed (edit: not completely screwed anymore) - Page 18 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-26-2013, 10:00 AM   #171
v2.0focuszx3
Focus Jr. Enthusiast
 
Join Date: Oct 2013
Fan#: 119713
Location: City of Brotherly hate, I mean, love, PA
What I Drive: 2004 Comp O SVT ZX5

Posts: 49
Points 511, Level 10
Points: 511, Level: 10 Points: 511, Level: 10 Points: 511, Level: 10
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 v2.0focuszx3 Good Standing Member
Buy-Sell-Trade Rating: (4)
Whats the issue now?
v2.0focuszx3 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-2013, 01:49 PM   #172
p0sitivevibez
Focus Fanatic
 
p0sitivevibez's Avatar
 
Join Date: Aug 2004
Fan#: 11223
Location: Taneytown, MD
What I Drive: SVTF

Posts: 1,567
FF Reputation: 1 p0sitivevibez Good Standing Member
Buy-Sell-Trade Rating: (6)
A lot of noise coming from the front right, most likely an axle/CV joint.

I'm going to be commuting 100 miles a day to work and I need something reliable. This car ain't that.

The paint is also flaking off in places, the hatch/hood/drivers side door are misaligned, the sideskirts are jacked to hell, more then one wheel is bent, the exhaust is falling off and leaking......

Last edited by p0sitivevibez; 11-26-2013 at 02:50 PM.
p0sitivevibez is offline  
    Reply With Quote
Old 11-27-2013, 05:31 PM   #173
v2.0focuszx3
Focus Jr. Enthusiast
 
Join Date: Oct 2013
Fan#: 119713
Location: City of Brotherly hate, I mean, love, PA
What I Drive: 2004 Comp O SVT ZX5

Posts: 49
Points 511, Level 10
Points: 511, Level: 10 Points: 511, Level: 10 Points: 511, Level: 10
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 v2.0focuszx3 Good Standing Member
Buy-Sell-Trade Rating: (4)
how much would you sell it for in its current state?
v2.0focuszx3 is offline  
    Reply With Quote
Old 11-27-2013, 06:13 PM   #174
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,530
Points 17,859, Level 85
Points: 17,859, Level: 85 Points: 17,859, Level: 85 Points: 17,859, Level: 85
Level Up 2% Completed
Level up: 2% Level up: 2% Level up: 2%
Forum Activity 32%
Activity: 32% Activity: 32% Activity: 32%
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Quote:
Originally Posted by p0sitivevibez View Post
It really wasn't leaking anything except some blackish water from the lunchbox muffler. The radiator water was brown/rusty.
Quote:
Originally Posted by p0sitivevibez View Post
Just bought a 2003 Comp Orange SVT. 95k, buddy checked it out with me Drove fine. Drove it all the way home from New Jersey. Yesterday it started surging at idle, then smelled burning smell. Had it towed to local shop...they said it's screwed. They're worried about em putting any more money into the car. So I have a few options....sell as whole as is...part it out...new engine. I really like the car, so thinking about new engine. Can anyone recommend a reliable vendor or how to get through this? I don't have all the money in the world but I have good credit and my dad and I are pretty good mechanically wise. Are there new SVT engines for sale? Low mileage used ones?

Something in the engine is burning up. It's running hot. Sensors are bad. Exhaust is broken (figured I could get one from Trubendz). Airbag light is on. Accelerator is sticking. Test drive and drive home was fine. FML
Quote:
Originally Posted by p0sitivevibez View Post
OK car is driving, but not great.

Compression test was good. But there is a burning clutch/rubber smell still that scares me. Fan resistor replaced and fans are working. Throttle sticking but not as bad as before. Sometimes it revs up in neutral. Almost died when I turned the AC on sitting at a stop light. I went to replace the PCV valve last night and the v-shaped hose was so brittle it broke off, so I need one of those. Was gonna take to my buddys shop this morning but can't with the PCV valve like that. Flex pipe is broken but I bought another off of here. There is a pretty remarkable loss of power. I think that might be the flex pipe broken, the bad front o2 sensor and maybe a vacuum leak. Clutch/brake fluid resvoir cap was broken, have another coming in.
Quote:
Originally Posted by p0sitivevibez View Post
Drove it to work today. Drives awesome. Sweet jeebus this thing is a rocket compared to my ZX3. Will have to replace front struts, front wheel bearings, front swaybar links, unbend/replace rear subframe. Now have a small crack in windshield, either gonna have it done or get the kit. Gotta get it inspected, tomorrows the deadline.

Sorry to FF community for my poor communication skills on this.
Quote:
Originally Posted by p0sitivevibez View Post
Thanks all for the well wishes. Yeah he knew what was up lol. I have the knuckles out and are getting bearings pressed at the shop. New hubs and bearings, new shocks, new struts, front and rear swaybar links and control arms. Then an alignment. I won't worry about the rear subframe for now because I am completley broke. And yeah, i flushed the brake system and all other fluids..radiator was nasty! I'm gonna seafoam it soon as well. The car is timed properly now after I got it from my buddys shop. If you need work in Maryland, I'd highly suggest European Automotive Services iN Silver Spring/Kensington. I trust them and they won't do unneccessary crap or rip you off, and do AWESOME work. And dang ZXThrizzle, it's STILL leaking? Wtf?!? I wouldn't trust myself with timing on account of the SHTF if you're too off...kaboom.

I still have CEL for rear o2 sensor....got some spark plug non-foulers...for off road use of course..... And Airbag light is giving me problems (ground problem according to the codes..13), other than that she runs like a methed-out cheetah. Loving it and once suspension is all fixed up (DIY except for bearings and alignment) we'll be good to go. I Appreciate all the help and concern from FocusFanatics peeps and especially big one to Focus_Family and her fam for helping get this car back into shape.
Quote:
Originally Posted by p0sitivevibez View Post
Thanks!!

New problem.... did bearings/hubs/struts/shocks/control arms, swaybar links......

Got a problem I think coming from drive shaft on drivers side. The one my buddy hammered to get the the hub out of. Gonna pop off the wheel and have a look. Grinding starting from 1st and a "shutter" feel in the pedals in low speed/low gear. CV/drive shaft assembly isn't expensive thank God.

I knew I should've bought a hub puller!!

Aside from that the car is great!!! New suspension is soooo nice...no clunking or noises.
Quote:
Originally Posted by p0sitivevibez View Post
Thanks Chefster, yeah I replaced all that. Thermo, PCV, coil pack, etc. Burning gone. But now the clutch is slipping or we put the front suspension assemblys together wrong. Grinds coming out of 1st, 2nd and 3rd. I need to have someone look at it.

And yeah lol. It's like a friggin game of whack a mole!!! But I WILL fix this car and drive it forever. If I give up on the SVT, the terrorists win.
Quote:
Originally Posted by p0sitivevibez View Post
WELLLL..

grinding noise turned out to be really bad. Focus_Family and fam helped fill up my transmission fluid (it was very low). Grinding noise got better, almost gone. Driving down highway today to work, I put it in neutral at 70mph just to test it out. Wouldn't go into gear. Pulled off, couldn't start it in gear at all. They came down from Htown and drove my car home without the clutch (rev matching), and then bled it in my driveway. No go. Slave cylinder/clutch is toast. FML.

But Focus_Family and another buddy of mine from Virginia said they can help me install a new one. I can't afford to take it to a shop. Looking at the LUK kit, Exedy OEM, Brute Force and some others. I'm gonna take their advice and steer clear of the cheap off brand ones of ebay. Something I know is good by name cuz don't want any more problems. I've gotta class ring and some other stuff to sell to get some clutch money woot!

By the time this is over, the whole dayum car will be new.
Quote:
Originally Posted by p0sitivevibez View Post
UPDATE!!!! Car is running and driving, relativley fine!!!

Clutch, thermo, suspension, battery cable, etc. were all installed. I have been daily driving the car to and from work. It's I'd say 70% in good shape. Finally broke the clutch in. Still got a few problems

-roughness/loud/shaking - Focus_family looked at it and side it was passenger side mount. Ordered one of those
-VCT not working (worked before the clutch swap!)- my dad deleted 3 codes without writing them down, but that was over a month ago and they haven't come back. So think the solenoid is either disconnected? or needs to be dipped in brake cleaner or replaced. Focus_Family heard the intake manifold open up, but not VCT
-Idles high at startup - will idle between 1100-2200 in first few minutes of cold startup, then stays at 900-ish for the most part. Sometimes if I put it in neutral and roll to a stop the idle flucuates, but never too high
-Driver door is misaligned, hatch is misaligned, gas cap seems to open.close funny - think this has to do with the subframe being bent which shop told me, but I didn't follow up. Haven't got an alignment yet but it drives straight, but those items are misaligned. This issue worries me. Found rear subframes for like $120 locally. But dunno if that will fix the door and hatch misalignment. If I have to get frame straighetning so be it, for as much BS and $$ I put into this car to bring it back from the dead, i'm keeping it forever.
-sometimes there is a gassy/oily smell at startup, but always goes away. My MPG doesn't seem as high as I'd like but I guess at 70mph on the highway it's not gonna be prius like anyways
-lunchbox in exhaust is leaking water. Doesn't seem to be huge deal.

Thanks to everyone for all thier help!! I couldn't have done it without ya'll!!
Quote:
Originally Posted by p0sitivevibez View Post
Screw this POS. It's gonna be a parts car for my new SVT. I fix one problem and 3 more pop up. The frame is misaligned to the body. These car has been to hell and back again.


I'm probably missing more but,
Nearest I can find,
- you never had a 4 wheel alignment done (bear in mind that only toe is adjustable in the front, and toe/camber as one in the rear)
- you never chased down the exhaust leak, which seems to have been an issue since day 1


A new rear subframe will not fix any body misalignment. The 2 are unrelated.
It's pretty damn simple to align panels/hatch. Simply loosen bolts, move as needed and retighten.
W/O pictures I'm really doubting the subframe is bent to hell and that the body panels are out of alignment that far. It takes a very violent impact to bend the subframe and panels can move over time.

I'm not sure if I've ever seen another member so hot/cold about a damn car. It' works fine for months, 1 thing goes wrong and the whole damn car is a POS. Not to mention that you and you mechanic buddy looked at it when you bought it and everything seemed good. Day later it falls to shit?

Dunno. I'd seen you mention that you and your dad are mechanically inclined but I'm really not seeing that evidence. Turning a wrench is not mechanically inclined. That is simply the ability to follow directions, tab A into slot B.


Post exactly (and clearly) what has been done to the car since you've bought it and what it's doing currently. I'll try to do my best to help from here.
iminhell is offline  
    Reply With Quote
Old 12-02-2013, 12:41 PM   #175
p0sitivevibez
Focus Fanatic
 
p0sitivevibez's Avatar
 
Join Date: Aug 2004
Fan#: 11223
Location: Taneytown, MD
What I Drive: SVTF

Posts: 1,567
FF Reputation: 1 p0sitivevibez Good Standing Member
Buy-Sell-Trade Rating: (6)
Quote:
Originally Posted by v2.0focuszx3 View Post
how much would you sell it for in its current state?
Have to talk to the insurance company about the deer damage. I'll update when I figured it out.

@Iminhell - there's things I've done that haven't been listed. I'd like to think changing a clutch in a driveway on cinderblocks proves our mechanical abilities :)

I had an alignement except a wheel in the back they couldn't do due to the a bent knuckle. The exhaust actually fell off so I bet it leaks a lot more than it did. I just don't want to deal with it anymore.

Bought a 2006 Civic Si coupe and am very happy with it. I'm still waiting on the insurance company regarding the SVT.
p0sitivevibez is offline  
    Reply With Quote
Old 12-02-2013, 03:35 PM   #176
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,573
Points 12,451, Level 73
Points: 12,451, Level: 73 Points: 12,451, Level: 73 Points: 12,451, Level: 73
Level Up 1% Completed
Level up: 1% Level up: 1% Level up: 1%
Forum Activity 27%
Activity: 27% Activity: 27% Activity: 27%
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Discussion of sales is not permitted outside of the B-S-T section guys. Please follow the proper protocol when it comes to selling this vehicle.
zetecDon is offline  
    Reply With Quote
Old 12-18-2013, 11:47 AM   #177
p0sitivevibez
Focus Fanatic
 
p0sitivevibez's Avatar
 
Join Date: Aug 2004
Fan#: 11223
Location: Taneytown, MD
What I Drive: SVTF

Posts: 1,567
FF Reputation: 1 p0sitivevibez Good Standing Member
Buy-Sell-Trade Rating: (6)
Quote:
Originally Posted by zetecDon View Post
Discussion of sales is not permitted outside of the B-S-T section guys. Please follow the proper protocol when it comes to selling this vehicle.
Sorry about that!
p0sitivevibez is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:06 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.