looking for help zx3 running poorly - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-26-2013, 12:09 PM   #1
injen78
Focus Rookie
 
Join Date: Nov 2013
Fan#: 125081
Location: Lima, OH
What I Drive: 01 Black zx3

Posts: 8
FF Reputation: 1 injen78 Good Standing Member
Buy-Sell-Trade Rating: (0)
looking for help zx3 running poorly

have an 01 zx3 and it has been running very poorly the past couple months.
i brought it to have the CEL checked last week and it was throwing a code for the TPS sensor and IACV, so i replaced the IACV(second time in 2 months), and went back to have the codes run. now im only getting a CEL for o2 sensors and IACV. the car runs like garbage, at initial start up it idles high and has a sputter, then will idle down and act as if its going to die, then jump back up, bog out....etc. the whole time it sputters.

replaced- iacv(2x), plugs, wires, catalytic converter, egr, oil/filter, fuel filter, vc gasket, rear pcv hose(original had collapsed) and new pcv

cleaned- throttle body, MAF

looked at- vacuum hoses, had a smoke test run on it and its passing.

really looking for some pointers as to what to look at now. could possibly get a video of how its running later if someone would be interested in helping me put it up.


injen78 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-2013, 07:45 PM   #2
Highball116
Focus Enthusiast
 
Join Date: Mar 2013
Fan#: 112564
Location: Williamsport, PA
What I Drive: 2005 Red ZX4

Posts: 282
FF Reputation: 3 Highball116 Good Standing Member
Buy-Sell-Trade Rating: (0)
What are the exact codes for oxygen sensors? Depending what they are, it could be a failure of one or both of the sensors.

Toby
Highball116 is online now  
    Reply With Quote
Old 11-27-2013, 04:04 PM   #3
injen78
Focus Rookie
 
Join Date: Nov 2013
Fan#: 125081
Location: Lima, OH
What I Drive: 01 Black zx3

Posts: 8
FF Reputation: 1 injen78 Good Standing Member
Buy-Sell-Trade Rating: (0)
i cant remember exactly but one of them was a malfunctioning heating switch i believe. i really doubt the o2 sensors being bad would be causing it to run the way it does. its acting as if theres a major sensor unplugged, but the scan tool shows otherwise.
injen78 is offline  
    Reply With Quote
Old 11-27-2013, 04:23 PM   #4
Highball116
Focus Enthusiast
 
Join Date: Mar 2013
Fan#: 112564
Location: Williamsport, PA
What I Drive: 2005 Red ZX4

Posts: 282
FF Reputation: 3 Highball116 Good Standing Member
Buy-Sell-Trade Rating: (0)
If the code was for an internal fault in the upstream heated oxygen sensor, then that's your problem right there. The upstream oxygen sensor contributes a lot to performance. The downstream oxygen sensor does not, and is only there to check for excessive emissions. Get the code checked again, but if it's the upstream heated oxygen sensor, that'll cause a lot of problems.

Toby
Highball116 is online now  
    Reply With Quote
Old 11-27-2013, 04:51 PM   #5
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,501
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
You're looking at STFT/O2 Voltage, which is not the heater circuit.

Check the fuses.
If they are good look at the heater duty cycle.
iminhell is offline  
    Reply With Quote
Old 11-30-2013, 06:27 PM   #6
injen78
Focus Rookie
 
Join Date: Nov 2013
Fan#: 125081
Location: Lima, OH
What I Drive: 01 Black zx3

Posts: 8
FF Reputation: 1 injen78 Good Standing Member
Buy-Sell-Trade Rating: (0)
Codes are as follows

p1506-Idle Air Contol Overspeed Error
p0136-Oxygen O2 Sensor Circuit Low Voltage (Bank 1, Sensor 2)
p0135-O2 Sensor Heater Circ.,Bank1-Sensor1 Malfunction

the tech also said something about p2271 and p2270 which are related to the o2 signals/heaters

so what im going to assume is that a vacuum leak causing too much unmetered air to be burned which is making the engine run lean(o2 incorrect reading) and making it run fast(iac incorrect)

but ive been messing with the vacuum lines and havent really come up with anything.

first o2 is $43.99
second o2 is $65.99
coil pack is $90
and then theres various vacuum hoses that could need replaced.
injen78 is offline  
    Reply With Quote
Old 11-30-2013, 09:31 PM   #7
Highball116
Focus Enthusiast
 
Join Date: Mar 2013
Fan#: 112564
Location: Williamsport, PA
What I Drive: 2005 Red ZX4

Posts: 282
FF Reputation: 3 Highball116 Good Standing Member
Buy-Sell-Trade Rating: (0)
One of the codes indicates a malfunction in the heater circuit of the upstream oxygen sensor. See my original post. Internal faults supersede abnormal readings, and are always the roots of poor performance; not mere symptoms.

Toby
Highball116 is online now  
    Reply With Quote
Old 12-02-2013, 04:07 PM   #8
cheap sleeper
Focus Enthusiast
 
cheap sleeper's Avatar
 
Join Date: Oct 2008
Fan#: 59848
Location: florida, FL
What I Drive: 2001 black zx3

Posts: 326
FF Reputation: 3 cheap sleeper Good Standing Member
Buy-Sell-Trade Rating: (0)
coil pack, faulty battery cables, tps, dirty maf, fuel pump screen clogged or fuel pump failure. these all are common reasons why our cars will run like poo. i would check the coil pack first.
cheap sleeper is offline  
    Reply With Quote
Old 12-03-2013, 09:36 AM   #9
injen78
Focus Rookie
 
Join Date: Nov 2013
Fan#: 125081
Location: Lima, OH
What I Drive: 01 Black zx3

Posts: 8
FF Reputation: 1 injen78 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Highball116 View Post
One of the codes indicates a malfunction in the heater circuit of the upstream oxygen sensor. See my original post. Internal faults supersede abnormal readings, and are always the roots of poor performance; not mere symptoms.

Toby
So replace the upstream o2? Ill give it a shot but i really doubt a bad o2 r and o2 with abnormal readings will make the car sputter, lope, and die at idle. But i do appreciate the ideas.
Quote:
Originally Posted by cheap sleeper View Post
coil pack, faulty battery cables, tps, dirty maf, fuel pump screen clogged or fuel pump failure. these all are common reasons why our cars will run like poo. i would check the coil pack first.
Coil pack is one of the things id like to replace first, but money is the issue, im hoping that my buddy with a zx3 will let me test some parts before buying new.
injen78 is offline  
    Reply With Quote
Old 12-04-2013, 06:33 AM   #10
Highball116
Focus Enthusiast
 
Join Date: Mar 2013
Fan#: 112564
Location: Williamsport, PA
What I Drive: 2005 Red ZX4

Posts: 282
FF Reputation: 3 Highball116 Good Standing Member
Buy-Sell-Trade Rating: (0)
Just to reiterate, you have a code for a malfunctioning upstream oxygen sensor. The only recommended repairs are to replace the sensor, or repair the wiring: http://www.obd-codes.com/p0135. Also, the upstream oxygen sensor contributes a lot to performance, as it informs the air-fuel ratio. You're thinking of the downstream oxygen sensor, which is only there to track emissions.

Toby
Highball116 is online now  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:17 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.