JRSC BBK SVTF and no fuel in boost up top?!? Drives fine normally. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Forced Induction

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-17-2011, 07:32 PM   #1
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
UPDATE JRSC BBK SVTF and no fuel in boost up top?!? Drives fine normally.

Hey what's up gang. Car is doing something funky. Drives perfect when not in any boost. But all the sudden when leaving a toll, car falls on its face and wideband goes lean to no reading and the car just falls on its face. Drives fine out of boost. Fuel pump? Already changed the coil once and has a new alternator so thinking its not lack of spark. Belt looks good and is tight so that's not slipping. Figure belt slip would make it go rich.

Gonna change the fuel filter first to see if its clogged out tomorrow. Figure not injectors since it would still get fuel from a couple injectors. Lol no way they would all fail. What else do y'all recommend I check? Should have my OBD 2 to log with torque app hopefully tomorrow. But anything else I should check?

Thanks,

Tim


__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM

Last edited by Charged SVTF; 02-05-2012 at 04:28 PM.
Charged SVTF is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-17-2011, 07:37 PM   #2
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,756
FF Reputation: 153 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
You have a xcal / predator ? If so do a datalog and see if the fuel psi is falling off

Fuel filter
sock on fuel pump
fuel pump

Are some things that will cause a drop in fuel psi

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote
Old 11-17-2011, 07:39 PM   #3
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
No xcal. But torque data logs and gives csv files.
__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM
Charged SVTF is offline  
    Reply With Quote
Old 11-17-2011, 07:57 PM   #4
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
Lol think I found the problem. Three options here, because just did a second gear pull and all was well. Either crappy gas because I just got some more. Car engine being recycled....had it off and sitting for a few. Of fuel filter....all I did was tap it a bunch and it could had a clog loosen up. Money on fuel filter.

-edit....started acting up again. Leaning out, not complete cut off. Hoping fuel filter because I really don't feel like taking it in for a fuel pump. I can do a fuel pressure regulator but that shouldnt be it. But fuel pump...not feeling that job.
__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM
Charged SVTF is offline  
    Reply With Quote
Old 11-17-2011, 09:28 PM   #5
volcomstone1966
RIP 02 SVT 0209
 
volcomstone1966's Avatar
 
Join Date: May 2006
Fan#: 35104
Location: Tracy ,Nor-Cal, CA
What I Drive: 04 PWSC EAP SVT - 04 Kawasaki ZX6R

Posts: 3,787
FF Reputation: 15 volcomstone1966 Great Standing Member
Buy-Sell-Trade Rating: (44)
My powerworks Svt is doing the same, idels
Cool drives ok but when I put my foot down
She goes nowhere and my A/F leans way out
__________________
04 SVT EAP #1131 -POWERWORKS-Torsen-Clutch Masters-Top Speed-Massive-Brembo-Fifteen52-Steeda-UNDER CONSTRUCTION
04 Kawasaki ZX6R
volcomstone1966 is offline  
    Reply With Quote
Old 11-17-2011, 10:18 PM   #6
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
When was the last time you did your fuel filter? Ill have my new one on tomorrow and will let you know if that's the fix. Been a while since I changed mine.
__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM
Charged SVTF is offline  
    Reply With Quote
Old 11-17-2011, 10:25 PM   #7
volcomstone1966
RIP 02 SVT 0209
 
volcomstone1966's Avatar
 
Join Date: May 2006
Fan#: 35104
Location: Tracy ,Nor-Cal, CA
What I Drive: 04 PWSC EAP SVT - 04 Kawasaki ZX6R

Posts: 3,787
FF Reputation: 15 volcomstone1966 Great Standing Member
Buy-Sell-Trade Rating: (44)
its been a while , i have a new one for it already but i been doing other things to
it too so she has been off the road for a bit, CF hood CF hatch CF RS wing
take out back seats and new rims ....and a few other things
__________________
04 SVT EAP #1131 -POWERWORKS-Torsen-Clutch Masters-Top Speed-Massive-Brembo-Fifteen52-Steeda-UNDER CONSTRUCTION
04 Kawasaki ZX6R
volcomstone1966 is offline  
    Reply With Quote
Old 11-17-2011, 10:33 PM   #8
volcomstone1966
RIP 02 SVT 0209
 
volcomstone1966's Avatar
 
Join Date: May 2006
Fan#: 35104
Location: Tracy ,Nor-Cal, CA
What I Drive: 04 PWSC EAP SVT - 04 Kawasaki ZX6R

Posts: 3,787
FF Reputation: 15 volcomstone1966 Great Standing Member
Buy-Sell-Trade Rating: (44)
oh and whats your miles im just under 100k but the PW is only been on for like 3k
im wondering how long the fuel pumps last ?
__________________
04 SVT EAP #1131 -POWERWORKS-Torsen-Clutch Masters-Top Speed-Massive-Brembo-Fifteen52-Steeda-UNDER CONSTRUCTION
04 Kawasaki ZX6R
volcomstone1966 is offline  
    Reply With Quote
Old 11-17-2011, 10:33 PM   #9
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
OK ill let ya know if the filters the trick. I think so since I tapped it and was perfect then got worse again. I don't think our pumps are screwed.
__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM
Charged SVTF is offline  
    Reply With Quote
Old 11-18-2011, 07:15 AM   #10
Psycareyo
Focus Rookie
 
Psycareyo's Avatar
 
Join Date: Nov 2011
Fan#: 91644
Location: Plattsburgh, NY
What I Drive: 2010 Sport Trac Adrenalin/ SaleenSC

Posts: 16
FF Reputation: 1 Psycareyo Good Standing Member
Buy-Sell-Trade Rating: (0)
So it goes lean in all gears when in boost but drives fine when in vac?

My Lighting had a bad fuel pump(s) in July of this year. Basically it sputtered at idle and if you feathered the throttle it would about stall. When you let go of the throttle and it came down off rev, it would run normally.

The issue didn't have a slow ramp up. It just suddenly lost all power and almost stalled while going 35mph 25 feet from my driveway lol. I was lucky because it didn't move again until it was on the back of a flatbed. I then paid to tow it to my dealership and the stupid thing was down for 3 weeks while I waiting on parts.

Mine were OEM original pumps that lasted 175,000 miles.


Very interested in how you discover, trace and resolve your issue.
__________________
2010 Sport Trac Adrenalin AWD 4.6L Sonic Blue Saleen VI.5 Supercharged. 400RWHP
2011 Impreza WRX STI Sedan Dark Gray (Wife's).
1999 SVT Lightning #2590 Built: June 21, 1999 (Sold)
http://youtu.be/6MoiSi-xrFw
Psycareyo is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:32 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.