Ford Focus ZETEC Stalling..... - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-11-2011, 03:42 PM   #1
ZX3_Gomez
Focus Enthusiast
 
ZX3_Gomez's Avatar
 
Join Date: May 2010
Fan#: 75295
Location: Orangevale, CA, CA
What I Drive: 2003 Red ZX3, 2010 Matrix XRS

Posts: 296
FF Reputation: 1 ZX3_Gomez Good Standing Member
Buy-Sell-Trade Rating: (0)
Ford Focus ZETEC Stalling.....

I have a 2000 ford focus zx3 Zetec. After driving for a while and I am at s top light the car sometime swill almost stall and my battery light will comeone for like half a second....

What could this be. Already cleaned MAFS, Throttle body, new air filter, and did a tune up....


__________________
2003 ZX3 Cardinal Red ZETEC , 2010 Super White XRS Matrix
ZX3_Gomez is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-11-2011, 03:44 PM   #2
drunkyoda
Hmmmmm
 
drunkyoda's Avatar
 
Join Date: May 2009
Fan#: 65151
Location: Milton, WA
What I Drive: 2003 Pitch Black LX

Posts: 3,704
Points 13,451, Level 75
Points: 13,451, Level: 75 Points: 13,451, Level: 75 Points: 13,451, Level: 75
Level Up 51% Completed
Level up: 51% Level up: 51% Level up: 51%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 9 drunkyoda Good Standing Member
Buy-Sell-Trade Rating: (3)
the coil pigtail? alternator going bad? the tube at back of the intake manifold
__________________
2003 Focus Sedan - Sold but not forgotten
2014 Mustang V6 - Current
drunkyoda is offline  
    Reply With Quote Quick reply to this message
Old 10-11-2011, 03:46 PM   #3
ZX3_Gomez
Focus Enthusiast
 
ZX3_Gomez's Avatar
 
Join Date: May 2010
Fan#: 75295
Location: Orangevale, CA, CA
What I Drive: 2003 Red ZX3, 2010 Matrix XRS

Posts: 296
FF Reputation: 1 ZX3_Gomez Good Standing Member
Buy-Sell-Trade Rating: (0)
<a href="http://media.photobucket.com/image/pcv hose ford focus/areala/PCV.jpg" target="_blank"><img src="http://img.photobucket.com/albums/v484/areala/PCV.jpg" border="0"></a>

I was looking at my engine closer and on the PCV I see that the hose is kinked. Can that be the main problem? Its the hose
__________________
2003 ZX3 Cardinal Red ZETEC , 2010 Super White XRS Matrix
ZX3_Gomez is offline  
    Reply With Quote Quick reply to this message
Old 10-11-2011, 05:10 PM   #4
nov173
Focus Fanatic
 
nov173's Avatar
 
Join Date: Nov 2005
Fan#: 29840
Location: Pittsburgh, Pa, United States
What I Drive: 2014 Focus ST

Posts: 3,263
FF Reputation: 79 nov173 Excellent Standing Member
Buy-Sell-Trade Rating: (4)
check your 02 sensors... That can do exactly that.
__________________
SVT header kit, 2.25 MBRP cat-back & flex, r/t high flow cat. aem cai, frpp kit

For Sale: Rear bumper(stock). SVT side skirts FS as well. Buy em!!!!
nov173 is offline  
    Reply With Quote Quick reply to this message
Old 10-11-2011, 06:56 PM   #5
02chromeyellowzx5
Focus Enthusiast
 
02chromeyellowzx5's Avatar
 
Join Date: Feb 2011
Fan#: 83522
Location: Colorado Springs, CO
What I Drive: 2002 Egg Yolk Yellow ZX5

Posts: 123
FF Reputation: 1 02chromeyellowzx5 Good Standing Member
Buy-Sell-Trade Rating: (1)
I kinda had that same problem. took it to autozone and had them test the battery and it came back to the alternator going bad, wasn't charging the battery only had like 35% charge to it.
__________________
Check out my photo albums
02chromeyellowzx5 is offline  
    Reply With Quote Quick reply to this message
Old 10-11-2011, 11:39 PM   #6
ErnestoEDowns78
Banned
 
Join Date: Sep 2011
Fan#: 90066
Location: Independence, OH
What I Drive: 2003 Pitch Black ZX3

Posts: 18
FF Reputation: 1 ErnestoEDowns78 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by 02chromeyellowzx5 View Post
I kinda had that same problem. took it to autozone and had them test the battery and it came back to the alternator going bad, wasn't charging the battery only had like 35% charge to it.
Great job.ty
ErnestoEDowns78 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:04 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat