Focus 2008 extreme rough idle - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-07-2011, 01:13 PM   #1
Johnston
Focus Rookie
 
Join Date: Jul 2011
Fan#: 87557
Location: Perry, GA
What I Drive: 2008 blue 2.0 focus

Posts: 3
FF Reputation: 1 Johnston Good Standing Member
Buy-Sell-Trade Rating: (0)
Focus 2008 extreme rough idle

I have a Focus 2008 2.0 DOHC that my wife just bought used, and it idles extremely roughly. I mean like crazy... the darn thing won't stay still... goes from 600 to 900 and back down and up nonstop.

You can only tell when the car is not in motion, and it drives well. It's a pretty new car, only 45,000 miles on the engine. But the person that had it before my wife got it crashed into a pole... so it is rebuilt.

I took the MAF out and cleaned it (it was in pretty good condition... but I figured it couldn't hurt so I doused it down with quick dry electronic cleaner fluid).

I scanned it and no MIL codes show up. I've driven it about 1000 miles since buying it and have had no problems on the highways. Someone told me to reset the computer... would that help? Can you do that by just taking the battery out for an hour or so or do I have to drag it down to the agency?

Any ideas? Does the 2008 focus have a IAC? If so, where?

I'd GREATLY appreciate any help on this ... have a 2000 mile trip coming up in a few weeks and I need to have it fixed before we leave.


Johnston is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2011, 03:39 PM   #2
Focusalaska
Focus Enthusiast
 
Focusalaska's Avatar
 
Join Date: Aug 2009
Fan#: 68329
Location: Anchorage, AK
What I Drive: 2009 Ebony SES

Posts: 258
FF Reputation: 2 Focusalaska Good Standing Member
Buy-Sell-Trade Rating: (0)
There is a TSB for the throttle body, this might be your problem http://www.focusfanatics.com/forum/s...&highlight=TSB

Edit don't think my link is working? Search for "TSB" under the technical section. There is a thread called extreme rough idle. The OP had a rough idle and loss of power WITH and WITHOUT any DTC's.
__________________
Team Duratec #23
Official SES Registry #49
Tom's Tune, DDMTUNING 5000k HI/LO & FOGS, Switchback LED turn signals, AR103's gapped .54, FSWerks CAI. more to come
Focusalaska is offline  
    Reply With Quote
Old 07-07-2011, 09:55 PM   #3
Johnston
Focus Rookie
 
Join Date: Jul 2011
Fan#: 87557
Location: Perry, GA
What I Drive: 2008 blue 2.0 focus

Posts: 3
FF Reputation: 1 Johnston Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks... I'll look into it!
Johnston is offline  
    Reply With Quote
Old 03-29-2012, 08:13 PM   #4
new focus
Focus Rookie
 
Join Date: Mar 2012
Fan#: 97034
Location: Vancouver, WA
What I Drive: 2008 Grey Focus SE Sedan

Posts: 1
FF Reputation: 1 new focus Good Standing Member
Buy-Sell-Trade Rating: (0)
hey, I have the same exact issue, did you ever get it fixed? and what was the part that fixed it? how did you fix it?


thanks
new focus is offline  
    Reply With Quote
Old 03-29-2012, 09:19 PM   #5
elsolo
Focus Fanatic
 
elsolo's Avatar
 
Join Date: Mar 2012
Fan#: 96835
Location: Long Beach, CA
What I Drive: 2003 dark shadow grey metallic ZX3

Posts: 2,169
FF Reputation: 17 elsolo Great Standing Member
Buy-Sell-Trade Rating: (1)
I would consider the idle air control valve on any efi motor with an idle problem.

edited to add:
Forgot they switched to a fly by wire, probably the throttle body then.
elsolo is offline  
    Reply With Quote
Old 04-10-2012, 09:22 AM   #6
mustang1986
Focus Rookie
 
Join Date: Apr 2012
Fan#: 97259
Location: Morristown, TN
What I Drive: 2009 Blue Focus

Posts: 2
FF Reputation: 1 mustang1986 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have a 2009 Focus and was having a similar idle problem. Local dealership after 5 trips "flashed my computer" and changed my PCM with no results. Took to a different dealer after 2 days they discovered my throttle body needed replaced. On my way to pick it up now. Fingers crossed that this fixed my problem.
mustang1986 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:37 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.