2012 Focus - Aftermarket Stereo possibilities. - Page 26 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-24-2013, 12:45 PM   #251
BLarson
Focus Fanatic
 
BLarson's Avatar
 
Join Date: Aug 2008
Fan#: 58905
Location: East Bay, CA
What I Drive: 2012 Ox White SE Sports Pack Hatch

Posts: 3,005
Points 2,829, Level 32
Points: 2,829, Level: 32 Points: 2,829, Level: 32 Points: 2,829, Level: 32
Level Up 53% Completed
Level up: 53% Level up: 53% Level up: 53%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 7 BLarson Good Standing Member
Buy-Sell-Trade Rating: (0)
Okay so here is the short of it.

I installed the unit last night. It powered up just fine. And the screen functioned as it should and worked well. The sound played through my speakers. But the radio Reception was really really poor. I attribute that likely to the fact that there was only one of the two antenna connectors connected, because the unit only came with one connection plug and not two. This bothered me but would not have been the straw that broke the camels back. Having the original iPhone connector only, really bothered me as well but also wasn't the straw that broke the camels back either. The last straw was the fact that no matter what I tried I could not get the steering wheel controls to work. The system has a learning feature where you select the button and then press the button on the wheel for it to learn which button is which. However as I tried to make it work by pressing the buttons it would not recognize the wheel. It tells you to hold down the button for a long period of time which I tried, to no avail. Long story short, I'm sending the unit back. I think that for the money I spent($410), it Wasn't worth it. I think I will wait until a different unit comes out before I purchase a new one. Until then I purchased a LOC so I can hook up my subwoofers.

I think I will throw in the towel for any of these Chinese units until someone in United States successfully tests the unit and gives it a good thumbs-up. And I mean someone that specifically has the SE tech package like I do(203A).

I'm sure something new will come out later this year that I will want to try but until then I will wait.

@cgrums I really hope it works out for you man! It just didn't for me. I hope the steering wheel controls function on your car. And I hope all the connections are proper for you. We have different systems, you have the my ford touch. So I'm hopeful that the different systems will work better for you than they did for me. I am anxious to see here if it works for you. I also want to know if It has two antenna hook ups. Good luck bud.
BLarson is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-24-2013, 01:47 PM   #252
fanoftheliving
Focus Enthusiast
 
Join Date: Aug 2011
Fan#: 88586
Location: Morristown, NJ
What I Drive: 2012 silver SE

Posts: 62
FF Reputation: 1 fanoftheliving Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by BLarson View Post
Okay so here is the short of it.

I installed the unit last night. It powered up just fine. And the screen functioned as it should and worked well. The sound played through my speakers. But the radio Reception was really really poor. I attribute that likely to the fact that there was only one of the two antenna connectors connected, because the unit only came with one connection plug and not two. This bothered me but would not have been the straw that broke the camels back. Having the original iPhone connector only, really bothered me as well but also wasn't the straw that broke the camels back either. The last straw was the fact that no matter what I tried I could not get the steering wheel controls to work. The system has a learning feature where you select the button and then press the button on the wheel for it to learn which button is which. However as I tried to make it work by pressing the buttons it would not recognize the wheel. It tells you to hold down the button for a long period of time which I tried, to no avail. Long story short, I'm sending the unit back. I think that for the money I spent($410), it Wasn't worth it. I think I will wait until a different unit comes out before I purchase a new one. Until then I purchased a LOC so I can hook up my subwoofers.

I think I will throw in the towel for any of these Chinese units until someone in United States successfully tests the unit and gives it a good thumbs-up. And I mean someone that specifically has the SE tech package like I do(203A).

I'm sure something new will come out later this year that I will want to try but until then I will wait.

@cgrums I really hope it works out for you man! It just didn't for me. I hope the steering wheel controls function on your car. And I hope all the connections are proper for you. We have different systems, you have the my ford touch. So I'm hopeful that the different systems will work better for you than they did for me. I am anxious to see here if it works for you. I also want to know if It has two antenna hook ups. Good luck bud.
Thank you very much, I think this is very useful information. Can you comment on the sound quality?
__________________
'02 Honda S2000, 2012 Silver Focus HB, 5 spd Ordered August 13th, Build Date Sept 19th, delvrd: 9/29/2011. Sport pkg, Moon Roof, Winter Pkg, 203A
fanoftheliving is offline  
    Reply With Quote Quick reply to this message
Old 01-24-2013, 02:08 PM   #253
cgrums
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108510
Location: Renton, WA
What I Drive: 2012 White Focus SEL

Posts: 9
FF Reputation: 2 cgrums Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by BLarson View Post
Okay so here is the short of it.

I installed the unit last night. It powered up just fine. And the screen functioned as it should and worked well. The sound played through my speakers. But the radio Reception was really really poor. I attribute that likely to the fact that there was only one of the two antenna connectors connected, because the unit only came with one connection plug and not two. This bothered me but would not have been the straw that broke the camels back. Having the original iPhone connector only, really bothered me as well but also wasn't the straw that broke the camels back either. The last straw was the fact that no matter what I tried I could not get the steering wheel controls to work. The system has a learning feature where you select the button and then press the button on the wheel for it to learn which button is which. However as I tried to make it work by pressing the buttons it would not recognize the wheel. It tells you to hold down the button for a long period of time which I tried, to no avail. Long story short, I'm sending the unit back. I think that for the money I spent($410), it Wasn't worth it. I think I will wait until a different unit comes out before I purchase a new one. Until then I purchased a LOC so I can hook up my subwoofers.

I think I will throw in the towel for any of these Chinese units until someone in United States successfully tests the unit and gives it a good thumbs-up. And I mean someone that specifically has the SE tech package like I do(203A).

I'm sure something new will come out later this year that I will want to try but until then I will wait.

@cgrums I really hope it works out for you man! It just didn't for me. I hope the steering wheel controls function on your car. And I hope all the connections are proper for you. We have different systems, you have the my ford touch. So I'm hopeful that the different systems will work better for you than they did for me. I am anxious to see here if it works for you. I also want to know if It has two antenna hook ups. Good luck bud.
Sorry to hear that, I think you made a more than reasonable effort and certainly went in eyes wide open.

I too would much prefer a quality, name-brand aftermarket headunit. I'd gladly pay 3x what I paid for the off-brand.

If the steering wheel controls don't work I'm going to have to have a long think about whether or not I want to keep it. I've gone into this not necessarily expecting a dud but also expecting to make a number of compromises. I've been really disappointed with the MFT in terms of weird little bugs:

- It loses the clock time at least 2x per week. I haven't been motivated to seek a solution because it is easy to reset but seriously, 2013 and I have to frequently reset the time on the clock?

- Every couple of weeks the system takes an inordinately long time to boot; I'll be 10-15 minutes into my commute before the screen comes to life.

- Bluetooth; this is a big one for me because 98% of my listening is of podcasts on my phone. I can't tell you the number of times that bluetooth media just refused to stream and would only play out of my phone. Disconnected the phone, reconnected the phone, disconnected and reconnected just media via bluetooth, re-paired the phone countless times etc.

- Navigation; more than any other issue this is what's motivating me to seek aftermarket alternatives. From everything that I've read (which, granted, may not be complete) all of the hardware 'hooks' are in my car for the navigation to be enabled. I'd even strongly consider spending the $795 Ford wants for the package just to turn the thing on. Alas, no dice.

I'm both looking forward to installing the unit on Saturday and I'm not; either way it should be interesting.
cgrums is offline  
    Reply With Quote Quick reply to this message
Old 01-24-2013, 05:37 PM   #254
JL330
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99616
Location: Bowling Green, KY
What I Drive: 2012 silver focus S

Posts: 486
FF Reputation: 1 JL330 Good Standing Member
Buy-Sell-Trade Rating: (0)
I don't have steering wheel controls so it may be a good choice for me. How was the sound quality? Remember I'll be coming from the stock S model junk.
JL330 is offline  
    Reply With Quote Quick reply to this message
Old 01-24-2013, 09:55 PM   #255
dpando1
Focus Enthusiast
 
Join Date: Nov 2011
Fan#: 92144
Location: Clovis, CA
What I Drive: 2012, Grey, Focus SE Sport Package

Posts: 151
Points 225, Level 4
Points: 225, Level: 4 Points: 225, Level: 4 Points: 225, Level: 4
Level Up 50% Completed
Level up: 50% Level up: 50% Level up: 50%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 dpando1 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by JL330 View Post
I'm picking up a 1911 this weekend.
AHHHSOMMEE!! hahaha because we all know what's happening.

Quote:
Originally Posted by BLarson View Post
I love when car threads move to gun talk(I'm not being facetious). I'd love to buy a nice 1911. But they are big $$$.
Hahah you know I would love to start a new thread like "what gun goes best with your new Mk3" hahaha or "Cold air intake vs buying an AR-15" lol

but oh yeah those connectors just don't make sense....hahaha
dpando1 is offline  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 04:36 AM   #256
Seondave
Focus Rookie
 
Join Date: Jan 2013
Fan#: 109095
Location: Statesville, NC
What I Drive: 2012 Sterling Grey Focus SE Hatch

Posts: 8
FF Reputation: 1 Seondave Good Standing Member
Buy-Sell-Trade Rating: (0)
I just got my Focus, but, much to my wife's amusement, I'm already looking at the various options available to upgrade, either looks or functionality. I have the SE model without USB or Sync. I've been reading through the various posts and threads about the Metra faceplate among others. Someone linked this in an earlier post.

My question is, does anyone know anything about it? Has anyone purchased anything from this site or purchased one of their products? I couldn't find out whether or not they ship to the US...
Seondave is offline  
    Reply With Quote Quick reply to this message
Old 02-04-2013, 06:01 PM   #257
cgrums
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108510
Location: Renton, WA
What I Drive: 2012 White Focus SEL

Posts: 9
FF Reputation: 2 cgrums Good Standing Member
Buy-Sell-Trade Rating: (0)
So, after two weeks, I have my own sit-rep to submit.

Bottom line: it's going back.

This whole experience has gone basically exactly as I expected it would only the stereo never actually functioned completely.

Two weekends ago my brother and his wife were in town to celebrate my birthday. As part of the weekends festivities we had planned to install the stereo. We removed the MFT system fairly painlessly (with the exception of a few tough molex connectors).

We first ran in to issues with the aftermarket wiring harness(es) not matching the factory harness(es). To some extent I was expecting this; it's clear when you have the MFT unit next to the aftermarket stereo that a lot of computer is being taken out, not a whole is being put back in. I expected some of the factory connectors to no longer be functional with the more basic aftermarket stereo.

I did not expect whole giant connectors (that plugged into the screen for the MFT) to have absolutely no mate in the aftermarket harness whatsoever.

The aftermarket wiring harness exists in two discreet looms. I was not expecting to have to wire bits of these looms together. Nor was I aware that this connection would have to be made as there is no mention in the 'manual' of this.

We pulled the stereo out, put the MFT back in and I initiated a return with the seller. I was immediately contacted by the seller inquiring as to the reason for the return. I explained the lack of compatability with the SEL focus and the seller proceeded to attempt to provide wiring diagrams and installation instructions. Unfortunately the instructions were in Chinese and they depicted pretty clearly a base model stereo being replaced.

After twenty-some odd emails I agreed to check the unit again with a revised wiring diagram. I went out yesterday and pulled the MFT back out and installed the new stereo per the revised wiring diagram.

It powered on! My first thought was that it looked pretty good. Nothing fancy, simple front end GUI, media player, phone, radio and navigation. It seemed to be running a new(er) copy of iGo Primo navigation software. I was actually getting excited.

Not for long; no sound. There are two pairs of male RCA audio cables coming out of the two connectors that interface with the factory stereo. These RCA cables are, per the seller, supposed to be connected to some of the 6 female RCA audio inputs/outputs for the new stereo.

No combination of plugging these in as either inputs or outputs from the new stereo would produce any sound from the factory speakers.

I'm giving up on this earlier than I might have at one time. I no longer have the time to troubleshoot and work the bugs out of what is supposed to be a 'finished' product.

Meh...at least it only took a minimal amount of arguing to get the seller to authorize a return.
cgrums is offline  
    Reply With Quote Quick reply to this message
Old 02-04-2013, 07:47 PM   #258
Seondave
Focus Rookie
 
Join Date: Jan 2013
Fan#: 109095
Location: Statesville, NC
What I Drive: 2012 Sterling Grey Focus SE Hatch

Posts: 8
FF Reputation: 1 Seondave Good Standing Member
Buy-Sell-Trade Rating: (0)
I just want to thank all of you who were willing to be guinea pigs for the rest of us. I've been looking at the various "overseas" sellers to see if I could find something that I might be interested in, but I concerned with the reputability of those companies.

I may still go with the Metra kit...I haven't decided. I really don't like the way it looks, but I may be able to overlook that for a nicer system.
Seondave is offline  
    Reply With Quote Quick reply to this message
Old 02-04-2013, 08:10 PM   #259
cgrums
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108510
Location: Renton, WA
What I Drive: 2012 White Focus SEL

Posts: 9
FF Reputation: 2 cgrums Good Standing Member
Buy-Sell-Trade Rating: (0)
If I was coming from a base-model stereo *and* this thing actually worked, I can't say I'd be terribly disappointed. It's fairly well put-together for what you pay for it ($410) and if it sounds decent I'd be content feature-wise.

Life expectancy? 2 years? 6 months? 90 min? 0?

I think the general business model (on their end) is that the units are compatible in replacing 90% of the base models stereo for whatever OEM they're targeting.

Is there any sign of any of the major audio manufacturers (Alpine, Pioneer, Kenwood) intending to offer a direct replacement for the MFT?
cgrums is offline  
    Reply With Quote Quick reply to this message
Old 02-04-2013, 08:16 PM   #260
BLarson
Focus Fanatic
 
BLarson's Avatar
 
Join Date: Aug 2008
Fan#: 58905
Location: East Bay, CA
What I Drive: 2012 Ox White SE Sports Pack Hatch

Posts: 3,005
Points 2,829, Level 32
Points: 2,829, Level: 32 Points: 2,829, Level: 32 Points: 2,829, Level: 32
Level Up 53% Completed
Level up: 53% Level up: 53% Level up: 53%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 7 BLarson Good Standing Member
Buy-Sell-Trade Rating: (0)
I attempted to install the unit again today. The steering wheel controls still do not work. I have included a link of a video of me trying to connect the wheel controls. Kind of boring.
http://www.youtube.com/watch?v=G6D_ImE9h8E

I also took a video of the poor radio reception.
http://www.youtube.com/watch?v=ZPSppK7vMb8

Here is a video how those same stations sound on the stock radio unit.

http://www.youtube.com/watch?v=lXOzFwxbT8Q
Here is a picture of the antenna connection.

Here is a video showing how the back up camera does not automatically change when car is put into reverse.

http://www.youtube.com/watch?v=L26YWSDIugk

The unit is still not functioning as it should.
BLarson is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:07 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.