knock sensor issues - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Focus Tuning Chat

Focus Tuning Chat Discuss performance tuning options for your Ford Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 04-22-2011, 02:08 AM   #1
EggYolkedZX3
Focus Enthusiast
 
EggYolkedZX3's Avatar
 
Join Date: Jan 2009
Fan#: 61654
Location: Henderson, NV
What I Drive: '01 Yellow ZX3, '04 Blue SVT w/EAP

Posts: 126
Points 859, Level 15
Points: 859, Level: 15 Points: 859, Level: 15 Points: 859, Level: 15
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 8 EggYolkedZX3 Good Standing Member
Buy-Sell-Trade Rating: (3)
knock sensor issues

First off, I have an '01 ZX3 with the Zetec/ATX and have an XCAL 3 w/ Tom's tune.

I'm wondering what others who datalog with the first "KNOCK SENSOR RETARD LIMIT" DMR in the SBAF6 processor code list see as far as values or on the graph while doing a normal cruise datalog. My issue currently is when I log the KS (on either the stock tune or on Tom's tune, doesn't matter), it shows that I'm always knocking and pulling -5 degrees of timing usually right around 2000 rpm or above. The problem is though, I'm not hearing or feeling any detonation at all. I believe my KS is bad or something else making noise is setting it off but not positive. My graph would show a straight line at 0 when idling and almost always goes straight down to -5 when it hits the 2000 rpm mark and eventual goes back to 0. But there is never an in between, always at 0 or a straight vertical to -5 with the occasional advancement.

So I was wondering what should I be seeing on the graph or in values as far as the KS? Should it mostly read at 0 with very little timing being pulled at any rpm range with advancement here and there or what? I'd appreciate any advice or suggestions on this issue from others who know what I'm talking about. Its causing me to not be able to get tuned and I'd like to change that asap. Its impossible to get a proper tune when the KS decides to max out pulling timing.

Thanks in advance,
Steven


EggYolkedZX3 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-23-2011, 02:50 PM   #2
EggYolkedZX3
Focus Enthusiast
 
EggYolkedZX3's Avatar
 
Join Date: Jan 2009
Fan#: 61654
Location: Henderson, NV
What I Drive: '01 Yellow ZX3, '04 Blue SVT w/EAP

Posts: 126
Points 859, Level 15
Points: 859, Level: 15 Points: 859, Level: 15 Points: 859, Level: 15
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 8 EggYolkedZX3 Good Standing Member
Buy-Sell-Trade Rating: (3)
Bump for some help!

I'd really like to know what I should be seeing on the graph when I log the knock sensor.
EggYolkedZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-23-2011, 03:45 PM   #3
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,202
Points 51,306, Level 100
Points: 51,306, Level: 100 Points: 51,306, Level: 100 Points: 51,306, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
You shouldnt see anything 0

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 04-23-2011, 07:04 PM   #4
JCH841
Focus Enthusiast
 
JCH841's Avatar
 
Join Date: Oct 2010
Fan#: 79303
Location: Suffolk, VA
What I Drive: 2013 Blue ST3

Posts: 505
Points 906, Level 16
Points: 906, Level: 16 Points: 906, Level: 16 Points: 906, Level: 16
Level Up 6% Completed
Level up: 6% Level up: 6% Level up: 6%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 3 JCH841 Good Standing Member
Buy-Sell-Trade Rating: (0)
We used to see false knock in boat engine EFI from loose motor mounts, etc. I think even a couple of loose knock sensors. Make sure you don't have anything like that.
__________________
Growing old is unavoidable. Growing up is optional.
JCH841 is offline  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 01:33 AM   #5
EggYolkedZX3
Focus Enthusiast
 
EggYolkedZX3's Avatar
 
Join Date: Jan 2009
Fan#: 61654
Location: Henderson, NV
What I Drive: '01 Yellow ZX3, '04 Blue SVT w/EAP

Posts: 126
Points 859, Level 15
Points: 859, Level: 15 Points: 859, Level: 15 Points: 859, Level: 15
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 8 EggYolkedZX3 Good Standing Member
Buy-Sell-Trade Rating: (3)
Well today I found a few new things but the problem is still there.

First thing I found was the wire that goes from the battery to the alternator was rubbing on the stud where the knock sensor mounts. I moved it but the car still shows knock during a datalog.

I decided to log the car while free reving not in gear and in drive while on the jack stands still and the KS read 0 all through out the rpm's, couldnt get it to show knock. Then I go to put the car on the ground and go for a cruise. Well the same thing as before happens anywhere above about 2000rpm while accelerating in a gear, the KS goes off.

I guess I'll play with it more tomorrow and see if I get anything to work correctly. Is it unheard of to have a KS go bad? Starting to think its the problem.

EDIT: I tried transbraking while on jackstands to create load and the KS shows knock. Graph looks the same as if driving it on the street. So now, I think I've got this narrowed to a load issue. Gonna try a new set of Motorcraft spark plugs tomorrow and see what happens, cant hurt anything. I believe now its either ignition related or the KS itself is way too sensitive. I'll update tomorrow. Oh and I've run 87oct, 91oct, and 96oct all with the same knock results on the stock tune.

Last edited by EggYolkedZX3; 04-24-2011 at 02:53 AM.
EggYolkedZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 03:32 AM   #6
BowerR64
Focus Fanatic
 
BowerR64's Avatar
 
Join Date: Sep 2010
Fan#: 78699
Location: Kansas city, MO
What I Drive: 2007 ZX3 SE

Posts: 2,379
Points 11,745, Level 71
Points: 11,745, Level: 71 Points: 11,745, Level: 71 Points: 11,745, Level: 71
Level Up 24% Completed
Level up: 24% Level up: 24% Level up: 24%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 12 BowerR64 Great Standing Member
Buy-Sell-Trade Rating: (2)
If the knock sensor was bad or going bad wouldnt you feel a major power loss?

I read the life of the knock sensors are like 10 years. I read you can trick the sensor temporarily to trouble shoot problems. emergency solution not a long term solution.
__________________
It's not important to win, it's important to make the other guy lose.
BowerR64 is offline  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 10:10 AM   #7
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,202
Points 51,306, Level 100
Points: 51,306, Level: 100 Points: 51,306, Level: 100 Points: 51,306, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
We talked about all the things that need to be checked and I dont see where you have tested any of them

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 01:35 PM   #8
EggYolkedZX3
Focus Enthusiast
 
EggYolkedZX3's Avatar
 
Join Date: Jan 2009
Fan#: 61654
Location: Henderson, NV
What I Drive: '01 Yellow ZX3, '04 Blue SVT w/EAP

Posts: 126
Points 859, Level 15
Points: 859, Level: 15 Points: 859, Level: 15 Points: 859, Level: 15
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 8 EggYolkedZX3 Good Standing Member
Buy-Sell-Trade Rating: (3)
Quote:
Originally Posted by 1turbofocus View Post
We talked about all the things that need to be checked and I dont see where you have tested any of them

Tom
Ok,

The first thing you said was run 5 gallons of 91oct and 5 gallons of 100oct which averages out to 95.5 but since I had a little less 91oct in the tank already it came out to be about 96oct. Knock still showed in the datalog, just like the 87oct log, after wasting over $50 for a 3/4 tank of gas (remember jobless high school kid here)... That rules out bad gas though, right?

Next you said to get a piece of garden hose and listen around for metal noise while someone holds the rpms around 2000rpm. Well since I can only do that in place and already stated the KS doesnt pick up anything while revving in place, then what am I supposed to hear? I already said there's nothing out of the ordinary. Acording to datalogging, this only happens when driving around or transbraking on jackstands. Must be a load issue now, right?

And that's all you've said.
EggYolkedZX3 is offline  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 03:46 PM   #9
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,202
Points 51,306, Level 100
Points: 51,306, Level: 100 Points: 51,306, Level: 100 Points: 51,306, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
You will only see knock after a set load and RPM , you have to have load to have/see knock

I was asking you to check thing to see if you had something loose and vibrating and that would cause the knock sensor to go off

I can adjust the sensitivity of the knock sensor but I would like to know for sure it isnt something else

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 04-24-2011, 06:37 PM   #10
redZX300
Focus Enthusiast
 
Join Date: Sep 2006
Fan#: 39044
Location: Vermont, United States
What I Drive: 2000 red zx3

Posts: 179
FF Reputation: 2 redZX300 Good Standing Member
Buy-Sell-Trade Rating: (3)
is this an NA focus?
redZX300 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:16 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat