2003 1.8 TDCi 115 electric/engine issue - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Regional Forums > Overseas Fanatics > Fanatics: Europe

Fanatics: Europe Europe & UK Global Forum

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-11-2010, 02:38 PM   #1
andywit
Guest
 
Fan#:
Posts: n/a
2003 1.8 TDCi 115 electric/engine issue

For about the last week or so my Focus dashboard display has been either working well or not at all. I was not particularly bothered as I had experienced similar issues about a year ago and resolved it by removing the cluster and cleaning the PCB with Isopropyl alcohol.
Anyway on my way home I decided to fill up with fuel as the guage was indicating "empty" although I knew it had about a quarter tank left. 50 later it was full to the brim. I drove nearer home but after about 4 or 5 miles the engine started to run rough. If it was a petrol engine I would have described it as pinking or hunting. It would not idle but stall.
Next day I duly removed and cleaned the cluster; but it did not resolve either the electric cluster or engine issue. I took it to a local garage who said it was "limp" and needed to be computer analysed for fault identification, as the car was protecting itself from further damage.
I agreed to return a couple of hours later, not realising that it would become undrivable after covering less than one mile.
The garage recovered my car but say that although it has now been attached to three computer analysers they still do not have any firm ideas as to resolution.
Any ideas gratefully accepted. Mine include alternator, ignition, earthing, relay. Thanks for looking.


 
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-11-2010, 03:17 PM   #2
S0C0nFused
Focus Fanatic
 
S0C0nFused's Avatar
 
Join Date: Sep 2006
Fan#: 39405
Location: Saint Louis, MO
What I Drive: 2007 TorD-Red ZX5 SES

Posts: 3,351
FF Reputation: 77 S0C0nFused Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Discounting the fact that it is diesel (which I have no practical knowledge of). I think your on track with earthing (or ground as we call it). There are 2 primary ground (earthing) points. One tends to be under the hood, close to the battery and fuse box. This is ground for the starter, lights etc. Then there is another ground. On my 07 (American version), it is the passenger side pillar (behind the kickpanel plastic). This ground point is for you ECU, low current lamps (like you dash) etc. On the odd chance that it has corroded or otherwise gotten somewhat dodgy, it can lead to all sorts of interesting phenomena (like screwing with analyzers). That's the only help I can offer. Good luck!
__________________
Steeda SRI w/CAI intake. Trubendz SS 2.5" . FR Susp/Struts. Tune by Tom (FocusPower). Rota Grids. SAP rear spoiler. Custom front air dam, rocker panel bits and Rear valance.
Last of the Hatches #28
S0C0nFused is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:27 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.