help! wiper linkage bushing disconnected - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-08-2010, 02:51 PM   #1
sd0070
Focus Rookie
 
Join Date: Sep 2010
Fan#: 78397
Location: buffalo, NY
What I Drive: 2000 gold ford focus

Posts: 2
FF Reputation: 1 sd0070 Good Standing Member
Buy-Sell-Trade Rating: (0)
help! wiper linkage bushing disconnected

2000 ford focus: the rod that is connected to the wiper motor disconnected from the rest of the wiper linkage (at the end of the rod away from the motor). I got in there and tried to snap it back together, but when I turned the wipers on it disconnected again after about 5 seconds.

I really dont want to have to replace the whole wiper linkage system (whatever its called) because I know the problem is just that one bushing. Anyone have any advice? Can I buy just the bushing? How easy is it to replace myself? Would I be better off taking it in to the dealer? How much would that set me back? Edit: is there any way to rig this together not using the conventional parts/methods?

An unrelated question: my hood latch and cable are messed up and it takes a while for me to get it to latch. (the safety release doesnt work at all). In order to get the hood to latch shut I have to feed the cable back in where the release is inside the car. How easy is this to replace myself? Or how much am I looking at to take it to a mechanic?

Thanks in advance for your help!


sd0070 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-08-2010, 05:12 PM   #2
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,881
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Ford lists the "wiper link assembly" as a single part: 5S4Z 17508 AA. And it's expensive. (My out of date parts list says $225. Phone your local dealer for an up to date quote.) The bushings aren't listed separately. If funds are tight, you might get a used one from the junk yard. I think anything you rig up probably wouldn't hold for long but it may be worth a try. Sorry, no suggestions there. Removal and replacement of the linkage is a definite DIY type job.

PS Welcome to FF.
BC_ZX3 is offline  
    Reply With Quote
Old 10-20-2010, 11:44 AM   #3
sd0070
Focus Rookie
 
Join Date: Sep 2010
Fan#: 78397
Location: buffalo, NY
What I Drive: 2000 gold ford focus

Posts: 2
FF Reputation: 1 sd0070 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by BC_ZX3 View Post
Ford lists the "wiper link assembly" as a single part: 5S4Z 17508 AA. And it's expensive. (My out of date parts list says $225. Phone your local dealer for an up to date quote.) The bushings aren't listed separately. If funds are tight, you might get a used one from the junk yard. I think anything you rig up probably wouldn't hold for long but it may be worth a try. Sorry, no suggestions there. Removal and replacement of the linkage is a definite DIY type job.

PS Welcome to FF.
Thanks for the input. I finally got around to attempting the fix on my own. I got the piece I needed from the junkyard. I was able to attach the end of the new piece where I was having the problem, but now I cant attach the other end! Its just way too hard (my hands cant squeeze tight enough). I cant figure out how to wiggle the whole unit out (yes I unscrewed the screws - i can move it around a few inches each way, just not completely out of the little nook it is in). There are a couple metal parts of the frame making it seem impossible to get free. So I'm doing this all with the whole unit in place.

My question is: Any advice on how to get the whole unit out so I can maybe tap the end on with a hammer or something? Or is there some technique or tool I can use to squeeze the pieces together so they snap into place?

Thanks in advance for any help!
sd0070 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:02 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.