No dome light, trunk light stays on, trunk doesnt open from button, scratched windshield - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-30-2010, 02:44 AM   #1
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
No dome light, trunk light stays on, trunk doesnt open from button, scratched windshield

So those are the three I can think of at the moment. Dome light does not turn on when either door is open. Trunk light stays on for some reason so I took out bulb. Trunk does not open from button in dash. When button is pressed, I can hear what I believe is a relay inside the dash somewhere turning on. And the windshield and rear window have scratches from the wipers turning on when the water has not reached the glass yet from the sprayers. Any ideas on how to fix any of this? Thanks! -Aaron


__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2010, 10:15 PM   #2
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
bump
__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Old 08-31-2010, 01:29 AM   #3
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,834
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Quote:
Originally Posted by TheIVJackal View Post
Dome light does not turn on when either door is open.
Check the light switch selector - "always on", "door open on", "always off" - is in the right position. If that's OK, check fuse 35 in the passenger compartment fuse panel, the dome bulb itself and the individual door switches (that are located behind the brass door striker.) Since both doors don't work, it's probably the bulb or the switch position.
Quote:
Originally Posted by TheIVJackal View Post
Trunk light stays on for some reason so I took out bulb. Trunk does not open from button in dash. When button is pressed, I can hear what I believe is a relay inside the dash somewhere turning on.
If you can hear a click, the dash hatch release switch should be OK - even though they commonly fail with age - so check for breaks/shorts in the wiring. At the rear hatch, there is an accordion joint through which the wiring harness passes, between the two hatch hinges. Look for wiring breaks/shorts here and repair as necessary. It's a very common area for hatch electrical problems. Check that the hatch mechanism wiring is receiving 12V with a multimeter when dash button is pressed. If it is, the hatch release mechanism itself has failed. Replace it.
Quote:
Originally Posted by TheIVJackal View Post
And the windshield and rear window have scratches from the wipers turning on when the water has not reached the glass yet from the sprayers. Any ideas on how to fix any of this? Thanks! -Aaron
Check your fluid reservoir filter screen is not clogged (in the bottom of the reservoir - remove front wheel well lining to get at) or that your reservoir isn't full of crud. Both front and rear wipers use the single front reservoir. Spray should be almost instantaneous; a delay indicates an obstruction or weak washer motor.
BC_ZX3 is offline  
    Reply With Quote
Old 08-31-2010, 02:31 AM   #4
emsvitil
Focus Addict
 
Join Date: Sep 2007
Fan#: 50210
Location: SoCal, CA
What I Drive: 2000 SE Wagon

Posts: 1,196
FF Reputation: 9 emsvitil Good Standing Member
Buy-Sell-Trade Rating: (0)
Just replaced the hatch lock on my wagon.

It did click and sound like it was working.

And the rear light stayed on because the car evidently thought the hatch was open.

Had to crawl back and remove the covering to gain access to the lock mechanism.

If you gain access, you'll see a metal part around the pin and what looks like black plastic holding the metal part that's to one side.

The black plastic looking part is a metal covered piece and is what you need to push against sideways (the side it's on)to release the lock.

A white plastic piece inside the lock breaks and won't open the black piece.

Rather than replacing the white plastic piece that breaks, the new improved lock mechanism has a hole in it so you can see if the white plastic piece is broken rather than the original lock in which you had to break away parts of plastic to see what's inside the mechanism
__________________
Ed
emsvitil is offline  
    Reply With Quote
Old 08-31-2010, 12:25 PM   #5
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
I did fix the license plate lights as their wire had been ripped in that booth between the hatch and the car. Dome light is on correct selector and works when the selector is moved to the on position. Ill check the other wires at the joint to see if they are ripped or something. At school I looked up the wiring diagram and found that the door ajar switch ground is the same as the ground for the hatch mechanism. Kind of sounds to me that the ground is somehow bad. Weird thing is that the ground is in the Left A-Pillar and dont understand how that ground would go bad. I haven't checked it yet but will soon. Ill get back to you guys if I find anything...
__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Old 09-04-2010, 06:19 PM   #6
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
Update. The trunk mechanism randomly worked twice then it stopped again making me think its a connection problem somewhere. Checked that hinge boot thing and found that some of the wires were exposed but not enough to short to ground, just the plastic coating was ripped but none of the actual wires were torn. Dome light still is not working. Opened the drivers side door and the chime went off so I know That switch is working. Chime did not turn on with the passenger side door open and im not sure if its suppose to or not. Took out the gauge cluster to check some bulbs and found 2 missing! One of which is the Door Ajar light... Previous owner conveniently failed to mention this. Im kind of running out of ideas! Please help
__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Old 09-04-2010, 06:46 PM   #7
Madrab
Focus Jr. Enthusiast
 
Madrab's Avatar
 
Join Date: Aug 2010
Fan#: 77346
Location: Glasgow, United Kingdom
What I Drive: 2002, green, focus 1.8 Zetec

Posts: 33
FF Reputation: 1 Madrab Good Standing Member
Buy-Sell-Trade Rating: (0)
Have you checked the dome light's contacts? it's a 3 postion switch so check that when the door is open it gets 12 vots to the middle one (i think) it may be that in the door open position there is a bad contact in the switch. The trunk lock solenoid may be sticking or it's way out, these can be serviced if you're handy with that type of thing. Getting them out is the pain in the ass tho...line up some finger plasters if they're the same as the UK Focus
Rob
__________________
Been a ford fanatic all my days - From my 1973 Mk1 Escort 1300GT to now my 1.8 Zetec Focus! Well apart from my much loved E30 Tourer too :o)

Please take the time to notch me a rep score if you feel I've been of help to you....cheers
Madrab is offline  
    Reply With Quote
Old 09-06-2010, 11:03 PM   #8
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
Guess I can try to clean those contacts a little more. Kinda scraped the top of them with a piece of metal and I dont think it would always be off if that were the case. Anyone know the wiring path for the switch to the light? And it says the ground is behind left A pillar but I took that out, saw the wires went by there but did not see a ground. Looks like the wires go down into the dash towards the fuse block. And im guessing that if the ground was bad, then the chime wouldn't work right?
__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Old 09-12-2010, 03:31 AM   #9
TheIVJackal
Focus Enthusiast
 
Join Date: Aug 2010
Fan#: 77556
Location: Santa Barbara, CA
What I Drive: 2000 White Zx3

Posts: 53
FF Reputation: 1 TheIVJackal Good Standing Member
Buy-Sell-Trade Rating: (0)
Update. Trunk mechanism started to work! Will only work if hatch is closed "correctly", whatever that means exactly. I closed it and pushed on it to make sure and it worked over and over! Not saying its 100% as I still want to clean it or spray it with stuff to help it. Dome Light is still a problem though=-(
__________________
Isaiah 5:21-22
TheIVJackal is offline  
    Reply With Quote
Old 09-12-2010, 04:06 AM   #10
sailor
"Elder"
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 11,234
FF Reputation: 60 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Posted via FF Mobile In my sedan, trunk light works with the latch - and latch needs to be opened fully by the emergency exit handle B4 shutting or it doesn`t always latch fully (door ajar light on) and I assume trunk light is still on when not fully latched, as closing latch with trunk open shuts off light..... That interior light is complicated, turns on when door unlatched by remote, has a timer relay to turn off slowly after exiting vehicle delay timer shut off immediately if car started(lights go off) check manual/wiring diagram for an interior light relay that may be bad..... now that you know at least one door switch works!
sailor is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:01 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.