CAI or SRI? - Page 4 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus First Generation > DURATEC Performance (2003-2007)

DURATEC Performance (2003-2007) The place to chat about any Duratec 23, 23E, and 20 engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-23-2010, 12:56 AM   #31
4UQX007
Focus Jr. Enthusiast
 
4UQX007's Avatar
 
Join Date: Apr 2009
Fan#: 63932
Location: Pacific Grove, CA
What I Drive: 2001 SEVT

Posts: 37
FF Reputation: 1 4UQX007 Good Standing Member
Buy-Sell-Trade Rating: (0)
I did the same, with the Spectre filter.
Worked great until I started experiencing the heat lock and poor acceleration.
Sorry to everyone who disagree but, I picked up an Ebay CARB exempt 2.5" CAI and replaced the wire mesh cone filter it came with, for a K&N cone, had to use the handy spacers that came with the Spectre.
Noticed a great improvement through the bar but best at higher RPM. vs. the SRI seemed better at lower RPM. It tucks in pretty solid above the splash guard and in front of the wheel well. 01 SE.
__________________
SEdan Revolution #52.
R.I.P Dad ()
Asphalt. Its whats for dinner.
4UQX007 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2010, 07:31 AM   #32
mtadd162
Proudly Daily Driven
 
mtadd162's Avatar
 
Join Date: Jun 2007
Fan#: 47890
Location: Massachusetts, Afghanistan
What I Drive: 2005 Focus ST

Posts: 2,255
FF Reputation: 9 mtadd162 Good Standing Member
Buy-Sell-Trade Rating: (5)
what year did this splash guard start coming on the focus?...i want one! i had to make one, but a factory one would be key
__________________
05 Focus ST-Sold but missed
-ST Crew #73 N/A FTW!
Feb. 09' ROTM
SSR - Silver Sedan Revolution Member #1
Cams Installed, great made my car into a VTAK
mtadd162 is offline  
    Reply With Quote
Old 02-23-2010, 07:45 AM   #33
Dung1sm
Atx PZEV FTW!
 
Dung1sm's Avatar
 
Join Date: Dec 2007
Fan#: 52323
Location: Los Angeles/Las Vegas, NV
What I Drive: 2005 Silver ZX4

Posts: 2,919
FF Reputation: 4 Dung1sm Good Standing Member
Buy-Sell-Trade Rating: (2)
k/n CAI ftw!!!
__________________
So Cal Crew#43
Sedan Revolution #130

Moderator for:
South West Fanatics
Ford Focus & General Car Chat
Ford Focus Build Showroom
Dung1sm is offline  
    Reply With Quote
Old 04-26-2010, 03:26 PM   #34
lets_FOCUS
Focus Enthusiast
 
lets_FOCUS's Avatar
 
Join Date: Feb 2009
Fan#: 62632
Location: Cheektowaga, NY
What I Drive: 2003 Silver ZX3

Posts: 134
FF Reputation: 1 lets_FOCUS Good Standing Member
Buy-Sell-Trade Rating: (1)
I found a really cheap CAI online, threw it on the car, and it definitely made a difference. It did set the CEL on though, I have yet to fix that, I'm going to stop at Autozone tonight to find out what code it's throwing. I only paid 60 bucks for it, so I wasn't expecting much, although being that it's wayy better than stock, I will be investing in a quality one soon. My inspection isn't up until December, so I have plenty of time to get it resolved.
lets_FOCUS is offline  
    Reply With Quote
Old 04-26-2010, 04:04 PM   #35
aTm Beaner
Focus Addict
 
aTm Beaner's Avatar
 
Join Date: Apr 2005
Fan#: 21542
Location: Del Valle, TX
What I Drive: 2005 Ford Focus ST

Posts: 1,089
FF Reputation: 5 aTm Beaner Good Standing Member
Buy-Sell-Trade Rating: (6)
CAI FTW!!! UNLESS you live in an area that is prone to flooding like my Houston members.
__________________
TEAM DURATEC #512 ST CREW #100
2005 Ford Focus ZX4 ST
Focus Sport Cool-Flo v.1, Focus Racing Cat-Back w/ Magnaflow HFC, F2 Header, Focus Sport Tune 93 Octane, Saleen Suspension Kit, Rota Slips 16x7
aTm Beaner is offline  
    Reply With Quote
Old 04-28-2010, 05:27 AM   #36
lets_FOCUS
Focus Enthusiast
 
lets_FOCUS's Avatar
 
Join Date: Feb 2009
Fan#: 62632
Location: Cheektowaga, NY
What I Drive: 2003 Silver ZX3

Posts: 134
FF Reputation: 1 lets_FOCUS Good Standing Member
Buy-Sell-Trade Rating: (1)
So I went to have my car checked to find out what my check engine light was on for, and it said all 3 of my O2 sensors were bad, and that my engine was running too lean!! This is ridiculous! I can't afford to replace all those, is there a chance it has to do with the intake rather than the sensors themselves? I can't imagine it being anything else, I mean how would they all go at once??
lets_FOCUS is offline  
    Reply With Quote
Old 04-28-2010, 12:00 PM   #37
sailor
"Elder"
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 13,399
FF Reputation: 67 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Posted via FF MobileIntake - try cleaning maf, rechecking connections & resetting computer B4 chucking it for now...
sailor is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Tags
cai , cold air , intake , short ram , sri
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:17 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.