HOW TO: IMRC Removal and Repair - Page 10 - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 04-26-2012, 04:16 PM   #91
shb5007
Focus Enthusiast
 
Join Date: Aug 2008
Fan#: 58683
Location: USA
What I Drive: 04 SVT Focus

Posts: 207
FF Reputation: 1 shb5007 Good Standing Member
Buy-Sell-Trade Rating: (1)
I have the rattle can sound during start-up, does that mean mine is unfixable and I should just order a new IMRC?
shb5007 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 05-06-2012, 08:58 PM   #92
MVent
Focus Addict
 
MVent's Avatar
 
Join Date: Jan 2005
Fan#: 17635
Location: Moore, OK, United States
What I Drive: 2012 Focus Hatchback SE

Posts: 723
FF Reputation: 2 MVent Good Standing Member
Buy-Sell-Trade Rating: (1)
I wanted to clarify how to remove the wire from the mount since I've been getting very PO'd trying to figure it out.

Identify the cable as it runs between the battery box and the engine.

Reach down with your left hand and grab it.

Turn the cable so that the two tabs that need to be compressed are sitting at 12 and 6, straight up and straight down.

Take a flat head screw driver and press down on the top tab while gently pulling back on the cable. ( Back meaning pull it towards the front of the car.)

Depressing the one tab allowed it to slip out partially and the bottom tab just folded all the way flat and the cable pulled out.

Honestly I could see this breaking the bottom tab on some brittle plastic so If you can fit some flat needle nose, regular needle nose will not fit, to compress both sides, that should work even better.
__________________
2003 Focus SVT - SOLD
2012 Focus SE Hatchback
MVent is offline  
    Reply With Quote
Old 07-16-2012, 06:00 PM   #93
LiciouzSVT
Focus Addict
 
LiciouzSVT's Avatar
 
Join Date: Feb 2011
Fan#: 83568
Location: Tacoma, WA
What I Drive: 2013 Performance Blue ST

Posts: 566
FF Reputation: 1 LiciouzSVT Good Standing Member
Buy-Sell-Trade Rating: (6)
Thanks for this write-up! Had no idea it was this simple until I read this!!!
__________________
2003 Screamin' Yellow SVT - Wrecked
2004 Silver SVT- Sold
2013 Performance Blue ST- BEASTY
LiciouzSVT is offline  
    Reply With Quote
Old 08-05-2012, 09:52 PM   #94
rthurston57
Focus Rookie
 
Join Date: Jun 2011
Fan#: 87077
Location: Boston, MA
What I Drive: 2003 Black SVT

Posts: 4
FF Reputation: 1 rthurston57 Good Standing Member
Buy-Sell-Trade Rating: (0)
My IMRC has been broken since last fall; I pulled it out in late November and have been driving around with it removed up until yesterday, 8/4/2012. The only reason I replaced it is because I was sick of looking at the Check Engine light on the dash. But I wanted to comment that since I replaced it yesterday, and have put over 100 miles highway miles on it and another 20-30 city miles, I don't notice any difference, other than the Check Engine light isn't on anymore. It doesn't feel anymore responsive at high or low speeds or rpms. Hopefully I notice my mpg increase, because I did notice a dip of about 4mpg when it stopped working. We will see. Did anyone else notice little to no difference when there IMRC wasn't functioning?
rthurston57 is offline  
    Reply With Quote
Old 08-05-2012, 11:29 PM   #95
Sniper Focus
Focus Addict
 
Sniper Focus's Avatar
 
Join Date: Mar 2011
Fan#: 84221
Location: IL, IL
What I Drive: '03 SVT EAP "Eurotrish"

Posts: 1,195
FF Reputation: 20 Sniper Focus Great Standing Member
Buy-Sell-Trade Rating: (13)
^^^Maybe you're not driving it hard enough. Mine ran like a turd one morning so I put the scanner on and found a pending IMRC code, the light hadn't even officially come on yet. I fixed my IMRC that day and its been fine ever since.
__________________
'03 SVT EAP "Eurotrish Bennett"
Sniper Focus is online now  
    Reply With Quote
Old 08-06-2012, 01:31 PM   #96
stromberg2
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57480
Location: Monroe, United States
What I Drive: 2003 Red SVT

Posts: 81
FF Reputation: 1 stromberg2 Good Standing Member
Buy-Sell-Trade Rating: (1)
^^^
How did you fix it?

Stromberg2
stromberg2 is offline  
    Reply With Quote
Old 08-06-2012, 02:47 PM   #97
Sniper Focus
Focus Addict
 
Sniper Focus's Avatar
 
Join Date: Mar 2011
Fan#: 84221
Location: IL, IL
What I Drive: '03 SVT EAP "Eurotrish"

Posts: 1,195
FF Reputation: 20 Sniper Focus Great Standing Member
Buy-Sell-Trade Rating: (13)
Quote:
Originally Posted by stromberg2 View Post
^^^
How did you fix it?

Stromberg2
Just like in this thread.

There's a different repair thread floating that says to flow some fresh solder on the two large contacts in red. The solder can crack and cause the same code. So I did both repair write ups.
__________________
'03 SVT EAP "Eurotrish Bennett"
Sniper Focus is online now  
    Reply With Quote
Old 08-06-2012, 03:03 PM   #98
SVTF 03
Focus Enthusiast
 
SVTF 03's Avatar
 
Join Date: Jun 2012
Fan#: 99859
Location: Plymouth, MI
What I Drive: 2003 Pitch Black SVT EAP ZX3

Posts: 472
FF Reputation: 1 SVTF 03 Good Standing Member
Buy-Sell-Trade Rating: (5)
I tried all the fixes. Unfortunately they didn't work. Had to go with new.
SVTF 03 is offline  
    Reply With Quote
Old 08-06-2012, 04:12 PM   #99
SvviftSVT
Release the Kraken!!
 
SvviftSVT's Avatar
 
Join Date: Aug 2008
Fan#: 58277
Location: Houston, TX
What I Drive: Green-Eyed 2004 Black SVT #0461

Posts: 13,812
FF Reputation: 9 SvviftSVT Good Standing Member
Buy-Sell-Trade Rating: (6)
Was the plastic wheel broken at all?
__________________
TeamFOCALIZE!// HATCH NATION #45// October '12 ROTM

Track build will commence by Christmas (hopefully)
SvviftSVT is online now  
    Reply With Quote
Old 08-11-2012, 08:57 AM   #100
michael1199
Focus Rookie
 
Join Date: Jul 2009
Fan#: 67491
Location: essex, United Kingdom
What I Drive: 2003 silver st170

Posts: 15
FF Reputation: 1 michael1199 Good Standing Member
Buy-Sell-Trade Rating: (0)
sorry to jump into this old thread but i have lost the spring which goes inside the DSI clip,

Anyone know where i can find one?

Thanks

Michael
michael1199 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Tags
dsi imrc

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:31 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.