Air bag warning light... - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-19-2010, 10:12 AM   #1
Aaflac
Focus Rookie
 
Join Date: Jan 2010
Fan#: 72246
Location: Illinois, IL
What I Drive: 2000 Blue SE

Posts: 10
FF Reputation: 1 Aaflac Good Standing Member
Buy-Sell-Trade Rating: (0)
Air bag warning light...

The airbag light on the dashboard normally shuts off after starting the car, but, a few days ago it stayed on, and will not shut off.

Any risks associated with this? Could the airbag deploy without warning? Could the car shut down while going down the road? Will it damage anything to leave the light on?

Thanks in advance for your help.

Have a great week!!!


Aaflac is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2010, 01:01 PM   #2
stan170
Focus Jr. Enthusiast
 
Join Date: Oct 2006
Fan#: 39944
Location: Kirkcaldy, United Kingdom
What I Drive: 2003.magnum grey.ST170

Posts: 25
FF Reputation: 1 stan170 Good Standing Member
Buy-Sell-Trade Rating: (0)
SRS Fault Codes
Fault codes are flashed by the airbag light. A single flash with a few seconds between it is Code 1. A double flash and a pause is code 2 and so on. The codes are as follows:
1 Flash Drivers airbag failure - or open circuit to airbag (check Mylar clock spring connection)
2 Flashes Passenger Airbag failure - or open circuit to airbag
3 Flashes Failure of both airbags
4 Flashes Pyrotechnic seatbelt pre-tensioner failure (Either side)
5 Flashes Drivers airbag failure - System shorted
6 Flashes Passenger airbag failure - System shorted
7 Flashes Drivers crash sensor failure
8 Flashes Passenger crash sensor failure

The most common failure is code 1. It looks as if the light is simply flashing on and off, but if this is seen the driver’s airbag Mylar connector should be checked for security. After disconnecting the battery and waiting at least 15 minutes the airbag can be removed from the steering wheel by undoing the Torx screws through the rear of the steering wheel lifting the airbag off and checking the multiplug on the clock spring because this can work loose. Reconnect and reinstall the airbag fully before reconnecting the battery.

Any help to you ,taken from uk spec ford .Think the codes would be the same?not heard of the light staying on constant .
stan170 is offline  
    Reply With Quote
Old 01-19-2010, 08:23 PM   #3
Aaflac
Focus Rookie
 
Join Date: Jan 2010
Fan#: 72246
Location: Illinois, IL
What I Drive: 2000 Blue SE

Posts: 10
FF Reputation: 1 Aaflac Good Standing Member
Buy-Sell-Trade Rating: (0)
Thank you for the reply, stan170.

The airbag light on the dashboard will not shut off. However, it is not flashing.

Would appreciate knowing if anything will be damaged if the airbag light on the dashboard is left on?

Thanks for your help.
Aaflac is offline  
    Reply With Quote
Old 01-19-2010, 09:02 PM   #4
Demon09
Focus Enthusiast
 
Demon09's Avatar
 
Join Date: Jan 2010
Fan#: 72257
Location: Chicago, IL
What I Drive: 2007 Black ZX4 SES w/ SAP

Posts: 81
FF Reputation: 1 Demon09 Good Standing Member
Buy-Sell-Trade Rating: (0)
Mine is doing the same thing. I checked the connectors under the seats, got nothing there, the light is still on solid. Also took a look at the fuses under the dash, no luck there either.

I did the odometer test mode, it showed 2 (possibly 3 codes). The first is 9318 (low battery voltage). I had the battery checked at a very good battery center, they said its all good, alternator is good too, so maybe that's an old code.

The second code (I can't find what it is anywhere) was 9868.

The last one (not sure if its really a code at all) looks like its d900.

After I got the battery checked the light went off, but I'll see tomorrow if it comes back on after I drive it to work.

So far I'm stumped as to what the airbag deal is. If worse comes to worst, I may just take it to a dealer.
Demon09 is offline  
    Reply With Quote
Old 01-19-2010, 09:36 PM   #5
Aaflac
Focus Rookie
 
Join Date: Jan 2010
Fan#: 72246
Location: Illinois, IL
What I Drive: 2000 Blue SE

Posts: 10
FF Reputation: 1 Aaflac Good Standing Member
Buy-Sell-Trade Rating: (0)
Demon09, thanks for the info.

Was the battery disconnected when it was checked?

Sure hope it does not come back on for you!
Aaflac is offline  
    Reply With Quote
Old 01-19-2010, 10:21 PM   #6
Demon09
Focus Enthusiast
 
Demon09's Avatar
 
Join Date: Jan 2010
Fan#: 72257
Location: Chicago, IL
What I Drive: 2007 Black ZX4 SES w/ SAP

Posts: 81
FF Reputation: 1 Demon09 Good Standing Member
Buy-Sell-Trade Rating: (0)
No, I did disconnect the battery for 15 minutes on Sunday, but the light came back on later.

Today when they tested the battery, first they did an alternator test with the engine on, then shut it off and tested the battery itself, but never disconnected anything.
Demon09 is offline  
    Reply With Quote
Old 01-20-2010, 11:46 AM   #7
montum_81
Focus Jr. Enthusiast
 
Join Date: May 2009
Fan#: 65027
Location: canada
What I Drive: 2009 red focus coupe

Posts: 34
FF Reputation: 1 montum_81 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Demon09 View Post
Mine is doing the same thing. I checked the connectors under the seats, got nothing there, the light is still on solid. Also took a look at the fuses under the dash, no luck there either.

I did the odometer test mode, it showed 2 (possibly 3 codes). The first is 9318 (low battery voltage). I had the battery checked at a very good battery center, they said its all good, alternator is good too, so maybe that's an old code.

The second code (I can't find what it is anywhere) was 9868.

The last one (not sure if its really a code at all) looks like its d900.

After I got the battery checked the light went off, but I'll see tomorrow if it comes back on after I drive it to work.

So far I'm stumped as to what the airbag deal is. If worse comes to worst, I may just take it to a dealer.
i got same problem with you but the difference is it the ENGINE CHECK SOON wont turn off for a reason its just in solid orange, so i brought it to my dealer for service and they say nothings wrong with my car because they complimentary check all the posibility and scan it in their comp, they just reflashed my electronincs system and its all good now, im not saying that it might answer your problem in that way too but theres no harm for trying it. its just my opinion man!
montum_81 is offline  
    Reply With Quote
Old 01-20-2010, 02:35 PM   #8
mtadd162
Proudly Daily Driven
 
mtadd162's Avatar
 
Join Date: Jun 2007
Fan#: 47890
Location: Massachusetts, Afghanistan
What I Drive: 2005 Focus ST

Posts: 2,255
FF Reputation: 9 mtadd162 Good Standing Member
Buy-Sell-Trade Rating: (5)
well i dont know if it would the same problem with you but on my 05' i had the same issue, air bag light came on and stayd on...never blinked...and i got it checked and replaced under warranty, it was a "pretensioner" dont know what it is, but hopefully that can point you in the right direction
__________________
05 Focus ST-Sold but missed
-ST Crew #73 N/A FTW!
Feb. 09' ROTM
SSR - Silver Sedan Revolution Member #1
Cams Installed, great made my car into a VTAK
mtadd162 is offline  
    Reply With Quote
Old 01-20-2010, 04:22 PM   #9
goinloco1
Late for Dinner
 
goinloco1's Avatar
 
Join Date: May 2004
Fan#: 8529
Location: Aberdeen, SD
What I Drive: 13 stang

Posts: 15,223
FF Reputation: 90 goinloco1 Excellent Standing Member
Buy-Sell-Trade Rating: (2)
quick question, does your cruise and horn work? if one of them (especially the cruise) doesn't, the clock spring is bad which will also light the airbag light since the one on the steering wheel is disconnected.
This is what mine was and what I discovered the problem was
goinloco1 is offline  
    Reply With Quote
Old 01-20-2010, 08:18 PM   #10
Aaflac
Focus Rookie
 
Join Date: Jan 2010
Fan#: 72246
Location: Illinois, IL
What I Drive: 2000 Blue SE

Posts: 10
FF Reputation: 1 Aaflac Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks, everyone, for all the info.

The horn does work. As far as the CC, have not checked it recently. Will do so and see if it still works.
Aaflac is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:31 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.