Customer Service? Thats questionable. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Marketplace > Vendors, Dealers & Seller Reviews

Vendors, Dealers & Seller Reviews Good or Bad dealings? Post your vendor, dealer or seller recommendations, feedback and comments here. Members who knowingly post false or malicious information will be banned from the site.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Closed Thread
 
Thread Tools Display Modes
Old 11-09-2009, 10:13 AM   #1
Tantalus
Focus Addict
 
Tantalus's Avatar
 
Join Date: May 2007
Fan#: 47203
Location: Epsom, NH, NH
What I Drive: 2005 CD Silver ZX3

Posts: 868
FF Reputation: 48 Tantalus Great Standing Member
Buy-Sell-Trade Rating: (5)
Customer Service? Thats questionable.

(If anyone feels this should be moved to the vendor reviews section, please do so).

It's time that my dealings with HTP went public. I have kept them on the down low in an attempt not to mar HTPerformance's credibility. At this point though, I am fed up with driving a car that isn't doing what it is supposed to.

Currently, the cams that they installed are WAY off. The car runs similar to how a friends focus did with similar cams that were mistimed close to 20 degrees. (Not to mention my car made 112whp/128wtq with a perfect 13.4-13.5 AFR) The clutch (an Exedy Stage II) doesn't have enough clamping force to take a hard 1-2 shift from a car that makes 128wtq and 112whp. Wait, what? Thats right, a clutch rated for 300wtq can't handle 128 ft lbs of torque. It's not a breakin issue, because the clutch occasionally does grab (and when it does, it knocks your teeth out). There was an issue somewhere along the installation line.



But lets start at the beginning.

July 6th, 2009- Dropped 2005 Ford Focus ZX3 and 2.0L Duratec engine with 27k miles off at HTP Facility @ 10:45 am. Car had FRPP 2.3L Head, Crower StgII FI cams, SCT Xcal2, J&S Safeguard, SPC Camber bolts, and 2 new lower control arms in the trunk. Paperwork was agreed upon and signed for, install of FocusSport/FSWerks header, flex-pipe, 2.5in Full race exhaust, motor swap, head install, cam and cam gear install, Exedy STGII Clutch and Flywheel combo install, Prothane rear poly bushings install, and Quaife ATB install. Price was set, agreed upon, and signed for. Car was to be done 4 days later, on July 10th.

July 7th, 2009- Spoke with Jason at HTP over AIM. He had yet to start work on the car. Discussed doing and SVT front brake conversion, and confirmed it later that day. Price was set and agreed upon.

July 9th, 2009- Contacted HTP for an update on the car. The head gasket they were asked to order over a month ago had never been ordered. They had one overnighted from Tousley Ford. They also had bearings and seals overnighted, and told me that they would cover both the shipping costs, and the cost of parts.

July 10th, 2009- Spoke with HTP. The head gasket, and transmission parts were sent to their old address. At about 7:30 PM I was told they were starting work on the car, after finally tracking down the parts. They assured me the car would be complete, and delivered for 8AM Saturday (7/11/2009) morning in time for my appointment with my tuner. At the time I talked to them, they were about to put the head back together, then finish up the transmission, and put the brakes on.

July 11th, 2009- Contacted HTP over AIM at about 5:30/6 am. I was told the car would not be done, as they hit a snag. The pin for the timing chain guide was missing from the FRPP 2.3L head. They could not proceed. They informed me that the part would be ordered first thing Monday morning. Had to cancel my appointment with my tuner for 8 am.

July 13th, 2009- Contacted Jason at HTP via text message. I was informed he was having difficulty getting a part number, but not to worry. Said he was making phone calls and would get it ordered.

July 14th, 2009- Called HTP shop phone at about noon, having heard nothing from them. Talked to Brian. They had still not ordered the part. I immediately called Tousley Ford, explained what I needed, and got a part number. Called Brians cell after texting Jason the part number. Jason answered, told me that they had already ordered the part. Thats odd, I had JUST been told they hadn't ordered it yet. Different part number. It should be there 7/15/2009.

July 15th, 2009- Jason called and left a voicemail telling me that the part they had ordered from the dealership was not the correct part. Dealer ordered the wrong part. Told me he thought they now had the right part on order, and that it would be there either Thursday (7/16/2009) or Friday (7/17/2009).

July 17th, 2009- Contacted Jason, he said he had the part around noon. Told me the car would be running Saturday morning.

July 18th, 2009- Sent Jason a text message around noon. No response. Called the shop at 4, Brian answered. I was told that they were putting the transmission together, and were about to do the brakes. Seems like I was told this was already done. Said it should be running within a few hours. Heard nothing, called the shop phone at 10:09 pm. No answer. Called Jason's cell phone, he answered. Told me they were going to stop working on the car at 11 PM. It was still not complete, and not running. Still had quite a bit of work to do. Was told the car would be running Sunday morning.


(The above was from a detailed log I had kept up showing every interaction I had with them. To be honest, after what happened the next day, I kind of just gave up on the whole situation.)

What happened next is I went down there to pick the car up. Upon arriving, the car still wasn't complete, and hadn't been fired yet. After an hour of work, it was ready to go. Crank it over...oh wait, theres a bolt missing in the head by the power steering pump. Car shoots oil out of the head. They pull the front clip back apart, get the bolt back in (a few hours later) fire it up. Lots of valvetrain noise. And I mean LOTS. We take it for a test drive, seems okay. Still everyone questions the valvetrain noise. Jason and Brian say I should be good to go, could just be the new head.

Turns out they never checked for valve clearance. Now, I'm not an engine builder, but when you install an aggressive set of cams you would check for valve clearance before putting everything back together, correct? Well, they didn't. The 2.0 block with 27k on it blew up 5 miles down the road. The block, head, and valves ended up all being junk.



It took us about a week to agree upon a new course of action. We agreed to swap the 2.3L Duratec with 8k miles out of Brians car and into mine. After 4 or 5 days, they decided they were going to source a 2.3 engine from a junkyard for me (would have preferred the running, working, 2.3 out of Brians car like I had been told I was getting.).

Long story short, as I'm sure you are all sick of reading this by now. When they finally got the 2.3 installed and running in my car, I went down and picked it up. (This was I believe my 3rd or 4th trip down there at the time). When I got got up the next morning after driving home at 2 am, the entire front subframe was outlined in oil, there was oil dripping off the wheels, it was everywhere. I spent a few days trying to locate the leak, and to be honest it was coming from EVERYWHERE. I also found that one of the fuel injectorrs hadn't been seated properly, and was dumping fuel down the side of the block. Thats...safe. I fixed that, but could not locate the leaks (Having done this on my back under the car in my driveway). It was leaking from what appeared to be the rear main seal, and just about everywhere else.

They eventually agreed to have the car towed back down there, and fix the leak. Well, they fixed one bolt, 2 bolts, 3 bolts, said I was good to go. Come to pick up the car...still leaking. It was still leaking from the oil pan (where I told them it was coming from originally), and from somewhere else. Few days go by, I'm told it done and not leaking. Go to pick up the car again, am assured it's not leaking. Jason starts the car, and pulls it out of the garage...oh look, theres a huge puddle of oil. WTF. Car is STILL leaking, not ready to go home, and I'm on my 6th trip to a shop that is 230 miles away round trip.

Another week goes by, and it's finally done. I picked the car up, brought it home. Didn't leak, thankfully. For the next month I had to drive the car paranoid wondering what was going to break next, what else wasn't done correctly.

I dropped my car off on July 6th, 2009, fully expecting to get in back on July 10th, 2009, as promised. I received my car back in 'working' condition on September 5th, 2009, nearly TWO MONTHS after dropping it off. At the time this was my daily driver. The entire purpose of paying someone to do the work on this car was so It could continue being my daily driver.


Needless to say I was not pleased, satisfied, or anything in between. I am still not to this day, because work that I paid for was not done correctly. I have a $900 clutch that doesn't grab, and cams that are timed so poorly that my D23 with FRPP head and cams makes less power than a stock D20.


I called them after having the car dyno'd last Sunday, and left a message. Jason returned my phone call Monday, but I was at the hospital with a sibling and couldn't answer. I returned the call Tuesday, the line was busy. I called right back, and got no answer...so I left a message. Weird that no one is there to answer the call after the line was just busy, and it's 11am on a tuesday. It's now Monday of the next week, and I still have not received a phone call...which is why this is going public. If my car isn't going to run right, and I have to fix it myself, then people have the right to know exactly what you get when you deal with HTP.

Good day sirs.


__________________
2005 Ford Focus ZX3 D23 Swapped 5-speed
FSWerks Header, flex, 2.5" SS exhaust
Custom Ported 2.0L head, Stock cams w/ Crower springs/Titanium Retainers
Quaife ATB Differential, Exedy Stg II Clutch/Flywheel
Coming soon...
Tantalus is offline  
   
Sponsored Links
Advertisement
 
Old 11-09-2009, 06:00 PM   #2
jholso
Guest
 
Join Date: Oct 2008
Fan#: 59578
Location: Northern Fla. So North We Call it the NorthEast, FL
What I Drive: 08' S, I like Turtles

Posts: 1,235
FF Reputation: 6 jholso Good Standing Member
Buy-Sell-Trade Rating: (1)
I was wondering when this was going to finally come out.

At lease you did give them MORE than enough time to fix problem after problem, and are not jumping the gun on this review.
They need to fix your car.

I hope the car is up and runing right by spring Justin.
jholso is offline  
   
Old 11-09-2009, 08:03 PM   #3
Buickboy
br/o/stang
 
Buickboy's Avatar
 
Join Date: Oct 2005
Fan#: 28542
Location: Stratford, CT
What I Drive: 72 Skylark, '12 Mustang

Posts: 5,251
FF Reputation: 39 Buickboy Great Standing Member
Buy-Sell-Trade Rating: (29)
. sounds like they got in way over their heads. hope this gets set right for you
__________________
==2012 Kona Blue Mustang V6==
==1995 Light Iris Neon Coupe==
==1972 Skylark==
Buickboy is offline  
   
Old 11-09-2009, 09:59 PM   #4
svt3d
Focus Jr. Enthusiast
 
svt3d's Avatar
 
Join Date: Jun 2008
Fan#: 56887
Location: Washington, United States
What I Drive: 2004 E4 ZX3 SVT

Posts: 37
FF Reputation: 1 svt3d Good Standing Member
Buy-Sell-Trade Rating: (1)
WOW! I dont even know what to say!
__________________
The Red Army!
04 E4 ZX3 SVT
#450 of 1978
svt3d is offline  
   
Old 11-09-2009, 10:05 PM   #5
FocusVet
I'm Back!
 
FocusVet's Avatar
 
Join Date: Dec 2006
Fan#: 41812
Location: Cincinnati, Ohio, OH
What I Drive: '03 Twilight Blue Sedan-D23E

Posts: 2,304
FF Reputation: 19 FocusVet Great Standing Member
Buy-Sell-Trade Rating: (9)
hmm...not good at all.
__________________
TEAM DURATEC # 074 / SEDAN REVOLUTION #001
FocusVet is offline  
   
Old 11-10-2009, 12:44 PM   #6
drosado15
Focus Enthusiast
 
Join Date: Mar 2009
Fan#: 63457
Location: Pompano Beach Florida, FL
What I Drive: 01 Black zx3, 06 Pearl White Titan

Posts: 521
FF Reputation: 3 drosado15 Good Standing Member
Buy-Sell-Trade Rating: (0)
Wow, I would just call a lawyer and ask for money back on that one. Lets see what HTP has to say about this.
drosado15 is offline  
   
Old 11-10-2009, 08:29 PM   #7
05yellowd20
Banned
 
Join Date: Feb 2009
Fan#: 62464
Location: Reading, PA, PA
What I Drive: 2005 Yellow ZX3 2.0 Duratec

Posts: 3,665
FF Reputation: 15 05yellowd20 Great Standing Member
Buy-Sell-Trade Rating: (4)
I rarely find myself in this state but i am truly speechless......
05yellowd20 is offline  
   
Old 11-10-2009, 08:39 PM   #8
roosterst
фанатик
 
roosterst's Avatar
 
Join Date: Dec 2008
Fan#: 61461
Location: Somewhere, PA
What I Drive: '05 CD silver ZX3 ST

Posts: 5,054
FF Reputation: 77 roosterst Excellent Standing Member
Buy-Sell-Trade Rating: (14)
Quote:
Originally Posted by 05yellowd20 View Post
I rarely find myself in this state but i am truly speechless......
Me too.
__________________
FR valvebody, 91 tune = 16.296 @ 84.08mph
roosterst is offline  
   
Old 11-10-2009, 08:54 PM   #9
drosado15
Focus Enthusiast
 
Join Date: Mar 2009
Fan#: 63457
Location: Pompano Beach Florida, FL
What I Drive: 01 Black zx3, 06 Pearl White Titan

Posts: 521
FF Reputation: 3 drosado15 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by roosterst View Post
Me too.

Same Here.

I just can't believe they blew a effin motor. That's what gets me out of all of that. I can understand the car the taking longer then usual to get fixed but Blowing a motor......................... Speechless as well. As i stated earlier Wanna see someone from HT chime in on this. I believe the op this is not the first time i've heard someone complain about HT
drosado15 is offline  
   
Old 11-10-2009, 08:59 PM   #10
misfire
Moderator
 
misfire's Avatar
 
Join Date: Jan 2006
Fan#: 31379
Location: West Chester, PA
What I Drive: 2012 SEL Hatch, 2014 Mazda CX-5

Posts: 16,048
FF Reputation: 31 misfire Great Standing Member
Buy-Sell-Trade Rating: (13)
wow! im sorry to hear this
__________________
Will aka Misfire
2010/2011/2012/2013 Ford Master Certified Service Advisor
2003 LX "traded in"/2010 SES "traded in"/2012 SEL Hatch "current"
misfire is offline  
   
Closed Thread

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:18 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.