Beware of BLAAST PERFORMANCE Turbo Rebuilding! - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Forced Induction

General Forced Induction The place to chat about turbochargers, superchargers nitrous systems and custom engine fabrications.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-13-2009, 10:57 PM   #1
95dc2teg
Focus Rookie
 
Join Date: Sep 2009
Fan#: 69081
Location: tampa, FL
What I Drive: 2000 red zx3

Posts: 8
FF Reputation: 1 95dc2teg Good Standing Member
Buy-Sell-Trade Rating: (0)
Beware of BLAAST PERFORMANCE Turbo Rebuilding!

Hello Focus Fanatics!

I would just like to share a big problem I had with http://blaastperformance.com/ turbo rebuilding. I have had them rebuild one of my cheap ebay turbos a while back and everything was great, turbo did an awesome job, sold it and as far as I know is still running strong. I decided to go with them again to rebuild my Precision SC6176e. There rebuild prices for named brand turbos such as Precision, Garrett, etc are $190 which includes the shipping fee for when they ship back. Isn't to bad of a price right? Well after they received it I had to pay another $190 for parts, such as a new center cartrage, 360 thrust bearing etc. Which wasn't to big of a deal and I sort of expected that. Finally, it was shipped back to me.

This first thing I noticed which kind of bothered me was the packaging. It was shipped back in the same box that I had use to ship it to them and it was pretty beat up and half ripped open. They also stated that they were going to send me my old parts so I can "appreciate" how messed up they were. There was no old parts in the box. Not sure if it fell out since the box was half torn open, or that they just didnt bother on putting the parts in the box.

The next thing I noticed was that the new center cartridge now had a 1/4npt hole for the feed instead of the original 1/8npt, which meant I couldn't use my oil restrictor that I had because it was 1/8npt. Again not a big deal as I just went to home depot and got a 1/4 to 1/8npt adapter.

Here are a couple of pictures of the turbo when I got it. Unfortunately I don't have any pictures of the box.












Looks good right? Well looks can definitely be deceiving. After it was installed, the first stop was the gas station. I then drove to my parents house to pick up a couple of things. Everything is fine with the car, just taking it easy. I notice the oil return is leaking a little bit so I went back home and used some hi temp silicone for temporary use until I could get another gasket. Small oil leak was now fixed.

I head back to my parents house, and do a quick second gear pull. The wastegate is set at 7psi. The car moves very well! I pick up some more things from my parents house and head back home. I do another quick second gear rip. RIGHT after the pull, I hear this constant noise like something is loose and rattling. I pull over leaving the car running and pop my hood to check it out. I can still hear it and think that it could be the crank pulley bolt had come loose and the big washer is just rattling around so I shut the car off. But as I do that and the engine is off I still hear the noise faintly. I quickly look back at the engine bay and notice the turbo is still spinning and noise was coming from there!

THE NUT AT THE END OF THE COMPRESSOR WHEEL WAS GONE! I take a cloth, and touch the turbo wheel and notice that the wheel has a noticeable amount of shaft play and the noise I was hearing was the compressor wheel hitting the housing. Need less to say the wheel where it was touching the compressor housing is now grounded now the wheel is now ruined. Here are some pictures of the compressor housing and compressor wheel all chewed up:



















Here is a video that I made that shows how much Shaft play had formed after two pulls:


Obviously something internally had messed up causing this to happen. Now the turbo is in worse condition than before I shipped it out to them and spent $430.




This is Where the emails begin.

Email from me to BlaastPerformance:


"Hello there. I finally received my turbo this passed Friday the 14th of August. When I got the package it was pretty beat up but the turbo was packaged well and it looked great! I was, although, disappointed that it did not come with any of the old parts to see how bad it was, like you said it would. I installed it today. I drove around for awhile, got gas, and everything was fine. I hit boost, only 7psi (thats what my wastegate spring is) because I have a brand new clutch that im breaking in. After the second pull (2nd gear) I hear a rattling noise. I drove for a mile and noticed it was still there. I then pulled over and popped the hood with the car on. I could still faintly hear it but could not find where it was coming from. I turned the car off and even though the engine was still on i could hear it. I noticed that the noise was coming from the turbo as it was still spinning. Once it stopped, I noticed that the nut on the end of the compressor wheel was GONE! I then took a cloth so I would not burn my had and noticed that there is a lot of shaft play and the noise was the compressor wheel RUBBING the housing! I was so excited to have the car running only to be very disappointed that this has happened. I have taken the turbo off and inspected it and noticed that the wheel is now ruined/grinded down because it had rubbed the housing. It is now worse than it was before I send it in to you, with the wheel now ruined. I hope that you will take care and cover the cost of fixing (labor/parts included) what ever caused the shaft to have play and the price of the new wheel it will need because of this. This should not have happened at all, and I am very disappointed. Please get back to me and what is going to be done about this I will be also give you a call tomorrow to talk to you personally about this. Thank you."




Blaastperformance Reply:



"It's very disapointing for us as well too ear about such turbo failure!

If the box was beat up on receipt of the turbo, please, if it's not too late, send pictures of the damaged box and also did you notice any sign of shipping related impact on the turbo itself such as fresh dents or pucks? pictures of all that would be appropriate in case we need to file an insurance claim with the postal services.

it's rare to see a shaft nut fall off but when they do, it's because of a sudden stop of the rotating assembly. in such case, even if this nut is designed by garrett not to loosen in operation, it may get unscrewed by the inertia of the rotating assembly as it decelerates violently.

Sure, you can return your turbo for warranty inspection.
while your turbo had all new internals and was balanced and assembled as per applicable specs, we will investigate the cause of this sudden clogging of your turbo. Yes, our warranty terms are very allowable and clear: when a turbo is found defective, the replacement internals (bearings, seals, thrust parts) and the labor are covered under warranty. As for the impellers, not only they aren't covered under warranty but we carry only garrett impellers, not precision ones. Although we may find a suitable replacement garrett impeller that fits your pte turbo. It's hard to confirm that up front since we didn't keep on file the exact size of your impeller."



At this point I am kind of pissed off because it seems to me that they aren't going to be covering the compressor wheel. I reply with another email saying:



"I will be shipping out the turbo tomorrow Via UPS. I had to save up some money for shipping costs again. I do however, have a couple of questions and statements about the last email I received from you. The first question I have is regards to this statement:

"it's rare to see a shaft nut fall off but when they do, it's because of a sudden stop of the rotating assembly. in such case, even if this nut is designed by garrett not to loosen in operation, it may get unscrewed by the inertia of the rotating assembly as it decelerates violently."

After hearing the noise of the wheel rubbing the compressor housing, I have a pretty good idea that the reason why the nut fell off was because something inside the center cartridge became loose or broke causing the blades to hit the housing causing it to decelerate violently. Wouldn't this most likely be the reason??

Another idea related to this statement:
"we will investigate the cause of this sudden clogging of your turbo."


I believe the clogging of the turbo was because because of the impellers hitting the housing because of the shaft play causing it to suddenly and violently stop.

And my last and final question was about this statement:

"As for the impellers, not only they aren't covered under warranty but we carry only garrett impellers, not precision ones. Although we may find a suitable replacement garrett impeller that fits your pte turbo. It's hard to confirm that up front since we didn't keep on file the exact size of your impeller."

Does this mean the impellers are not covered even though the work that was provided by you some how messed up and caused the turbo have shaft play and impellers to hit the housing?? I feel since the impellers being ruined was directly caused by the work that was done on the turbo that they should also be replaced free of charge (parts/labor) since they were fine before and now are ruined.


I am sorry about all the questions and inquiries but I hope you understand that I am very frustrated at this whole ordeal. This has turned out to be such a hassle, and quite frankly as of now, a waste of money and time since it has cost me $430 to get the turbo rebuilt, plus the cost of shipping it back again (another $60), 2 months of waiting, AND now it is worse off than it was before I sent it out to you guys the first time. Please let me know if the impellers will be covered, because I feel that they should be, because they are ruined from the direct cause of the work you did. Please get back to me and please work with me the best you can. Thank you!"


This is Blaastperformance's reply:


"Sorry again for the back and forth shipping. those are the inconvenients of dealing with a remote company.
Maybe you can keep the turbine housing at home to save a lot on shiping both ways since it makes 90% of the turbo's weight and we don't need it to fix your problem. Also, don'T forget to declare 15$ value on your turbo to avoid extra fees at the customs.

Sorry if we can't conclude as easily as you, and blindly, that improper work from our company caused the failure of your turbo at the second pull.
Since it was barely used, no wear had time to develop in your turbo. inspection is absolutely required to diagnose this faulure and rest assured, we have no problem recognizing an error. However, rest assured, we respect the same strict procedures for the rebuild and testing of all turbos and we do live by and respect the warranty terms applicable to your purchase.

To answer your concern, nothing can instantly come loose inside a t3 t4 turbo.
For sure, at the 2nd pull, the internals in your turbo were still brand new with no wear on them and the turbo had the same shaft play as when you received and installed it.
Of course the bearings and seals do wear over time, that's normal and when they do, the wheels will eventually start rubbing inside the housings, making noises and inconsistant boosting for a long period of time before it gets bad enough for the impeller to clog against the housing and cause the shaft nut to unscrew. When caused by shaft play, you can be sure such problem never happens instantly like you experienced.

Looking forward to receive and inspect your turbo. yes, as you can see, you are not by your own. You are getting all due customer service and support and regardless of the actual cause of your problems, we will keep helping you until everything works perfectly.
Thanks for your patience.



Have a nice day!"



I went head and shipped out the turbo on 8.24.09 via UPS and sent them an email stating:

"I do appreciate your reply! Thank you so much for working with me! I sent out the turbo today via UPS without the turbine housing. The tracking number is: 1z02813x681001*. I do have the pictures of the turbo so I can show what you should be expecting when you receive it. I also have a video of the shaft play that is in the turbo. Here they are:


http://s30.photobucket.com/albums/c3...ild%20Problem/



THIS WAS BLAASTPERFORMANCE REPLY:



"Thanks for the pictures and movies but they are not needed. We believe all your claims!

All we need to do is open and inspect the turbo to find what went wrong / what happened to it!

when we do, we'll let you know and send YOU pictures as needed."



THEY THEN SENT ME ANOTHER EMAIL STATING:


"looking at your pictures of the turbo before installation:

Those are the big 11 mm lock nuts from garrett and this one was torqued in loctite on top of that.
You may want to check the setting of your blow off valve.
Problems of unscrewing lock nuts have been seen mostly on cars without a blow off valve such as the buick grand national and such."



MY REPLY:

"I have the synapse engineering bov that was never touched when taking off the turbo etc. I could hear it clearly when the two pulls were done, so pressure was being relieved."



Here is a little update with the turbo rebuild and Blaast Performance. They received the turbo on Aug 28. After seeing that it was delivered and signed for, I sent them this email:

"Hello! I see that you have received the turbo today via UPS. It was much faster than USPS! Please let me know what you find out! Thank you so much!"


Today I check my email and there is a money request from Paypal for $157.49 for a replacement compressor wheel. This was in the "note" section of the paypal money request:

"Note:turbo rebuild wormanship under warranty........0$
new turbo internals under warranty....................0$
Replacement compressor wheel sc61........157.49$"

I never got an email stating what caused the compressor wheel to hit the housing, what caused the shaft play, etc. I got no feedback from them about what went wrong nor did I get any pictures that they said they would send in the previous email.


I SENT THEM THIS EMAIL:

"Hello, I got the paypal money request for the 157 for the compressor wheel. What was your diagnosis on the turbo? I never got any feedback."



THIS WAS BLAASTPERFORMANCE REPLY:

"yes we have received your turbo, inspected it and good news: except for the damaged compressor wheel, and the compressor cover that required some resurfacing to remove the scratches, everything is in good shape.
The bearings and seals don't show any sign of premature wear but they are being replaced anyways as part of the remanufacturing process that's 100% covered under warranty, same for the replacement lock nut that came off and the oversizing of the turbine piston ring land.

a Precision replacement compressor wheel is on order (157,49$ paypal invoice sent) so yYour repaired turbo will be ready to ship mid next week.

have a nice weekend.


Have a nice day!"



This statement right here: "except for the damaged compressor wheel, and the compressor cover that required some resurfacing to remove the scratches, everything is in good shape."

That statement is a bunch of bull. OBVIOUSLY everything wasn't in good shape or this would have never happened. There wouldn't have been a ridiculous amount of shaft play causing the compressor wheel to hit the housing. Also if everything is OK why would they replace the parts again?? Something definitely not making sense here. They know they messed up on the first rebuild causing the compressor wheel to hit the housing and be ruined and now dont want to pay for the new one, so they sent me that bull shit email.



After receiving that email from them saying that there was nothing wrong I sent them this email:

"
How can everything be in good shape? What caused the shaft play in the first place causing the blades to hit the compressor housing? Something doesn't make sense here. If everything was in good shape then none of this would have happened in the first place. Why did the compressor wheel hit the housing???"

**NEWEST EMAIL FROM THEM!**



"There was no shaft play in the first place. (as you certainly verified by yourself prior to install the turbo)
The wheel rubbed inside the housing only after the nut came off, which is 100% normal since the wheel was then free to come off the shaft and move forward, and it did.
As you have seen and pictured yourself, your impeller was scratched at it's base only, and not on the sides. same for the housing: not a single scratch on the sides, only at the base since the unbolted wheel was lifting from the backplate.
The damages to your impeller occured as you tried to perform more pulls after the turbo had started to show signs of problems.

One cause of such problem that we have seen before on such turbo is the red rubber seal that's between the backplate and the compressor cover: when you clock the compressor cover, if the 6 cover bolts aren't loosened enough, this rubber seal can bunch-up as you rotate the cover, making the compressor cover sit crooked on the backplate, which causes wheel to housing interference and impeller clogging. in the case of your turbo, we were not able to verify the occurrence of such problem since the cover was already removed by you on receipt of the turbo.
Even if your shaft had no wear, your center section had no wear, and the bearings had no wear either, all internals have been replaced again preventively, under warranty coverage and your turbo has zero shaft play again.
We are receiving the replacement wheel today, so the turbo will be ready to ship this afternoon, or on tuesday.

Thanks for your patience."


After reading that email I went ahead and gave them a call and had a good 20 minute conversation with them. I asked them if he even watched the video I made of the shaft play that it had. He replied with a we don't have time to watch a video. I told him but you can clearly see that side to side shaft play in the turbo in the video. He the says that since the nut fell off, the compressor wheel lifted and hit the housing. This is understandable I suppose. But then I asked so the nut holds the compressor wheel and the turbine wheel? Because in the video you can clearly see that both the compressor wheel and turbine wheel move together when moving side to side. He says yes. He then told me that the wheel is not covered in their warrenty because it was my original wheel. And sometimes, not saying that I did this, people just go ahead and beat on it even though they know its messed up because its covered under warranty. I ask well what if after time there becomes shaft play and the wheel gets ruined before the 6 month warrenty is up? He says that it is still not covered.

I am a little pissed. I guess im just going to have to eat the 157 dollars and just pay them. It *in sucks because this whole ordeal has cost me a total of $600 which is damn ridiculous!! I could have bought a new one for a couple hundred more and it could have been FULLY warrantied by Precision.


UPDATE:Alright, I decided to let them know about this thread I went ahead and sent them this email:

"Hello again. I have received the tracking number for my UPS shipment. Thank you. But to be honest, I am writing to you to inform you that I am very UNHAPPY about my over all experience with BlaastPerformance. Yes, your customer service was excellent BUT, I feel your warranty needs much MUCH more work. The fact of the matter is that ONLY 2 days after I received my turbo rebuilt by you, I ran it, boosted it TWICE and the nut fell off ruining my compressor wheel. This should NOT have happened. It definitely not the rubber o-ring around the compressor housing that caused this because as you saw when I shipped the turbo back it was all in one peice. If that rubber o-ring was bunched up it would have torn as it is very skinny. I feel that you should have held yourself responsible for the destruction of my compressor wheel, and therefore should have covered it the costs to replace it.

I also suggest you update your warranty statment on your website.

"BLAASTPERFORMANCE WARRANTY POLICY All items offered on this website are warrantied for 6 months from the date of purchase unless otherwise stated. Any DEFECTIVE item can be returned at customer's expense for a warranty inspection that is always FREE. Items that are determined to be DEFECTIVE and exempt from signs of abuse, neglect or tamper will be replaced or repaired for free (includes parts AND labor) and shipped back to the original purchase address only at our expense but any import/export fee remains at customer's charge."

No where in there does it say that compressor wheels are not covered. They are part of the turbo so why wouldn't they be, especially if the work that was originally done by you caused the destruction of it.

You stated that you do not have time to view the video I sent you of the turbo that clearly shows the whole shaft moving back and forth and not just the compressor wheel. I DO however hope you have the time to look at this thread that I made on honda-tech.com.

http://www.honda-tech.com/showthread.php?t=2637210

I have posted my story about what happened and how it was resolved. I have every email between you and I along with pictures AND the video in this thread on honda-tech.com. I just wanted to let you know that I posted my experience with Blaastperformance on this very busy site. From reading other people's reply to my thread, they seem to agree that as good business practice you should have replaced the compressor wheel free of charge. Please do not take this the wrong way, I feel like I was done wrong and now want to share with others so the same will not happen to them."

I am awaiting their response and maybe they will even chime in here and see what they have to say.....

UPDATE
They have not responded to the last email that I have sent to them and I have sent it twice now. I am assuming they do not care, which is fine, as I will be spreading the word about their business ethics on every major forum I can find.

I also went ahead and decided to file a claim with paypal, I mean why not? Apparently they replied to the claim saying that they blame me because "i clocked the turbo wrong and the little rubber gasket bunched up causing the compressor housing not to sit correctly therefore causing the wheel to hit the housing". Thats a bunch of *ing shit because that little gasket is so skinny that it would just have been torn if it was bunched up. I have escalated it to a claim with paypal because they declined my request for a refund. I will be keeping it updated.

UPDATE on paypal Claim

Paypal decided against me and hit me with this email:

"Our investigation into your claim is complete. As stated in our User
Agreement, the claims process only applies to the shipment of goods. It
does not apply to complaints about the attributes or quality of goods
received. Therefore, we are unable to reverse this transaction or issue a
refund. "

So im out the 157 dollars. I will definitely be working hard to spread the word about what I went through to steer people away from doing any kind of business with them. I can not believe that they blamed the destruction of my compressor wheel on me clocking the turbo wrong. I mean come on, that is so far fetched. They also said that I insisted on beating on which is why it got ruined. This is not true at all, as soon as i heard the noise i stopped, noticed the nut was missing, and got it towed home. There was no way of "saving" the compressor wheel once it came in contact with the housing, especially since they spin so damn fast, once the compressor wheel touched the housing at that speed it was already ruined.


UPDATE 9/12/09

Yesterday I received a call from the local UPS store here in town. Apparently when they shipped it back they charged the freight to the local ups stores account without their permission. The ups store declined the charge after I received my turbo and now I will be receiving a bill for $49 dollars. It only cost me $19 to ship it there!!! I had no idea that i was going to be charged for getting it shipped back as they didn't say that they were not going to cover it. Just another surprise from them! They wouldn't even pay for the shipping back to me.

UPDATE 9/15/09

I decided to send them this email, it hopes that they will finally reply to me:

"Thank you for shipping me the turbo back with freight charge upon receiving. This just gives me more of a reason to keep posting on different forums about your business."


Blaast Performance Reply:

"This was because you asked for a shipping service that we don't offer and you had already started your abusive and wrongfull cyber-bashing while your turbo, abused just like it was when you sent it the first time around, was still in here being repaired for free on our tap, not even under warranty but just to help you out.
You won't see any reply from us in your dirty campaign threads but everything is being printed out for future reference."

My Reply:

"You could have told me that you would not have covered the shipping charges when I asked you to ship via UPS, but instead you said nothing. Cyber-bashing? Is that a joke? I am not bashing at all in the threads that I have posted. The emails speak for themselves. If I were you, I would reply to them, as many people seem to agree with me, the customer. There is no lying in my threads and all the emails I have on these threads are copy and pasted from our conversations. No lying or bashing here, just simply stating the truth about how you conduct your business. I like how you state that it was not under warranty when I only had it for 4 days. You are in the wrong and you know it. That is why I suggest you take a look at the threads to at least tell your side of the story or try to atleast explain why your "right". I will even give you all the forums that I have posted our emails on.

Honda-tech.com
Teamintegra.net
Floridahondacrew.com
Preludepower.com
Preludeonline.com
mustangforums.com
clubrsx.com
Focaljet.com
Focusfanatics.com
z31performance.com"

Its funny how they say that it is wrong that I am posting this on forums and bashing them when I am only copy and pasting the emails back and forth and everyone seems to be agreeing with me that they should have covered the price of the compressor wheel. I feel that my write up on here and on other forums is not bashing or any kinds of lies. It is just a review of how they conduct their business. All I'm doing is letting people know. If people choose to still do business with them, so be it, that is fine, BUT im sure after they read this review, they will choose otherwise.

I have just looked at their website again and they have UPDATED their warranty information. I am sure it is because of this incident that they have done so!


Original Warranty Information:

Quote:
"BLAASTPERFORMANCE WARRANTY POLICY

All items offered on this website are warrantied for 6 months from the date of purchase unless otherwise stated. Any DEFECTIVE item can be returned at customer's expense for a warranty inspection that is always FREE. Items that are determined to be DEFECTIVE and exempt from signs of abuse, neglect or tamper will be replaced or repaired for free (includes parts AND labor) and shipped back to the original purchase address only at our expense but any import/export fee remains at customer's charge."
New Warranty Information:
Quote:
BLAASTPERFORMANCE WARRANTY POLICY

Items SOLD through this website are warrantied for 6 months from the date of purchase unless otherwise stated. Any item can be returned at customer's expense and risk for a FREE warranty inspection. Items that are determined to be DEFECTIVE and exempt from signs of abuse, neglect or tamper will be repaired or replaced for free and shipped back to the original purchase address only, at our expense. Any applicable import/export fee remains at customer's charge. Non-defective or abused/negleceted/tampered items will be returned at customer's expense.

Turbochargers SERVICED through this website are warrantied for 6 months from the date of service purchase unless otherwise stated. Turbochargers subject to premature wear or failure during the warranty period can be returned at customer's expense and risk for a FREE warranty inspection. Turbochargers that are determined to be DEFECTIVE and exempt from signs of abuse, neglect or tamper will be repaired for free (All workmanship AND replacement internals are covered) replacement impellers and housings excluded. Warrantied items will be returned at our expense. Any applicable import/export fee remains at customer's charge, Non-defective or abused/negleceted/tampered items, repaired or not, will be returned at customer's expense.
Definitions:
Neglect: Items that show signs of improper maintenance or installation (Example: Turbos that show signs of oil starvation such as melted/burnt internals, shafts discolored by overheating, impellers with blades damaged by foreign objects, Improper clocking of turbo housings, presence of welding projections on impellers or inside housings, presence of silicone/urethane cauking inside oil passages or between housings unless specified by manufacturer ... )
Abuse: Items which design capacities have been exceeded. (Example: Customers who claimed trying ( or succeeding ) to produce more power / run more boost than manufacturer's specifications, Turbo that show signs of severe surging due to the use of anti lag systems or lack of blow-off valve, Turbine wheels melted by detonation...)
Tamper: Items that have been modified in a way that impedes performance/reliability (example: Turbos which center housing has been opened, Housings that have been drilled, cut or welded in a way that prevents proper installation, ceramic coating on mating surfaces of housings...)
I am assuming that they considered my turbo to be neglected due to improper clocking with after only two pulls since they did not cover the shipping cost back to me. If the turbo was in fact improperly clocked, I would have noticed it right off the bat. After the installation and after the initial start-up I would have noticed compressor wheel to housing contact. Shoot, even after the first time hitting boost there was no noise coming from the turbo and spun freely with no shaft play. I think that pretty much throws the whole improper clocking BS out the window.



Last edited by 95dc2teg; 10-01-2009 at 01:08 AM.
95dc2teg is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-15-2009, 04:21 AM   #2
07FocusST
Focus Addict
 
07FocusST's Avatar
 
Join Date: Aug 2007
Fan#: 49661
Location: Bremerton, WA
What I Drive: 2007 Focus ST

Posts: 798
FF Reputation: 2 07FocusST Good Standing Member
Buy-Sell-Trade Rating: (3)
umm.... holy crap!? I would have been at their front door already beating them with the precision turbo over the head till they got a clue...

I am not certified in any way to rebuild turbos but I know the process. Seems like someone didn't tighten the compressor wheel bolt down enough w/ loc-tite. I had my shaft on my IHI balanced beforfe I personally rebuilt it and that was it for outside work. I rebuilt the turbo in my own garage. Saved myself a few pretty pennies and learned a whole bunch about turbos. My IHI is a freakin work horse.

It may be from a faulty thrust bearing. I would get all the pictures of this past tear down to verify all the internal parts are in decent condition as they are saying. That would be my best guess is a faulty 360 thrust bearing... Sorry to hear about your bad luck with them. Just goes to show you that there are people in this world who are like that. Have you thought of contacting BBB?

Save up some $$$$ and call Tom to see if he can hook you up with a sweet deal on a Comp Turbo.

-Derrick
__________________
Turbo ST (Soon Again)
Boosted Crew Member #115
SAP Crew Member #17

Quote:
Originally Posted by hypnoticracing View Post
foci's came without rear brakes? i guess mine is special with its drums
07FocusST is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 04:48 AM   #3
blackoutSVT
Lurking
 
blackoutSVT's Avatar
 
Join Date: Dec 2007
Fan#: 52102
Location: Rowlett, TX
What I Drive: 86 sportster1100, 12 Focus SE Sedan

Posts: 1,999
FF Reputation: 9 blackoutSVT Good Standing Member
Buy-Sell-Trade Rating: (15)
man sorry you had to deal with that crap.. that is a bunch of bull and if i were u i would report them to the BBB... i would never take what they gave you as an option... what a bunch of dicks.. i hope you get this settled... keep us posted...
__________________
Quote:
Originally Posted by Nytryder View Post
I've no doubt that the Marquise de Sade is alive and well and is designing Focus seats.
blackoutSVT is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 04:57 AM   #4
volcomstone1966
RIP 02 SVT 0209
 
volcomstone1966's Avatar
 
Join Date: May 2006
Fan#: 35104
Location: Tracy ,Nor-Cal, CA
What I Drive: 04 PWSC EAP SVT - 04 Kawasaki ZX6R

Posts: 3,897
Points 16,325, Level 81
Points: 16,325, Level: 81 Points: 16,325, Level: 81 Points: 16,325, Level: 81
Level Up 95% Completed
Level up: 95% Level up: 95% Level up: 95%
Forum Activity 12%
Activity: 12% Activity: 12% Activity: 12%
FF Reputation: 15 volcomstone1966 Great Standing Member
Buy-Sell-Trade Rating: (44)
dam that sucks
spread the word
__________________
04 SVT EAP #1131 -POWERWORKS-Torsen-Clutch Masters-Top Speed-Massive-Brembo-Fifteen52-Steeda-UNDER CONSTRUCTION
2K14 Turbo Veloster
04 Kawasaki ZX6R
volcomstone1966 is online now  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 05:00 AM   #5
death_bomber
Aggresive Not Crazy
 
death_bomber's Avatar
 
Join Date: Sep 2006
Fan#: 39461
Location: Sacramento, CA
What I Drive: 2001 RED LX

Posts: 1,809
Points 5,620, Level 48
Points: 5,620, Level: 48 Points: 5,620, Level: 48 Points: 5,620, Level: 48
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 6 death_bomber Good Standing Member
Buy-Sell-Trade Rating: (3)
so much written but off topic....did you get a welcome to the best site in the world?

WELCOME
death_bomber is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 11:51 AM   #6
95dc2teg
Focus Rookie
 
Join Date: Sep 2009
Fan#: 69081
Location: tampa, FL
What I Drive: 2000 red zx3

Posts: 8
FF Reputation: 1 95dc2teg Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks for the welcome! ya man this definitely has been a disaster for me. Its pretty ridiculous that they tried to blame it on me saying that I clocked the turbo wrong causing that little gasket to bunch up. Its just so far fetched that its ridiculous. I am doing my best to spread the word. I told them that I was going to do this, just so they would know and if they wanted could chime in and tell their side of the story BUT they havent even replied to that email. Fine by me. Im sure they will feel it.
95dc2teg is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 12:47 PM   #7
burkej62
Focus Enthusiast
 
Join Date: Feb 2009
Fan#: 62689
Location: Pa
What I Drive: 2002 Focus Zx3 5 speed, air ride.

Posts: 194
FF Reputation: 1 burkej62 Good Standing Member
Buy-Sell-Trade Rating: (1)
Damn thats crazy. I must have been a lucky one, I had a T3 super 60 rebuilt by BLAAST ( Guiliame Nadeue) and it rocked I ran the piss out of it with no issues
burkej62 is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 02:04 PM   #8
95dc2teg
Focus Rookie
 
Join Date: Sep 2009
Fan#: 69081
Location: tampa, FL
What I Drive: 2000 red zx3

Posts: 8
FF Reputation: 1 95dc2teg Good Standing Member
Buy-Sell-Trade Rating: (0)
Whats even better is when they shipped it back they charged the freight to the local ups stores account without their permission. The ups store declined the charge after I received my turbo and now I will be receiving a bill for $49 dollars. It only cost me $19 to ship it there!!! I had no idea that i was going to be charged for getting it shipped back as they didnt say that they were not going to cover it. Just another surprise from them! They wouldn't even pay for the shipping back to me. How ridiculous is that?!
95dc2teg is offline  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 02:25 PM   #9
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,088
Points 50,994, Level 100
Points: 50,994, Level: 100 Points: 50,994, Level: 100 Points: 50,994, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 36%
Activity: 36% Activity: 36% Activity: 36%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
You wouldnt be the first to have issues with there stuff

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 09-15-2009, 02:31 PM   #10
pauldogg_eq
Focus Jr. Enthusiast
 
Join Date: Sep 2009
Fan#: 69110
Location: Houston, TX
What I Drive: 2002, White, Focus ZTS

Posts: 28
FF Reputation: 1 pauldogg_eq Good Standing Member
Buy-Sell-Trade Rating: (1)
damn man, thats tough
pauldogg_eq is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:35 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.