lights flickering while driving and battery light turns on - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 05-05-2009, 12:09 PM   #1
aces ST
Focus Addict
 
aces ST's Avatar
 
Join Date: Jun 2008
Fan#: 56568
Location: East County San Diego, CA
What I Drive: 1994 mustang SC / 2004 Excursion

Posts: 605
FF Reputation: 2 aces ST Good Standing Member
Buy-Sell-Trade Rating: (2)
lights flickering while driving and battery light turns on

so under hard acceleration my headlights and interior lights will flicker like they are about to go out or they just dim, right when i let of the throttle they will go back to normal. Some cases the battery light will turn on for a little bit and then turn back off.

The car still drives fine, starts fine and everything just the flickering. It did sit in storage for seven months while i was deployed. any help thanks


__________________
NW POSSE #8
Sedan Revolution #166
ROTM Oct 2009 SOTM Aug 2009
http://www.zazzle.com/aces_st*
Fofo sold..94 mustang GT twin screwed 389whp/393tq
aces ST is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 05-05-2009, 01:39 PM   #2
RallieConGoggle
Focus Enthusiast
 
RallieConGoggle's Avatar
 
Join Date: Oct 2007
Fan#: 50774
Location: Lafayette, IN
What I Drive: 2007 CD Silver ZX4

Posts: 310
FF Reputation: 9 RallieConGoggle Good Standing Member
Buy-Sell-Trade Rating: (0)
Alternator! Don't wait until your stranded to get it checked (auto zone) and change it. I'm 95% sure from the description that it's your alternator, but there is a chance it could be something else.

I'd be surprised to see the alternator go on such a new car, hopefully it's warranty.

If the cause is low battery due to storage, it wouldn't have started without a jump.
__________________
Rally with your goggles on!
2000 Pitch Black ZTS Auto (230,000+ miles)
2007 CD Silver ZX4 SES 5spd
Zetec Crew #190
RallieConGoggle is offline  
    Reply With Quote
Old 05-06-2009, 08:20 AM   #3
03FocusZX3
Focus Enthusiast
 
03FocusZX3's Avatar
 
Join Date: Jan 2009
Fan#: 61785
Location: Anniston, AL
What I Drive: 2003 Liquid Grey ZX3

Posts: 544
FF Reputation: 1 03FocusZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
^^^ i am also 95% sure that it is the alternator, get it checked!
__________________
When I die, I want to go peacefully like my grandfather did, in his sleep, not screaming, like the passengers in his car.
03FocusZX3 is offline  
    Reply With Quote
Old 05-06-2009, 08:46 AM   #4
Thenicky
Focus Enthusiast
 
Join Date: Apr 2009
Fan#: 64757
Location: Outter Space, Afghanistan
What I Drive: 2002 Focus SE

Posts: 310
FF Reputation: 1 Thenicky Good Standing Member
Buy-Sell-Trade Rating: (0)
No Means to thread jack but it falls under same category
But When i come to a stop my lights like to flicker and at idle they dim a little
then when i accelerate i see my Mileage screen get brighter until i come to a stop and or idel. could this also be an altenator
Thenicky is offline  
    Reply With Quote
Old 05-06-2009, 08:49 AM   #5
Thenicky
Focus Enthusiast
 
Join Date: Apr 2009
Fan#: 64757
Location: Outter Space, Afghanistan
What I Drive: 2002 Focus SE

Posts: 310
FF Reputation: 1 Thenicky Good Standing Member
Buy-Sell-Trade Rating: (0)
on another note. i only started noticing this after i changed my vac lines and reset my ecu.

Sorry to OT but they seemed the nailed your prob with 95%
Thenicky is offline  
    Reply With Quote
Old 05-06-2009, 10:26 AM   #6
RallieConGoggle
Focus Enthusiast
 
RallieConGoggle's Avatar
 
Join Date: Oct 2007
Fan#: 50774
Location: Lafayette, IN
What I Drive: 2007 CD Silver ZX4

Posts: 310
FF Reputation: 9 RallieConGoggle Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Thenicky View Post
No Means to thread jack but it falls under same category
But When i come to a stop my lights like to flicker and at idle they dim a little
then when i accelerate i see my Mileage screen get brighter until i come to a stop and or idel. could this also be an altenator
That sounds more like a low-idle problem. When the alternator is spinning too slowly, the voltage is low and the headlights dim. Some dimming of the lights at idle is normal for all cars, but if lights are flickering or too dim you may have a low or rough idle. It is also possible that your alternator could be juuust starting to die on you. It couldn't hurt to get it tested at auto zone, as this is a free test. If you do have a low or rough idle, check your new vac lines for leaks and try cleaning your IAC by spraying carb cleaner into your idle bypass with the engine running.
__________________
Rally with your goggles on!
2000 Pitch Black ZTS Auto (230,000+ miles)
2007 CD Silver ZX4 SES 5spd
Zetec Crew #190
RallieConGoggle is offline  
    Reply With Quote
Old 05-06-2009, 10:30 AM   #7
Thenicky
Focus Enthusiast
 
Join Date: Apr 2009
Fan#: 64757
Location: Outter Space, Afghanistan
What I Drive: 2002 Focus SE

Posts: 310
FF Reputation: 1 Thenicky Good Standing Member
Buy-Sell-Trade Rating: (0)
IAC is this the same as MAF. Becuase i cleaned the MAF with solvent?
Sorry i dont know what IAC is...

And i replaced the 45 deg and 90 deg as well as cleaned my PCV out and replaced the line going from valve cover to airbox.

I Have the vac diagram and my chiltons but im so new its hard for me to understand by putting the diag with the chiltons... im more a visual learner...
Thenicky is offline  
    Reply With Quote
Old 05-06-2009, 11:02 AM   #8
RallieConGoggle
Focus Enthusiast
 
RallieConGoggle's Avatar
 
Join Date: Oct 2007
Fan#: 50774
Location: Lafayette, IN
What I Drive: 2007 CD Silver ZX4

Posts: 310
FF Reputation: 9 RallieConGoggle Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Thenicky View Post
IAC is this the same as MAF. Becuase i cleaned the MAF with solvent?
Sorry i dont know what IAC is...

And i replaced the 45 deg and 90 deg as well as cleaned my PCV out and replaced the line going from valve cover to airbox.

I Have the vac diagram and my chiltons but im so new its hard for me to understand by putting the diag with the chiltons... im more a visual learner...
Good question. The IAC is not the same as the MAF sensor. It is the Idle Air Control valve, and it is located under the intake manifold. When the throttle is closed (foot off gas) this variable valve controls how much air flows around the throttle into the intake manifold(on a Zetec).

To clean it, remove the hose between your MAF sensor and throttle body. Use carburetor cleaner (not MAF cleaner) and spray it into the throttle bypass several times while the engine is at idle. For extra credit, have your friend shut off the ignition while you are spraying and let it soak for about an hour. If you do this, the engine will die the next time you start it, but will run after that.


Again, some dimming of the lights at idle is normal. While driving the alternator should make about 14 volts, but at idle it's closer to 12 volts and you start to run on your battery. Depending on the severity of your dimming and flickering, you may not have a problem at all.
__________________
Rally with your goggles on!
2000 Pitch Black ZTS Auto (230,000+ miles)
2007 CD Silver ZX4 SES 5spd
Zetec Crew #190
RallieConGoggle is offline  
    Reply With Quote
Old 05-06-2009, 11:12 AM   #9
Thenicky
Focus Enthusiast
 
Join Date: Apr 2009
Fan#: 64757
Location: Outter Space, Afghanistan
What I Drive: 2002 Focus SE

Posts: 310
FF Reputation: 1 Thenicky Good Standing Member
Buy-Sell-Trade Rating: (0)
I dont have a zetech so i will look into my chilton and see if i can find the IAC. and once i find it clean it with carb cleaner. If all goes well...
But you want me to spray carb cleaner into the throttle bypass? sorry like i said im very new.
Thenicky is offline  
    Reply With Quote
Old 05-06-2009, 12:57 PM   #10
RallieConGoggle
Focus Enthusiast
 
RallieConGoggle's Avatar
 
Join Date: Oct 2007
Fan#: 50774
Location: Lafayette, IN
What I Drive: 2007 CD Silver ZX4

Posts: 310
FF Reputation: 9 RallieConGoggle Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Thenicky View Post
I dont have a zetech so i will look into my chilton and see if i can find the IAC. and once i find it clean it with carb cleaner. If all goes well...
But you want me to spray carb cleaner into the throttle bypass? sorry like i said im very new.
yeah, I don't have a pic - and mine's going to look different than yours. When you take the hose off of the throttle body, you will see the throttle plate. If yours looks like mine, there will be a vent beside the throttle plate. This is the passage that the IAC air draws from. Look in your manual for anything related to the throttle body, there should be pictures. I'm not sure if they'd have the exact procedure that I'm describing, but you should be able to make out the orfice that I am describing.

Removing the IAC to clean it will take much longer and may require removal of other parts (i.e. alternator or intake manifold).
__________________
Rally with your goggles on!
2000 Pitch Black ZTS Auto (230,000+ miles)
2007 CD Silver ZX4 SES 5spd
Zetec Crew #190
RallieConGoggle is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WEIRD Battery light on, but no problems...? DetroitBass General Technical Chat 27 08-10-2011 09:41 AM
Flickering Dash/Battery Light coming on and off BlackJack03 General Technical Chat 22 11-22-2008 11:10 AM
Strange problem - battery light 02_zxFIVE General Technical Chat 14 08-02-2007 09:56 AM
Please HELP - Battery light VR6guy General Technical Chat 11 02-06-2007 07:56 PM
Battery light coming on for a short time while driving Baron Von PickleWeenee SVT Performance (2002-2004) 11 09-23-2004 08:13 AM


All times are GMT -5. The time now is 10:21 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.