Lost of Power at 4000 RPM - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-10-2008, 02:23 PM   #1
jedum
Focus Rookie
 
Join Date: Nov 2008
Fan#: 60496
Location: Delray Beach FL
What I Drive: 2001 Ford Focus Red ZX3

Posts: 1
FF Reputation: 1 jedum Good Standing Member
Buy-Sell-Trade Rating: (0)
Question Lost of Power at 4000 RPM

HI Guys

I have a ZX3 2001 with a weird problem. When I drive my car and the engine is warm, it lost power. If I accelerate suddenly (gas pedal at bottom) afer 4000 RPM the engine doesn't respnd and stuck having a limitation of RPM in any shift and even if the car is stop. When the car is cold I dont have this. I notice that my engine is working hotter than normal but the cooling system is working (fan, radiator etc). I dont have any CEL and I already check the fuel pressure (32 PSI after 30 min engine on). I want to be sure before replace something as someone suggested that could be the catalytic converter and other told me that is the fuel pump and regulator, so I am confused. I would appreciate your help on this as the difference could be hundreds.

Regards

Jedum


jedum is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-10-2008, 08:56 PM   #2
lhc_focus
Focus Enthusiast
 
Join Date: Jan 2007
Fan#: 42464
Location: Lake Havasu AZ
What I Drive: 2002 ZX5

Posts: 134
FF Reputation: 11 lhc_focus Great Standing Member
Buy-Sell-Trade Rating: (0)
Check your coolant. Is it old? I've had 2 vehicles both react to old coolant. Once plowing snow I would lose all power when I was pushing a large pile of snow. Turned out the coolant was brown (i was a kid at the time) changed it and power returned. Bought a CJ7 6 cylinder several years ago and the first day took it out behind the house to climb some hills. It started losing power after it was warmed. Again the coolant was brown.
lhc_focus is offline  
    Reply With Quote Quick reply to this message
Old 11-10-2008, 09:12 PM   #3
viney266
Focus Fanatic
 
viney266's Avatar
 
Join Date: Jun 2003
Fan#: 93
Location: westminster, maryland, MD
What I Drive: focus ztw ,zx3,mustang, motorcycles

Posts: 25,586
Points 230,345, Level 100
Points: 230,345, Level: 100 Points: 230,345, Level: 100 Points: 230,345, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 112 viney266 Excellent Standing Member viney266 Excellent Standing Member
Buy-Sell-Trade Rating: (4)
well, the fuel pumps were under a recall on your year. Contact your local Ford dealer with the VIN and see if it has been done on your car. If not, go get it done, if it has, change the fuel filter before you do ANYTHING else.
__________________
Speed is only a matter of money; how fast do you want to go?
viney266 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How-To : Adding Power outlet (smimilar to Hardwiring radar by MISVTfocus) BeeFzX3 MK1 Interior Mods & Upgrades 2 08-10-2014 10:25 AM
Quick question about lost power.... Stooge General Technical Chat 14 04-03-2008 05:17 PM
Car Suddenly lost allot of power this Morning fusioncom01 SVT Performance (2002-2004) 1 11-29-2007 07:42 AM
Reoccurring Power steering issues (advice, anyone?) Aqua12632 General Technical Chat 4 12-13-2006 04:21 PM
boost low rpm power lacyk SVT Performance (2002-2004) 7 05-24-2004 09:05 AM


All times are GMT -5. The time now is 03:21 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.