O2 sensors - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-26-2008, 07:05 PM   #1
amac1
Focus Enthusiast
 
amac1's Avatar
 
Join Date: Jan 2004
Fan#: 2544
Location: Paulsboro, NJ (south jersey), NJ
What I Drive: 03 screamin yellow svt

Posts: 431
FF Reputation: 1 amac1 Good Standing Member
Buy-Sell-Trade Rating: (1)
O2 sensors

Hey focus family..i have a problem i have a 03 svt and it has 64k on it, and sometime in dec of 07 check engine light came on and it said that BOTH my
O2 sensors where bad.. i put 4 sets of o2 sensors in(upstream and downstream) and i jus replace it last week, and bam, came on again..So did anybody have this problem b4 and what they did to correct it.

thanks guys

tony


__________________
Tony (focusman01 on FJ) same on XboXLive

Tree Draggers
Keepin the Streetz fresh of rice.
amac1 is offline  
    Reply With Quote Quick reply to this message
Old 09-26-2008, 11:03 PM   #2
fastfocussvt87
Focus Enthusiast
 
fastfocussvt87's Avatar
 
Join Date: Sep 2008
Fan#: 59141
Location: buffalo NY
What I Drive: 2002 Blue SVT focus

Posts: 347
FF Reputation: 4 fastfocussvt87 Good Standing Member
Buy-Sell-Trade Rating: (2)
do you have a after market exhaust system??? if so, the o2's might not be reading correctly. this doesn't mean that there all bad, it just means that either there reading to rich or to lean, if to lean, they'll throw a code for being lean, same goes with running rich. or there might not be enough flow through them to register a reading for the computer. do you know what the PO#'s were for the codes???
__________________
02 SVTF, ORP, SRI, modified counterweight bracket. without the weight, short throw shifter, and many a modds to come.

i am #173 of 1184, sonic blue with blue interior SVTF's born during the year of 2002. And proud of it.
fastfocussvt87 is offline  
    Reply With Quote Quick reply to this message
Old 09-26-2008, 11:07 PM   #3
ShamrockSVT
Focus Enthusiast
 
ShamrockSVT's Avatar
 
Join Date: Jun 2007
Fan#: 47719
Location: Glendale, AZ
What I Drive: 2011 Ford Fiesta SE

Posts: 3,007
FF Reputation: 72 ShamrockSVT Excellent Standing Member
Buy-Sell-Trade Rating: (1)
What brand of sensors are you using? I've heard the Bosch ones avail at any parts store don't last, the only decent ones are the motorcraft ones available only at the dealer.
__________________
ShamrockSVT: Doing my part
ShamrockSVT is offline  
    Reply With Quote Quick reply to this message
Old 09-26-2008, 11:18 PM   #4
fastfocussvt87
Focus Enthusiast
 
fastfocussvt87's Avatar
 
Join Date: Sep 2008
Fan#: 59141
Location: buffalo NY
What I Drive: 2002 Blue SVT focus

Posts: 347
FF Reputation: 4 fastfocussvt87 Good Standing Member
Buy-Sell-Trade Rating: (2)
^^^^^^i agree with that statement, go with factory/dealer direct and spend the extra penny, instead of after market store bought sensors.
__________________
02 SVTF, ORP, SRI, modified counterweight bracket. without the weight, short throw shifter, and many a modds to come.

i am #173 of 1184, sonic blue with blue interior SVTF's born during the year of 2002. And proud of it.
fastfocussvt87 is offline  
    Reply With Quote Quick reply to this message
Old 09-27-2008, 04:09 PM   #5
scrammer
Banned
 
scrammer's Avatar
 
Join Date: Aug 2005
Fan#: 26570
Location: Hagerstown, MD
What I Drive: February 2010 ROTM

Posts: 7,946
FF Reputation: 172 scrammer Excellent Standing Member scrammer Excellent Standing Member
Buy-Sell-Trade Rating: (29)
blah blah....i bought a defective motorcraft o2 from the dealership! i asked them to warranty it. but in order to do that, i need a pinpoint test performed on the sensor to PROVE that it is faulty. guess how much the test costs.....yup, same price as a new sensor. F that!

so i bought a bosch. 3 weeks later and no problems. we will see. they also have a 12/12 warranty.

Last edited by scrammer; 12-23-2008 at 03:09 PM.
scrammer is offline  
    Reply With Quote Quick reply to this message
Old 09-27-2008, 04:32 PM   #6
dirtbrown
what it be like
 
dirtbrown's Avatar
 
Join Date: Oct 2006
Fan#: 40563
Location: Riverside, CA
What I Drive: ganjabus

Posts: 6,325
Points 39,679, Level 100
Points: 39,679, Level: 100 Points: 39,679, Level: 100 Points: 39,679, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 27 dirtbrown Great Standing Member
Buy-Sell-Trade Rating: (3)
maybe your cats defective?
dirtbrown is offline  
    Reply With Quote Quick reply to this message
Old 09-27-2008, 04:35 PM   #7
scrammer
Banned
 
scrammer's Avatar
 
Join Date: Aug 2005
Fan#: 26570
Location: Hagerstown, MD
What I Drive: February 2010 ROTM

Posts: 7,946
FF Reputation: 172 scrammer Excellent Standing Member scrammer Excellent Standing Member
Buy-Sell-Trade Rating: (29)
btw, the downstream "sensor" is simply a Cat monitor and will NOT hurt engine performance if it fails.
scrammer is offline  
    Reply With Quote Quick reply to this message
Old 09-27-2008, 06:09 PM   #8
RecoilRob
Focus Enthusiast
 
Join Date: Apr 2005
Fan#: 21404
Location: Uniontown, PA, United States
What I Drive: 04, CD Silver SVTF

Posts: 406
FF Reputation: 8 RecoilRob Good Standing Member
Buy-Sell-Trade Rating: (0)
What codes were/are being set? Just because an O2 sensor code comes up does NOT automatically mean that they are bad. There are other things that will set the codes when the sensors are working perfectly....just out of range, for example.
RecoilRob is offline  
    Reply With Quote Quick reply to this message
Old 09-27-2008, 07:12 PM   #9
amac1
Focus Enthusiast
 
amac1's Avatar
 
Join Date: Jan 2004
Fan#: 2544
Location: Paulsboro, NJ (south jersey), NJ
What I Drive: 03 screamin yellow svt

Posts: 431
FF Reputation: 1 amac1 Good Standing Member
Buy-Sell-Trade Rating: (1)
the first 2 sets were both bosch, and the last set i jus bought upstream is motorcraft and the downstream is bosch..i forgot what the codes where but it came up o2 sensors, when i take it back to get it scanned ill get the code numbers.. its all stock setup.. the only thing i have is intake, but i had that for about 3yrs now.
__________________
Tony (focusman01 on FJ) same on XboXLive

Tree Draggers
Keepin the Streetz fresh of rice.
amac1 is offline  
    Reply With Quote Quick reply to this message
Old 09-28-2008, 12:19 AM   #10
fastfocussvt87
Focus Enthusiast
 
fastfocussvt87's Avatar
 
Join Date: Sep 2008
Fan#: 59141
Location: buffalo NY
What I Drive: 2002 Blue SVT focus

Posts: 347
FF Reputation: 4 fastfocussvt87 Good Standing Member
Buy-Sell-Trade Rating: (2)
might have a bumm cat is what it sounds like. if you ever get adventurous, remove the cat and tap it on the ground. just to see if anything falls out, if so, your gunna need a new cat. or get the ORP or something like that. just so the codes dont keep coming back. other wise, if its not a "clogged" cat or something related to a poor cat operation, you might be looking at a computer/wiring problem.
__________________
02 SVTF, ORP, SRI, modified counterweight bracket. without the weight, short throw shifter, and many a modds to come.

i am #173 of 1184, sonic blue with blue interior SVTF's born during the year of 2002. And proud of it.
fastfocussvt87 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Will reversed O2 sensors throw P0136 code? supersonicsvt General Technical Chat 1 05-10-2008 08:09 AM
How many O2 sensors? noblesteed General Technical Chat 10 03-07-2008 06:23 PM
Pinpointing an O2 Sensor problem DerekNJND General Technical Chat 17 03-16-2007 10:07 AM
'03 ZTS Fails OBDII state inspection- 5 sensors not ready- NO CEL or issues-- HELP! Me1Magoo General Technical Chat 2 12-17-2006 02:22 PM
Got both o2 Sensors Replaced Today... TheWevel SVT Performance (2002-2004) 9 10-22-2004 02:13 AM


All times are GMT -5. The time now is 03:18 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.