Brake light keeps flashing! Help please!!! - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-10-2008, 12:29 AM   #1
<focusONthis>
Focus Enthusiast
 
<focusONthis>'s Avatar
 
Join Date: Apr 2008
Fan#: 55388
Location: FONTANA, CA
What I Drive: 2002 silver ZX3

Posts: 249
FF Reputation: 1 <focusONthis> Good Standing Member
Buy-Sell-Trade Rating: (6)
Brake light keeps flashing! Help please!!!

My car starts up fine. Emergency brake lifts and drops like normal. The car drives good. But as I'm driving, the red emergency brake light on the dash flashes on and off during the whole drive. I double check the emergency brake to make sure its all the way down but it still flashes on and off. I'll be pushing the gas pedal (not even touching the brake pedal) and it still flashes. Does anyone know what this could be? My brakes aren't too old either. PLEASE HELP!!!


__________________
SoCal Crew#16
Zetec Crew#289
<focusONthis> is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-10-2008, 12:41 AM   #2
DarkFire1986
暗炎
 
DarkFire1986's Avatar
 
Join Date: Nov 2006
Fan#: 40966
Location: Ohio, OH
What I Drive: 2010 Silver Fusion, 1994 Ranger

Posts: 1,925
FF Reputation: 31 DarkFire1986 Great Standing Member
Buy-Sell-Trade Rating: (6)
That light is telling you somethings wrong with your brake system. If your ebrake is down, I'd start by checking the fluid level.
__________________
Quote:
Originally Posted by mofocus View Post
my car makes babies cry
DarkFire1986 is offline  
    Reply With Quote
Old 08-10-2008, 04:14 AM   #3
zappaMan
Focus Enthusiast
 
Join Date: Jun 2003
Fan#: 44
Location: Edmonton, Alberta
What I Drive: 2000 SE - Zetec Swap

Posts: 433
FF Reputation: 63 zappaMan Excellent Standing Member
Buy-Sell-Trade Rating: (0)
If it is flashing on and off, especially irregularly, I would check to see if your E-brake position switch is working correctly. I have had one that was going which would flash on and off whenever I went over a bump.
zappaMan is offline  
    Reply With Quote
Old 08-10-2008, 04:18 PM   #4
<focusONthis>
Focus Enthusiast
 
<focusONthis>'s Avatar
 
Join Date: Apr 2008
Fan#: 55388
Location: FONTANA, CA
What I Drive: 2002 silver ZX3

Posts: 249
FF Reputation: 1 <focusONthis> Good Standing Member
Buy-Sell-Trade Rating: (6)
The brake fluid looks ok. I could probably add a little but its not below the min. line.

But I got my shift cable replaced not 2 long ago and when I got my car back, the ebrake felt like it was rubbing something everytime I dropped it. It did this 4 so many weeks and then stopped. U think they could've taken the console out, put it back in when they were done, and messed something up?

Also, my trans has been screwing up. 2nd gear grinds when its hot and the gears feel out of place when I'm shifting. The gears feel loose. The stick doesnt shift into gear like normal. Since the brake fluid and clutch fluid are together, and the clutch is in the trans, is there a way that it can be sensing the trans problem? If this is a dumb question, sorry. But I was just curious and trying 2 figure out something it could be. But I'm sure u see how I came up with that.
__________________
SoCal Crew#16
Zetec Crew#289
<focusONthis> is offline  
    Reply With Quote
Old 08-10-2008, 04:32 PM   #5
Blackcatn2o
soon to be turbo!
 
Blackcatn2o's Avatar
 
Join Date: Jun 2007
Fan#: 48278
Location: Brandon, FL
What I Drive: 06 silver ZX4 ST

Posts: 5,729
FF Reputation: 48 Blackcatn2o Great Standing Member
Buy-Sell-Trade Rating: (13)
Quote:
Originally Posted by zappaMan View Post
If it is flashing on and off, especially irregularly, I would check to see if your E-brake position switch is working correctly. I have had one that was going which would flash on and off whenever I went over a bump.
I second that
Blackcatn2o is offline  
    Reply With Quote
Old 08-10-2008, 04:46 PM   #6
Blackcatn2o
soon to be turbo!
 
Blackcatn2o's Avatar
 
Join Date: Jun 2007
Fan#: 48278
Location: Brandon, FL
What I Drive: 06 silver ZX4 ST

Posts: 5,729
FF Reputation: 48 Blackcatn2o Great Standing Member
Buy-Sell-Trade Rating: (13)
Quote:
Originally Posted by zappaMan View Post
If it is flashing on and off, especially irregularly, I would check to see if your E-brake position switch is working correctly. I have had one that was going which would flash on and off whenever I went over a bump.
I second that
Blackcatn2o is offline  
    Reply With Quote
Old 08-10-2008, 08:03 PM   #7
zappaMan
Focus Enthusiast
 
Join Date: Jun 2003
Fan#: 44
Location: Edmonton, Alberta
What I Drive: 2000 SE - Zetec Swap

Posts: 433
FF Reputation: 63 zappaMan Excellent Standing Member
Buy-Sell-Trade Rating: (0)
You have to take the console off to do the shift cables so I think you have found your culprit!
zappaMan is offline  
    Reply With Quote
Old 08-10-2008, 08:28 PM   #8
Blurvfocus
Focus Fanatic
 
Blurvfocus's Avatar
 
Join Date: Nov 2004
Fan#: 15299
Location: Temple, PA
What I Drive: 03 ZX3 Wine Cooled Eng.

Posts: 2,199
FF Reputation: 54 Blurvfocus Excellent Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by <focusONthis> View Post
The brake fluid looks ok. I could probably add a little but its not below the min. line.
If the pads are fairly new, the fluid level should be near the max line, not the nin line. I suggest you add a little fluid and see where you stand. It's a lot easier than ripping your console out, only to find out a tablespoon of brake fluid would have fixed it, no?
__________________
Often wrong but never in doubt.
Blurvfocus is offline  
    Reply With Quote
Old 08-10-2008, 08:37 PM   #9
zappaMan
Focus Enthusiast
 
Join Date: Jun 2003
Fan#: 44
Location: Edmonton, Alberta
What I Drive: 2000 SE - Zetec Swap

Posts: 433
FF Reputation: 63 zappaMan Excellent Standing Member
Buy-Sell-Trade Rating: (0)
The throw-out bearing and clutch are not in the transmission, they are between the tranny and the engine in the bell housing. It certainly is possible that it could be the fluid sensor, but if you had work done on the console and you felt your e-brake snag on something it really does point to the ebrake position sensor. It isin't that bad to remove the centre console. It also doesn't make sense to buy a litre of brake fluid to add a touch when you know you can't use it if it sits for more then a month or two.
zappaMan is offline  
    Reply With Quote
Old 08-10-2008, 09:08 PM   #10
gonzorelic
Focus Fanatic
 
gonzorelic's Avatar
 
Join Date: Sep 2004
Fan#: 13348
Location: Alma Ga
What I Drive: 2003 Pitch Black SVT Focus ZX5

Posts: 1,982
FF Reputation: 31 gonzorelic Great Standing Member
Buy-Sell-Trade Rating: (0)
pull the boot off the e brake handle. there is a small push button under there facing upward. thats your problem. my car and my friends car both do this. they just flash irregularly. the reason is the button may be going bad or it might have gotten worn on top a bit and the e brake handle doesnt fully push down on the button when its all the way down.
__________________
Jealousy is contagious,
Get well soon bitch!

WWW.PATTERNTEK.COM
WWW.SNAPOFFRACING.COM
gonzorelic is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake information and educational materials Geezer Wheels & Tires - Sponsored By Tire Rack 26 01-07-2009 11:35 AM
brake light mattstpier General Technical Chat 4 01-28-2008 06:34 PM
Brake Light DDyas General Technical Chat 6 05-08-2006 02:56 PM
question about 3rd brake light problem vanman MK1 Focus 0 04-29-2006 01:57 PM
Does your brake light work with key off? djdj General Technical Chat 1 02-22-2006 01:04 PM


All times are GMT -5. The time now is 12:39 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.