Cruise control not working - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-06-2008, 05:42 PM   #1
sathyan
Focus Rookie
 
Join Date: Mar 2008
Fan#: 54480
Location: Marina, CA, USA
What I Drive: 2007 White SE

Posts: 1
FF Reputation: 1 sathyan Good Standing Member
Buy-Sell-Trade Rating: (0)
Cruise control not working

Car: 2007 Ford Focus SE

I bought a used Focus (no warranty) which has the buttons for cruise control. I did not test cruise control during my test drive so don't know if it ever worked. Everything else works fine.
When I turn on the cruise control I get no response - the speedcontrol light on the dash does not illuminate. If I press "set/acc" and take my foot off the gas, the car does not hold its speed.

I've checked the following:
-checked fuse #53 inside and #29 under hood - appear to be in good condition
-third brake light works

Is there anything else to check? Or do myself (with no specialized tools)?

How much could it cost to have the cruise control fixed?

thanks,
Sathyan


sathyan is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-06-2008, 08:35 PM   #2
penguin
Focus Fanatic
 
Join Date: Apr 2005
Fan#: 21700
Location: Iowa
What I Drive: 2005 Infrared ZXW

Posts: 3,737
FF Reputation: 109 penguin Excellent Standing Member penguin Excellent Standing Member
Buy-Sell-Trade Rating: (0)
There is a switch that disengages the cruise control when you press the brake. If it is defective or loose, the cruise will not work. Are your brake lights working?

It also is possible the cable a the throttle body for the cruise control is broken of has come loose.
penguin is offline  
    Reply With Quote Quick reply to this message
Old 07-06-2008, 08:46 PM   #3
ShamrockSVT
Focus Enthusiast
 
ShamrockSVT's Avatar
 
Join Date: Jun 2007
Fan#: 47719
Location: Glendale, AZ
What I Drive: 2011 Ford Fiesta SE

Posts: 3,002
FF Reputation: 72 ShamrockSVT Excellent Standing Member
Buy-Sell-Trade Rating: (1)
another possibilty is the clock spring, which is located under the airbag in your steering wheel.
__________________
ShamrockSVT: Doing my part
ShamrockSVT is offline  
    Reply With Quote Quick reply to this message
Old 07-14-2010, 01:42 PM   #4
briancotten
Focus Rookie
 
Join Date: Jul 2010
Fan#: 76713
Location: Greenville, SC
What I Drive: 2006 Charcoal Gray ZX4

Posts: 1
FF Reputation: 1 briancotten Good Standing Member
Buy-Sell-Trade Rating: (0)
Sathyan,

I'm not familiar with which models are automatic transmission and which are not. My ZX4 is and the cruise seemed to stop working sometimes and start working other times. Either way, you can try this at no cost and it resolved my isssue. When the clutch is pushed in to shift, that also turns off the cruise control. I put my foot under the clutch pedal and lifted the clutch petal up, after which allows the crusie control to work. Basically, when I push the clutch in, it disengages the cruise, then when I let off the clutch, it doesn't always come back up high enough to allow the cruise to work again. Lifting the clutch reengages the switch and allows the cruise to work once more. Maybe this simple fix will help you as well. If this is the case for you as well, maybe you can have the dealer adjust the clutch pedal so it comes higher up after pressing, or try taking a spring or bunjee cord and hooking it up in a way that pulls the clutch higher up when released.
briancotten is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me Tell Ford they are WRONG scalderon General Technical Chat 41 07-21-2008 05:01 PM
Installing Stock Cruise Control on zx3 ldruth MK1 Interior Mods & Upgrades 6 09-29-2007 08:34 PM
Installing Stock Cruise Control on 2007 zx3 ldruth General Technical Chat 1 07-10-2007 12:10 PM
cruise control issues....??????? doc gates General Technical Chat 3 07-01-2007 07:40 AM
Cruise Control Died whiterose General Technical Chat 1 07-01-2006 06:24 AM


All times are GMT -5. The time now is 11:57 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat