random clicking - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 05-20-2008, 03:53 PM   #1
lazur
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49806
Location: West Virginia
What I Drive: 2001 Silver ZX3

Posts: 16
FF Reputation: 1 lazur Good Standing Member
Buy-Sell-Trade Rating: (0)
random clicking

I'm getting a very fast clicking sound coming from the little black relay



this is someone elses photo but the one that was clicking was right beside the relay covered up by the 19.

please comment back it seems like i'm invisible in this damn place


lazur is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 05-20-2008, 03:58 PM   #2
lazur
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49806
Location: West Virginia
What I Drive: 2001 Silver ZX3

Posts: 16
FF Reputation: 1 lazur Good Standing Member
Buy-Sell-Trade Rating: (0)
it is stopping my car from starting at all. gauges go a little nuts too
lazur is offline  
    Reply With Quote
Old 05-20-2008, 04:16 PM   #3
scrammer
Banned
 
scrammer's Avatar
 
Join Date: Aug 2005
Fan#: 26570
Location: Hagerstown, MD
What I Drive: February 2010 ROTM

Posts: 7,946
FF Reputation: 172 scrammer Excellent Standing Memberscrammer Excellent Standing Member
Buy-Sell-Trade Rating: (29)
the one that is coverd by the "19" is the horn relay. the one to the right is the battery saver relay. and then to the right of that is the defroster.

i think the clicking is coming from the battery saver relay.
i also believe that your connections at the battery arent as good as they should be.

my suggestion is this
tighten down the clamp on the negative terminal of the battery.
make sure none of the wires that are grounded to the fender a few inches away arent frayed or broken.
also make sure the nut that is holding these wires to the fender is secured tightly.

these are the normal creatures that create your symptoms.
do what i suggested and report back.
scrammer is offline  
    Reply With Quote
Old 05-22-2008, 01:35 AM   #4
lazur
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49806
Location: West Virginia
What I Drive: 2001 Silver ZX3

Posts: 16
FF Reputation: 1 lazur Good Standing Member
Buy-Sell-Trade Rating: (0)
just a bad battery relay. Good look man!
lazur is offline  
    Reply With Quote
Old 05-22-2008, 07:52 AM   #5
viney266
Focus Fanatic
 
viney266's Avatar
 
Join Date: Jun 2003
Fan#: 93
Location: westminster, maryland, MD
What I Drive: focus ztw ,zx3,mustang, motorcycles

Posts: 25,573
FF Reputation: 112 viney266 Excellent Standing Memberviney266 Excellent Standing Member
Buy-Sell-Trade Rating: (4)
Or a low battery ! Check the charge on the battery, and then check the battery connections to be clean and tight.
__________________
Speed is only a matter of money; how fast do you want to go?
viney266 is offline  
    Reply With Quote
Old 05-22-2008, 05:13 PM   #6
Vance
Focus Enthusiast
 
Vance's Avatar
 
Join Date: Jun 2005
Fan#: 24185
Location: Phoenix, AZ
What I Drive: 2007 ZX3 SE 2.0L ATX Aqua Blue Met.

Posts: 67
FF Reputation: 6 Vance Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by viney266 View Post
Or a low battery ! Check the charge on the battery, and then check the battery connections to be clean and tight.
And pull the wires out of the terminals and check them for corrosion. They may not appear corroded on the outside around the battery posts, but the wires could be corroded inside the terminals.
__________________
For Sale: VF Engineering torque mount (used <1k miles)... $60 incl. shippiing w/i the 48 states
Vance is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dash lights coming on and strange clicking noise KillaLude General Technical Chat 8 05-21-2008 06:54 AM
Clicking...? Foc ZETEC Performance (2000-2004) 0 10-30-2006 03:26 PM
what the heck - fricking Random cat onebluemcm SVT Performance (2002-2004) 15 04-15-2006 11:53 AM
random tech cat's Kicknzx3 Archive 3 03-15-2006 07:26 PM
Clicking valves ZX3Tech33186 General Technical Chat 8 04-08-2004 04:51 PM


All times are GMT -5. The time now is 04:51 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.