hesitation on acceleration - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-06-2008, 02:45 PM   #1
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
hesitation on acceleration

since i got my 2000 focus ive replaced the egr sensor, the black thing on the fire wall and the tps sensor, the one on the side of the TB.

over the months ive been getting a CEL with egr insufficient flow, reseting battery clears it for a few weeks. well in the last couple days the car started heavily stumbling in every gear at low rpms. there is no CEL atm because i recently reset the battery. tho id imagine it would throw the same egr insufficient flow. does this mean my egr sensor is broken again? i still have warranty.


thanks please help :)
need car to work on monday


wkornf is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2008, 02:50 PM   #2
fhg959
SE HABLA ESPAŅOL
 
fhg959's Avatar
 
Join Date: Oct 2007
Fan#: 50640
Location: Tia Juana, CA
What I Drive: 06 Big-Egg Rally

Posts: 2,858
FF Reputation: 52 fhg959 Excellent Standing Member
Buy-Sell-Trade Rating: (6)
Have you tried changing the actual EGR valve? I had to do this once in my old zetec, it did kind of the same thing as yours before I changed it, but ran great afterwards. It isn't expensive and super easy to do!
__________________
-Team Duratec #122 SoCal #0
278whp & 259 ft/lb @ 2688rpm of Pure N/A baby!!!
7.22 @ 89 mph 1/8 mile
10.68 @ 127 mph 1/4 mile

I'm a time taker and I just wasted your time
fhg959 is online now  
    Reply With Quote
Old 03-06-2008, 04:00 PM   #3
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
well my egr sensor warranty only had 1 month left on it so i decided to drive(kinda) over to autozone and cash in on free replacement.

no luck on that, still drives terrible.


EGR valve? autozone has it listed for $80, never heard of anyone replacing it. anyone else know about this?
wkornf is offline  
    Reply With Quote
Old 03-06-2008, 04:45 PM   #4
godsbassist
Focus Enthusiast
 
godsbassist's Avatar
 
Join Date: Feb 2007
Fan#: 44054
Location: DC, Afghanistan
What I Drive: 2004 Silver zx3 pzev

Posts: 527
FF Reputation: 1 godsbassist Good Standing Member
Buy-Sell-Trade Rating: (1)
It can get stuck and cause a stumble for sure. Worth looking at, in the least.
__________________
We used to think if we gave a million monkeys typewriters, they would eventually come up with the complete works of Shakespeare. Now that we have the Internet, we know we were wrong.
godsbassist is offline  
    Reply With Quote
Old 03-06-2008, 09:58 PM   #5
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
thanks for the advice, what should i be looking for? if im correct the part seems to be just a tin can with a hose going in the top.

also searching the forums ive heard similar problems being related to fuel filters? since ive had the car almost a year, used/88k miles. ive never replaced it, nor have a i changed the spark plugs/wires.

will these help me out?


ps, no clue how to install a fuel filter.
wkornf is offline  
    Reply With Quote
Old 03-06-2008, 10:32 PM   #6
fhg959
SE HABLA ESPAŅOL
 
fhg959's Avatar
 
Join Date: Oct 2007
Fan#: 50640
Location: Tia Juana, CA
What I Drive: 06 Big-Egg Rally

Posts: 2,858
FF Reputation: 52 fhg959 Excellent Standing Member
Buy-Sell-Trade Rating: (6)
Ok, first of all, if the MIL indicates an egr malfunction it has to be something related to the egr. Replacing your spark plugs/wires and fuel filter always help, but won't necessarily solve the problem (assuming that those are not the problem). Now, from experience I can tell you that in my old zetec replacing the egr valve solve my problem. Also it is important to mention that it was also on the mid 80k miles. First I changed the sensor and the malfunction continued, then I replaced the egr valve and the problem was fixed; MIL was gone and also the mechanical malfunction. I think there is one way to test your egr by blowing or sucking air out of it, I don't really remember, something similar to the way you test pvc vales. If I wasn't helpful, there is always the option of taking your car to the mechanic. :)
__________________
-Team Duratec #122 SoCal #0
278whp & 259 ft/lb @ 2688rpm of Pure N/A baby!!!
7.22 @ 89 mph 1/8 mile
10.68 @ 127 mph 1/4 mile

I'm a time taker and I just wasted your time
fhg959 is online now  
    Reply With Quote
Old 03-06-2008, 10:49 PM   #7
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
thanks, just a little hesitant to buy another $80 dollar part. having a car for less than 1 year and having to replace every part in the damn thing isnt to appealing. this car has been tons of trouble since i got it. i thought i knocked this problem out 6 months ago with the other 2 sensors.
wkornf is offline  
    Reply With Quote
Old 03-07-2008, 02:52 AM   #8
fhg959
SE HABLA ESPAŅOL
 
fhg959's Avatar
 
Join Date: Oct 2007
Fan#: 50640
Location: Tia Juana, CA
What I Drive: 06 Big-Egg Rally

Posts: 2,858
FF Reputation: 52 fhg959 Excellent Standing Member
Buy-Sell-Trade Rating: (6)
well, you know $h!T happens. Also, I don't want you to spend 80 bucks and not to solve your problem. My advice if you want to stop wasting money is... take it to a good mechanic and have him fix your car, even if they charge more. Remeber that most of the times you get what you pay for... good luck!
__________________
-Team Duratec #122 SoCal #0
278whp & 259 ft/lb @ 2688rpm of Pure N/A baby!!!
7.22 @ 89 mph 1/8 mile
10.68 @ 127 mph 1/4 mile

I'm a time taker and I just wasted your time
fhg959 is online now  
    Reply With Quote
Old 03-14-2008, 09:59 PM   #9
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
update:

so after replacing the egr sensor ive yet to get the CEL to pop back up which leads me to believe the CEL had nothing to do with thats happening now. Since it was on for months before i encountered this new problem.

the stuttering is almost constant at this point and im wondering why it doesnt cause a check engine light to turn on. Car has almost died a few times getting out of first. and it can buck real bad while accelerating seemed worsened at first with AC on but now its pretty bad regardless.

Thanks for the help so far.
Wayne
wkornf is offline  
    Reply With Quote
Old 04-04-2008, 06:54 PM   #10
wkornf
Focus Rookie
 
Join Date: Aug 2007
Fan#: 49305
Location: Coral Springs, FL
What I Drive: 2000 Black Focus XZ3

Posts: 23
FF Reputation: 1 wkornf Good Standing Member
Buy-Sell-Trade Rating: (0)
Update Again:

2000 zetec 2.0 zx3

Parts Replaced: fuel filter,spark plugs/wires/egr sensor/egr Valve
CLeaned: MAF/Throttle body

SO i still have the hesitation on acceleration and ive definately noticed its much worse when the air condition is on. For the most part the stuff ive done is regular maintenance on 90k mile car. I spoke to my uncle and he says it sounds like a problem with fuel delivery. Any other input? Since replacing the EGR valve i dont have a CEL anymore. Ive got nothing to go on.

Thanks,
Wayne
wkornf is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 SE Hesitation - Spark Plugs 2 MC P/Ns dwatson451 General Technical Chat 3 10-09-2007 04:54 PM
Need some input for more acceleration!!! teamrc49 Ford Focus & General Car Chat 2 05-07-2007 02:18 PM
hesitation?? SVTFOOCUS General Technical Chat 4 11-19-2006 11:43 PM
2005 Duratec a Little Rough on Light Acceleration? pragmatik General Technical Chat 2 02-15-2005 04:20 PM
I have lost my acceleration......help stxen12 ZETEC Performance (2000-2004) 16 06-12-2004 11:21 AM


All times are GMT -5. The time now is 10:40 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.