Oil pressure - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-01-2014, 07:40 AM   #1
Pudgy234
Focus Jr. Enthusiast
 
Join Date: May 2013
Fan#: 115274
Location: Johnston, RI
What I Drive: 2003 Red LX

Posts: 35
Points 311, Level 6
Points: 311, Level: 6 Points: 311, Level: 6 Points: 311, Level: 6
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 1 Pudgy234 Good Standing Member
Buy-Sell-Trade Rating: (0)
Oil pressure

Just curious is to what the oil pressure should be on these cars when hot and idling. Sat in traffic after a solid 40 min highway drive. Oil started flickering for about 15 min while I just stopped. Then evantually it just stayed on. The engine remained quite so it wasn't starving for oil. I replaced the pressure no luck. Oil pressure test revealed I was making 4psi at hot idle. My car also idles low...600-675 rpm and don't know why. If the light is on and I shift to neutral or park oil pressure goes up a few pounds and the light shuts off.

Has a new ford oil pump too
03 focus spi motor


Pudgy234 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-01-2014, 08:09 PM   #2
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,777
Points 6,780, Level 54
Points: 6,780, Level: 54 Points: 6,780, Level: 54 Points: 6,780, Level: 54
Level Up 15% Completed
Level up: 15% Level up: 15% Level up: 15%
Forum Activity 47%
Activity: 47% Activity: 47% Activity: 47%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
Who put the pump in?
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 09-01-2014, 09:33 PM   #3
Pudgy234
Focus Jr. Enthusiast
 
Join Date: May 2013
Fan#: 115274
Location: Johnston, RI
What I Drive: 2003 Red LX

Posts: 35
Points 311, Level 6
Points: 311, Level: 6 Points: 311, Level: 6 Points: 311, Level: 6
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 1 Pudgy234 Good Standing Member
Buy-Sell-Trade Rating: (0)
I put the pump in. It was brand new ford pump.
Pudgy234 is offline  
    Reply With Quote Quick reply to this message
Old 09-01-2014, 11:46 PM   #4
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,777
Points 6,780, Level 54
Points: 6,780, Level: 54 Points: 6,780, Level: 54 Points: 6,780, Level: 54
Level Up 15% Completed
Level up: 15% Level up: 15% Level up: 15%
Forum Activity 47%
Activity: 47% Activity: 47% Activity: 47%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
Are you 100% sure that the gears were clearanced correctly?
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 09-02-2014, 07:11 AM   #5
Pudgy234
Focus Jr. Enthusiast
 
Join Date: May 2013
Fan#: 115274
Location: Johnston, RI
What I Drive: 2003 Red LX

Posts: 35
Points 311, Level 6
Points: 311, Level: 6 Points: 311, Level: 6 Points: 311, Level: 6
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 1 Pudgy234 Good Standing Member
Buy-Sell-Trade Rating: (0)
The pump only goes onto the crankshaft one way. Either way you have pics of how it's supposed to sit?
Pudgy234 is offline  
    Reply With Quote Quick reply to this message
Old 09-02-2014, 12:20 PM   #6
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,777
Points 6,780, Level 54
Points: 6,780, Level: 54 Points: 6,780, Level: 54 Points: 6,780, Level: 54
Level Up 15% Completed
Level up: 15% Level up: 15% Level up: 15%
Forum Activity 47%
Activity: 47% Activity: 47% Activity: 47%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
No I don't but, IIRC the gears are supposed to be clearanced with a feeler gauge.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 09-02-2014, 12:49 PM   #7
Pudgy234
Focus Jr. Enthusiast
 
Join Date: May 2013
Fan#: 115274
Location: Johnston, RI
What I Drive: 2003 Red LX

Posts: 35
Points 311, Level 6
Points: 311, Level: 6 Points: 311, Level: 6 Points: 311, Level: 6
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 1 Pudgy234 Good Standing Member
Buy-Sell-Trade Rating: (0)
It could be somethig else too. The car idles low. I get about 10 psi in neutral and the light shuts off. I don't know how to kick the idle up
Pudgy234 is offline  
    Reply With Quote Quick reply to this message
Old 09-02-2014, 03:20 PM   #8
sailor
Elder
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 18,689
Points 13,387, Level 75
Points: 13,387, Level: 75 Points: 13,387, Level: 75 Points: 13,387, Level: 75
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 99%
Activity: 99% Activity: 99% Activity: 99%
FF Reputation: 82 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Does it still idle up high when cold started?

How about when it's put in gear, does the engine compensate for the load to keep the idle speed even? (might dip slightly & recover)

Trying to guess if your IAC (Idle Air Control) is functional.
__________________
"Rubber Side Down"

S.R. #275 Focus Takeover #003
sailor is online now  
    Reply With Quote Quick reply to this message
Old 09-02-2014, 07:26 PM   #9
Pudgy234
Focus Jr. Enthusiast
 
Join Date: May 2013
Fan#: 115274
Location: Johnston, RI
What I Drive: 2003 Red LX

Posts: 35
Points 311, Level 6
Points: 311, Level: 6 Points: 311, Level: 6 Points: 311, Level: 6
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 1 Pudgy234 Good Standing Member
Buy-Sell-Trade Rating: (0)
Yeah I think the IAC is working to an extent. I've suspected it but then it seemed to get better. So idk.
Pudgy234 is offline  
    Reply With Quote Quick reply to this message
Old 09-03-2014, 01:02 PM   #10
Mandroid
Focus Enthusiast
 
Mandroid's Avatar
 
Join Date: Mar 2014
Fan#: 150610
Location: enfield, CT
What I Drive: 2003 light tundra metalic SE 5spd

Posts: 532
Points 1,108, Level 18
Points: 1,108, Level: 18 Points: 1,108, Level: 18 Points: 1,108, Level: 18
Level Up 8% Completed
Level up: 8% Level up: 8% Level up: 8%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Mandroid Good Standing Member
Buy-Sell-Trade Rating: (0)
Have you tried adjusting the idle screw on the throttle body? Bing it up to 800 rpm or so. I believe that is where it's supposed to idle. Any higher and it will throw a code "engine idle higher than expected"
Mandroid is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:28 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat