Power Steering Giving Up Whilst Driving - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-30-2006, 12:58 PM   #1
Jip
Focus Rookie
 
Join Date: Sep 2006
Fan#: 39527
Location: Manchester
Posts: 9
FF Reputation: 1 Jip Good Standing Member
Buy-Sell-Trade Rating: (0)
Power Steering Giving Up Whilst Driving

Recently, whilst driving focus(1998) the speedometer needle suddenly drops to 0

the car is still going and works and then it would suddenly pop back up to wherever it was, without having to restart the car.

So it happened last night and i carried on driving, i proceeded to turn a corner when all of a sudden the power steering went and i found myself heading for a metal fence, i turned as hard as i could and it came back again and was fine for the rest of the journey.

I havent clue whats up, its due for its MOT on saturday.


1 more thing, i recently put an iPod adapter in and the cable goes round the back of the headunit and up the hole where the steering wheel base is, i dont know if i could have knocked a cable out or something?

does anyone know what it could be?


Jip is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-30-2006, 02:56 PM   #2
Slo_Focus
AKA Fast_Focus
 
Slo_Focus's Avatar
 
Join Date: Jan 2005
Fan#: 17238
Location: Burleson (DFW), Texas, TX
What I Drive: 2007 LG ZX4, 2007 Yamaha Blue R6

Posts: 6,078
FF Reputation: 14 Slo_Focus Great Standing Member
Buy-Sell-Trade Rating: (5)
you should check ur battery/starter/alternator cables... also, run back over ur wiring... it's VERY possible u knocked sometihg loose...
__________________
R6 runs 10s in 1/4 mile
FOCUS runs 10s in 1/8 mile
LOLZ!
Slo_Focus is offline  
    Reply With Quote
Old 11-30-2006, 05:05 PM   #3
Jip
Focus Rookie
 
Join Date: Sep 2006
Fan#: 39527
Location: Manchester
Posts: 9
FF Reputation: 1 Jip Good Standing Member
Buy-Sell-Trade Rating: (0)
searching through the forum, i found someone who had the same problem as me, the wheel locked, the power steering was fine, i hurt my arm in the scurry to turn the wheel in time :/

he got the pcm replace, havent clue what that is, but it sounds expensive

is there any how-to's on how to get to that wiring at the back on the dashboard?
Jip is offline  
    Reply With Quote
Old 11-30-2006, 05:21 PM   #4
scrammer
Banned
 
scrammer's Avatar
 
Join Date: Aug 2005
Fan#: 26570
Location: Hagerstown, MD
What I Drive: February 2010 ROTM

Posts: 7,946
FF Reputation: 172 scrammer Excellent Standing Member scrammer Excellent Standing Member
Buy-Sell-Trade Rating: (29)
sounds like your stealership needs to look at it. though, im sure they wont be able to replicate the problem, nonetheless, its worth looking into. this is your life at risk!
scrammer is offline  
    Reply With Quote
Old 11-30-2006, 05:34 PM   #5
RabidRodents
Focus Jr. Enthusiast
 
Join Date: Jun 2006
Fan#: 36379
Location: Los Osos
What I Drive: TURBO SPI

Posts: 47
FF Reputation: 1 RabidRodents Good Standing Member
Buy-Sell-Trade Rating: (0)
Battery connection, mine was corroded and had the same problem while turning at high speed.
__________________
2001 Black SE SPI
Money Pit: Short Shifter, Mangaflow, HR Sportlines, HID's
RabidRodents is offline  
    Reply With Quote
Old 11-30-2006, 05:45 PM   #6
Jip
Focus Rookie
 
Join Date: Sep 2006
Fan#: 39527
Location: Manchester
Posts: 9
FF Reputation: 1 Jip Good Standing Member
Buy-Sell-Trade Rating: (0)
i did try and take the corner rather fast to think of it :/

ill have a look at it and report back
Jip is offline  
    Reply With Quote
Old 11-30-2006, 10:06 PM   #7
Slo_Focus
AKA Fast_Focus
 
Slo_Focus's Avatar
 
Join Date: Jan 2005
Fan#: 17238
Location: Burleson (DFW), Texas, TX
What I Drive: 2007 LG ZX4, 2007 Yamaha Blue R6

Posts: 6,078
FF Reputation: 14 Slo_Focus Great Standing Member
Buy-Sell-Trade Rating: (5)
Quote:
Originally Posted by scrammer View Post
sounds like your stealership needs to look at it. though, im sure they wont be able to replicate the problem, nonetheless, its worth looking into. this is your life at risk!
I think I have heard u say "stealership" about 1287543676 times.... haha
__________________
R6 runs 10s in 1/4 mile
FOCUS runs 10s in 1/8 mile
LOLZ!
Slo_Focus is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:08 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.