gauge cluster - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-01-2013, 10:27 AM   #1
GonePostal
Focus Enthusiast
 
Join Date: Dec 2004
Fan#: 16697
Location: Brandon, Florida
What I Drive: 2004 Blue SVT ZX3

Posts: 503
FF Reputation: 1 GonePostal Good Standing Member
Buy-Sell-Trade Rating: (1)
gauge cluster

The main light will no longer work but needles do light up as well as radio and air conditioning lighting. The dim light switch does work for the radio and AC so that can't be the issue. Will I need to replace the entire gauge cluster or does this just require a light bulb change?


__________________
VF Rear Mount, Ford Racing STS, FC 65mm TB, RT Hi-Flow Cat, b16sir1991 Air Ram Kit, KW Coilovers, XCal II Tune, Grounding Wire Kit, Taylor Thundervolts w/Motorcraft Coppers, Euro Grille, Borla
GonePostal is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 06-01-2013, 10:39 AM   #2
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,182
FF Reputation: 22 freemind Great Standing Member
Buy-Sell-Trade Rating: (20)
The inverter sounds like it has given up the ghost. You can always make sure that all the connectors are seated correctly first. In the SVT the OEM inverter resides in the small oil pressure cluster.

Do you have a digital multimeter?
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote
Old 06-10-2013, 04:59 AM   #3
GonePostal
Focus Enthusiast
 
Join Date: Dec 2004
Fan#: 16697
Location: Brandon, Florida
What I Drive: 2004 Blue SVT ZX3

Posts: 503
FF Reputation: 1 GonePostal Good Standing Member
Buy-Sell-Trade Rating: (1)
No, I do not have a meter. Initially, when the problem first started happening, just a tap on top of the panel would make the light come back on. This remedy no longer works. Thanks for the input, freemind.
__________________
VF Rear Mount, Ford Racing STS, FC 65mm TB, RT Hi-Flow Cat, b16sir1991 Air Ram Kit, KW Coilovers, XCal II Tune, Grounding Wire Kit, Taylor Thundervolts w/Motorcraft Coppers, Euro Grille, Borla
GonePostal is offline  
    Reply With Quote
Old 06-10-2013, 12:48 PM   #4
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,182
FF Reputation: 22 freemind Great Standing Member
Buy-Sell-Trade Rating: (20)
^This totally sounds like a bad connection issue. Unplug the gauge cluster connectors(there should be 2 of them, push in on the main plug while moving the lever to the left)on the back of the cluster. Then re-seat them(installation is the same as removal). Check to see if they work. It only takes your time this way.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote
Old 06-12-2013, 04:20 PM   #5
josh6025
Focus Rookie
 
Join Date: Oct 2012
Fan#: 104734
Location: Ottawa, Canada
What I Drive: 2004 Pitch Black/Red Focus SVT

Posts: 18
FF Reputation: 1 josh6025 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have been having the same issue, I've even gone as far as switching clusters and I was still having the same issue.

How likely is it that the inverter is what needs to be replaced? How much is an inverter and how easy it is to replace?

I have a 2004 SVT (ZX5 body)
josh6025 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:12 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.