need help with my engine speed while driving - Page 3 - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-13-2013, 12:35 PM   #21
my_beautious_ZX3
Focus Addict
 
Join Date: Feb 2006
Fan#: 32386
Location: Chicago, IL
What I Drive: 2002 charcoal XZ3

Posts: 625
FF Reputation: 5 my_beautious_ZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
??

I replied to DaddyMO not turborich
__________________
"I'm jealous of girls because they get to wear dresses." (Todd Flanders)
my_beautious_ZX3 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2013, 02:56 PM   #22
Milton
Focus Enthusiast
 
Join Date: Sep 2011
Fan#: 89715
Location: San Antonio, TX
What I Drive: 2007 Black Focus SES 2.0 L4 4 Door

Posts: 341
FF Reputation: 4 Milton Good Standing Member
Buy-Sell-Trade Rating: (0)
Ahhhh... I see said the blind man.
Milton is online now  
    Reply With Quote
Old 08-13-2013, 07:50 PM   #23
turborich
Focus Jr. Enthusiast
 
Join Date: Sep 2011
Fan#: 89471
Location: Las Vegas, NV
What I Drive: 2000 Focus SE wagon

Posts: 37
FF Reputation: 3 turborich Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by DaddyMO View Post
Nice thread Rich! I have been chasing this problem on my wifes 00' Focus that has the same exact problem and has worsened this week that im having her drive her other car for safety reasons. Did you get your IAC from the dealer or your local parts store? I am going to look for an DIY on replacing the IAC since I have no idea where its at.

After I swapped her blown motor and got the car running perfect I am now chasing all the high milage wear and tear items every other weekend. When these things run good they are really not bad to drive at all.
Yes, I warrantied it through Autozone and the second one is still working. I'm sure a genuine Ford unit would be a better choice if it's not too much money.
turborich is offline  
    Reply With Quote
Old 08-13-2013, 08:38 PM   #24
Humphrey
Focus Enthusiast
 
Join Date: Nov 2011
Fan#: 91540
Location: Texarkana, AR
What I Drive: 2005 Silver ZX3

Posts: 98
FF Reputation: 1 Humphrey Good Standing Member
Buy-Sell-Trade Rating: (0)
Glad to see the issue is at least solved.

I was once having this issue. After a few weeks of dealing with this I decided to try and figure out what it was. Turns out, I put a part back on wrong.



See that little butterfly flap/door? I put it in upside down, or was it backwards... Who knows, I corrected its position and no more problems.
Issue was the door was getting caught on the wall and not closing all the way.
Humphrey is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:41 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.