04 Focus Sedan 2.3L Not Charging Battery - Page 2 - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-01-2013, 12:56 AM   #11
Gav-O-SVT
Focus Addict
 
Gav-O-SVT's Avatar
 
Join Date: Apr 2013
Fan#: 113561
Location: Concord, CA
What I Drive: '02 Infra-Red SVT

Posts: 645
FF Reputation: 5 Gav-O-SVT Good Standing Member
Buy-Sell-Trade Rating: (2)
Glad you got it fixed! Anytime you need help or have a question, there will be someone on here that can help you out. Damn those fusible links! Sometimes I wonder why they even put those on cars, why not just put a easily replacible inline fuse? Anyways, glad your car is running and charging like it should.
Gav-O-SVT is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:48 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.