Pesky p0304 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-14-2009, 11:43 AM   #1
Dustyfocus
Focus Jr. Enthusiast
 
Join Date: Jun 2009
Fan#: 66100
Location: Salt Lake City, UT
What I Drive: 2006, Sonic Blue, ZX3

Posts: 30
FF Reputation: 1 Dustyfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
Pesky p0304

Hi, wondering if anyone could help me shine some light on this situation. Like the title says I've got a pesky misfire code. I'll breifly give you the entire history of the story because I feel it's important to what the problem actually is, I thank anyone in advance for their input.

Story:Throws code p0304, midfire on cyl 4. I want to replace the spark plugs first so I buy some new ones. As I'm taking them out I see that the engine has at some point getten wet and there was rust in cyls 2 and 3 tubes. however the plugs for 1 2 and 3 were largely just fine. #4 appeared black, as youd expect for a misfiring cylinder, however it also apeared to have liquid on the business end (the firing end), I thought it was oil uh-oh. So I wipe it off put everything back and take it to a tunex. They clean out the cylinder wells and replace all of my plugs. They reported seeing no sort of liquid on the 4th plug, and generally ignored my concern for that.

So the code comes back later and I remebered hearing from the dude at tunex that he thought my 4th coil was "running hot" and he expected it would need to be replaced, so I did. But I order one and did it myself, pretty easy. Code goes away within minutes

Car runs just fine however code comes back. I take it to the dealership this time and they run some tests, including checking power output from each of my cylinders, everything was running perfect (cylinders were in the same 2% in power output, and again no liquid on the plug) and according to them no misfire occured after testing. they try to clear the code but it doesn't go away, it remains stored. Apparently this is a known problem so they had to reprogrm the whole computer, after that just like before my car was running fine.

Until 3 weeks later, today. I notice a little more hesitation at speed on the highway, nothing serious but I noticed it. lo and behold a few miles down the interstate it throws a code, I haven't even checked it yet but it felt just like having the code before and I'd be willing to bet it'll be another p0304. It felt like it was misfiring but not bad. Idle is fine, and generally it runs just fine.

But there is a little something nagging at this cylinder, maybe there is something fouling my coil? I don't know. ha, I'm going to take it in but not until thursday, anybody have any suggestions for me?


Dustyfocus is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 07-14-2009, 01:28 PM   #2
Dustyfocus
Focus Jr. Enthusiast
 
Join Date: Jun 2009
Fan#: 66100
Location: Salt Lake City, UT
What I Drive: 2006, Sonic Blue, ZX3

Posts: 30
FF Reputation: 1 Dustyfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
bump
Dustyfocus is offline  
    Reply With Quote
Old 07-14-2009, 04:19 PM   #3
SVT_ME
Focus Enthusiast
 
SVT_ME's Avatar
 
Join Date: Feb 2008
Fan#: 53618
Location: Annapolis MD
What I Drive: '02 Ranger XLT- '08.5 MS3 GT

Posts: 373
FF Reputation: 7 SVT_ME Good Standing Member
Buy-Sell-Trade Rating: (1)
Plug wires... a slightly damaged or corroded wire will do it every time. Happened in my truck, popped 3 packs before I pulled my head out of my ass.
__________________
Quote:
Originally Posted by HGFireHazard View Post
Truthfully, the only person I really trust to work on my cars is me. I know when I do something right and I know when I do something wrong...
SVT_ME is offline  
    Reply With Quote
Old 07-14-2009, 04:37 PM   #4
Djmike2485
Registered User
 
Join Date: Feb 2004
Fan#: 3230
Location: West Lafayette, IN, IN
What I Drive: Silver 2000 Ford Focus Zetec 4 Dr.

Posts: 829
FF Reputation: 6 Djmike2485 Good Standing Member
Buy-Sell-Trade Rating: (1)
x2 on the plug wires. I've had a cracked one that burned up my coil. They usually get bad when you disturb them to replace the plugs.
Djmike2485 is offline  
    Reply With Quote
Old 07-14-2009, 05:26 PM   #5
Dustyfocus
Focus Jr. Enthusiast
 
Join Date: Jun 2009
Fan#: 66100
Location: Salt Lake City, UT
What I Drive: 2006, Sonic Blue, ZX3

Posts: 30
FF Reputation: 1 Dustyfocus Good Standing Member
Buy-Sell-Trade Rating: (0)
these duratecs have an ignition coil over each plug so they don't really have "plug wires". But I think you guys might be on the right track with the wiring theory.
Dustyfocus is offline  
    Reply With Quote
Old 10-20-2013, 01:06 AM   #6
ThatFocusAgain
Focus Enthusiast
 
ThatFocusAgain's Avatar
 
Join Date: Sep 2012
Fan#: 103779
Location: Chesapeake Beach, MD
What I Drive: 2013 Oxford White ST

Posts: 151
FF Reputation: 1 ThatFocusAgain Good Standing Member
Buy-Sell-Trade Rating: (0)
My ST just developed this problem. I tried running a different fuel map due to studdering. The. P0304 popped up....can't really take mine in to ford. Down pipe cat delete, exhaust Cobb AP, Cobb turbo inlet tube matched up with FSwerks intake. And a tourque solutions rear motor mount.
ThatFocusAgain is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pesky p0304 Dustyfocus DURATEC Performance (2003-2007) 0 07-14-2009 11:19 AM
P0304 Misfire matt17485 General Technical Chat 3 10-16-2008 06:18 PM
Pesky Battery Warning Light Problem Solved - VR Plug mobsterx General Technical Chat 0 02-11-2008 06:24 PM
03 focus svt check engine code P0304 cyl 4 misfire tanya_03svt General Technical Chat 3 06-27-2007 10:08 AM
Permanent fix for that pesky DSI Clip BlueOhTwo SVT Performance (2002-2004) 15 12-16-2005 11:03 AM


All times are GMT -5. The time now is 10:41 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.