knock sensor not reading - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Focus Tuning Chat

Focus Tuning Chat Discuss performance tuning options for your Ford Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-18-2013, 07:19 PM   #1
RPMisChris
Focus Addict
 
RPMisChris's Avatar
 
Join Date: Jun 2010
Fan#: 76276
Location: Graham/Puyallup, WA
What I Drive: 07 svt 2.3 swap thing

Posts: 978
Points 5,147, Level 45
Points: 5,147, Level: 45 Points: 5,147, Level: 45 Points: 5,147, Level: 45
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 10%
Activity: 10% Activity: 10% Activity: 10%
FF Reputation: 1 RPMisChris Good Standing Member
Buy-Sell-Trade Rating: (14)
knock sensor not reading

Tom and I are currently datalogging/tuning my car and for whatever reason my car will not read my knock sensor. Tom is a stand up guy and has been more than helpful with my tunes thus far btw.

I recently installed crane stage 1 cams in my 2.0 dura and everything was tdc and looked good. So I decided to get a tune for it so I contacted Tom. After a few datalogging sessions it was determined that my knock sensor wasnt working and I was beginning to experience a hiccup from the exhaust.

I have no CEL's btw.

So I took the IM off and replaced the old sensor (which looked fine) with a new one from ford, replaced a pcv hose which was old but not cracked or anything, and thoroughly cleaned the IM. In addition, I changed the spark plugs, fuel filter, cleaned the maf, and installed new boots and springs on the COP's. I also checked for vacuum leaks and found nothing.

After all that my knock sensor still isnt working/picking up anything and my car still has a hiccup coming from the exhaust. When it hiccups the idle surges up about 100rpm and then drops back down.

Tom is working on getting me a safe reliable tune for all of my mods and working around my sensor not reading but this really bothers me.

Does anyone have any ideas on what it could be that is causing either issue or if they are both related?


RPMisChris is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-18-2013, 07:26 PM   #2
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,071
Points 50,944, Level 100
Points: 50,944, Level: 100 Points: 50,944, Level: 100 Points: 50,944, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
I would like to know more in an email about this hiccup please , KS not working worries me as well
I dont know if it isnt working or isnt logging ? I am working on finding that out with the last tune we did and waiting on the next , 1-2 more logs and I think I can answer that and we can go from there , the 2000 to 4000 wot the chances of hurting the engine at that low a RPM is very very very slim and why we havent gone past 4000

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote Quick reply to this message
Old 10-18-2013, 07:37 PM   #3
RPMisChris
Focus Addict
 
RPMisChris's Avatar
 
Join Date: Jun 2010
Fan#: 76276
Location: Graham/Puyallup, WA
What I Drive: 07 svt 2.3 swap thing

Posts: 978
Points 5,147, Level 45
Points: 5,147, Level: 45 Points: 5,147, Level: 45 Points: 5,147, Level: 45
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 10%
Activity: 10% Activity: 10% Activity: 10%
FF Reputation: 1 RPMisChris Good Standing Member
Buy-Sell-Trade Rating: (14)
Thanks for the quick response. I emailed you.
RPMisChris is offline  
    Reply With Quote Quick reply to this message
Old 12-10-2013, 07:24 PM   #4
Ghostrider86
Focus Jr. Enthusiast
 
Join Date: Sep 2006
Fan#: 39558
Location: Roswell, GA
What I Drive: 2003 Blk Centennial w-VF/FSwerks SC

Posts: 44
Points 276, Level 5
Points: 276, Level: 5 Points: 276, Level: 5 Points: 276, Level: 5
Level Up 52% Completed
Level up: 52% Level up: 52% Level up: 52%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 Ghostrider86 Good Standing Member
Buy-Sell-Trade Rating: (0)
So whats the PID that is chosen to log the knock sensor. I tried several my self and didn't get any kinds of readings.
__________________
Jeff
03 ZTS Centennial Edition W/VF/FSWerks SC kit
Service Advisor
Nalley Lexus
Ghostrider86 is offline  
    Reply With Quote Quick reply to this message
Old 12-10-2013, 07:30 PM   #5
RPMisChris
Focus Addict
 
RPMisChris's Avatar
 
Join Date: Jun 2010
Fan#: 76276
Location: Graham/Puyallup, WA
What I Drive: 07 svt 2.3 swap thing

Posts: 978
Points 5,147, Level 45
Points: 5,147, Level: 45 Points: 5,147, Level: 45 Points: 5,147, Level: 45
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 10%
Activity: 10% Activity: 10% Activity: 10%
FF Reputation: 1 RPMisChris Good Standing Member
Buy-Sell-Trade Rating: (14)
not sure but Tom found/fixed it
RPMisChris is offline  
    Reply With Quote Quick reply to this message
Old 12-10-2013, 11:35 PM   #6
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,692
Points 18,286, Level 85
Points: 18,286, Level: 85 Points: 18,286, Level: 85 Points: 18,286, Level: 85
Level Up 88% Completed
Level up: 88% Level up: 88% Level up: 88%
Forum Activity 16%
Activity: 16% Activity: 16% Activity: 16%
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Ks_rtd
iminhell is offline  
    Reply With Quote Quick reply to this message
Old 12-11-2013, 01:27 AM   #7
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,071
Points 50,944, Level 100
Points: 50,944, Level: 100 Points: 50,944, Level: 100 Points: 50,944, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
Quote:
Originally Posted by Ghostrider86 View Post
So whats the PID that is chosen to log the knock sensor. I tried several my self and didn't get any kinds of readings.
It depends on your year and ECU code , if you KS has been turned off in your tune it wont show anything , who did your tuning

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is offline  
    Reply With Quote Quick reply to this message
Old 01-11-2014, 04:52 PM   #8
ripto
Focus Enthusiast
 
ripto's Avatar
 
Join Date: May 2012
Fan#: 99257
Location: Ledyard, CT
What I Drive: 2012 Ford Focus

Posts: 243
Points 1,407, Level 21
Points: 1,407, Level: 21 Points: 1,407, Level: 21 Points: 1,407, Level: 21
Level Up 7% Completed
Level up: 7% Level up: 7% Level up: 7%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 ripto Good Standing Member
Buy-Sell-Trade Rating: (0)
Hey Tom, did you get my email regarding potential spark knocking on my car? I don't remember hearing anything before tuning, and now I'm hearing what sounds like spark knock aka pinging. I data logged with the layout you set up, which had the Knock Sensor PID. It did not move from 0.00 on my 25 minute drive home, but I heard it.


Chris
gnomerog60@aol.com
__________________
2012 Ford Focus SE Sedan, Red Candy Metallic Tinted CC, 5 Speed Manual
SE Sport and Winter Packages, 203A Equipment Group, 17" M&P Wheels
K&N 69-3517TS Intake, Magnaflow 15138 Catback Exhaust, WeatherTech 82573 Window Visors, 35% ON-35 Madico Tint
ripto is offline  
    Reply With Quote Quick reply to this message
Old 01-11-2014, 04:57 PM   #9
RPMisChris
Focus Addict
 
RPMisChris's Avatar
 
Join Date: Jun 2010
Fan#: 76276
Location: Graham/Puyallup, WA
What I Drive: 07 svt 2.3 swap thing

Posts: 978
Points 5,147, Level 45
Points: 5,147, Level: 45 Points: 5,147, Level: 45 Points: 5,147, Level: 45
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 10%
Activity: 10% Activity: 10% Activity: 10%
FF Reputation: 1 RPMisChris Good Standing Member
Buy-Sell-Trade Rating: (14)
Email him. He really responds fast to email. Speaking of I forgot to do another log for him. Oops it's been a while
RPMisChris is offline  
    Reply With Quote Quick reply to this message
Old 01-12-2014, 09:08 AM   #10
ripto
Focus Enthusiast
 
ripto's Avatar
 
Join Date: May 2012
Fan#: 99257
Location: Ledyard, CT
What I Drive: 2012 Ford Focus

Posts: 243
Points 1,407, Level 21
Points: 1,407, Level: 21 Points: 1,407, Level: 21 Points: 1,407, Level: 21
Level Up 7% Completed
Level up: 7% Level up: 7% Level up: 7%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 ripto Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by ripto View Post
Hey Tom, did you get my email regarding potential spark knocking on my car?
Quote:
Originally Posted by RPMisChris View Post
Email him. He really responds fast to email.
I did. Waiting.
__________________
2012 Ford Focus SE Sedan, Red Candy Metallic Tinted CC, 5 Speed Manual
SE Sport and Winter Packages, 203A Equipment Group, 17" M&P Wheels
K&N 69-3517TS Intake, Magnaflow 15138 Catback Exhaust, WeatherTech 82573 Window Visors, 35% ON-35 Madico Tint
ripto is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:26 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.