Electrical / Power Issues 2005 Focus ZX3 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-24-2013, 10:36 PM   #1
WindyCityKid
Focus Rookie
 
Join Date: Jul 2012
Fan#: 101067
Location: Warrensburg, MO
What I Drive: 2005 Ford Focus ZX3 SES

Posts: 1
FF Reputation: 1 WindyCityKid Good Standing Member
Buy-Sell-Trade Rating: (0)
Angry Electrical / Power Issues 2005 Focus ZX3

I was driving my 2005 Focus ZX3 two days ago and the headlights started switching between low and high speed very rapidly like a police car. The next day while driving all the instrument panel gauges started going haywire, the vehicle wanted to stall but I kept my foot on the pedal and made it to an Autozone. They checked the battery and alternator and said they were good. I had replaced the battery a year ago and installed an Autozone alternator only a month ago. The vehicle wasn't safe to drive and I had it towed to a Ford dealership. The technician said it ran smoothly and couldn't find any problems. Any advice from the experts what could be causing this intermittent electrical problem?


WindyCityKid is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-11-2014, 05:56 PM   #2
chris777
Focus Rookie
 
Join Date: Aug 2014
Fan#: 182297
Location: petawawa, Canada
What I Drive: 2005 frost silver zx4

Posts: 3
Points 14, Level 1
Points: 14, Level: 1 Points: 14, Level: 1 Points: 14, Level: 1
Level Up 27% Completed
Level up: 27% Level up: 27% Level up: 27%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 chris777 Good Standing Member
Buy-Sell-Trade Rating: (0)
i have a similar problem now, any luck finding a solution?
chris777 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:00 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat