Screen/Display Dead - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-27-2013, 06:22 PM   #1
Flyersrock87
Focus Rookie
 
Join Date: Apr 2013
Fan#: 114166
Location: Arlington, VA
What I Drive: 2013 black Titanium

Posts: 2
FF Reputation: 1 Flyersrock87 Good Standing Member
Buy-Sell-Trade Rating: (0)
Screen/Display Dead

So I drove about 200 miles from DC to Philly with no problems. When I started the car to leave, the display never came on, and hasn't been on since (this started Sunday, it's now Thursday). I tried disconnecting the battery for a couple minutes, but to no avail.

Any ideas?

EDIT: 2013 Titanium, MFT, no Nav.


Flyersrock87 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-27-2013, 07:27 PM   #2
dervari
Focus Enthusiast
 
Join Date: Apr 2013
Fan#: 113761
Location: Atlanta, GA
What I Drive: 2013 Performance Blue Titanium

Posts: 74
FF Reputation: 1 dervari Good Standing Member
Buy-Sell-Trade Rating: (0)
Warranty claim?
dervari is offline  
    Reply With Quote Quick reply to this message
Old 06-28-2013, 09:56 AM   #3
FordIVTteam
Official Ford Rep
 
FordIVTteam's Avatar
 
Join Date: Jul 2011
Fan#: 87765
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 971
Points 2,174, Level 28
Points: 2,174, Level: 28 Points: 2,174, Level: 28 Points: 2,174, Level: 28
Level Up 16% Completed
Level up: 16% Level up: 16% Level up: 16%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 3 FordIVTteam Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Flyersrock87 View Post
So I drove about 200 miles from DC to Philly with no problems. When I started the car to leave, the display never came on, and hasn't been on since (this started Sunday, it's now Thursday). I tried disconnecting the battery for a couple minutes, but to no avail.

Any ideas?

EDIT: 2013 Titanium, MFT, no Nav.
Hi, Flyersrock87 -

You'll need to make an appointment with your dealership to have them diagnose and fix this issue. Let me know how it goes.

Rebecca
__________________
FORD IN-VEHICLE TECHNOLOGY TEAM

p: 800.392.FORD (Prompts 1 then 3)
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordIVTteam is online now  
    Reply With Quote Quick reply to this message
Old 06-28-2013, 10:19 AM   #4
slybarman
Focus Addict
 
Join Date: Oct 2012
Fan#: 105425
Location: the not-so-free state, MD
What I Drive: 2013 Ford Focus Titanium hatchback

Posts: 1,256
Points 1,664, Level 23
Points: 1,664, Level: 23 Points: 1,664, Level: 23 Points: 1,664, Level: 23
Level Up 64% Completed
Level up: 64% Level up: 64% Level up: 64%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 6 slybarman Good Standing Member
Buy-Sell-Trade Rating: (0)
Mine had appeared dead once before only to come back to life after a reboot. You might want to try the delayed reboot before going to the dealer.


. . . or puling the MFT fuse . . . or disconnecting the batter and reconnecting.
__________________
MK3 Focus = a lot of good ideas rather poorly executed.
slybarman is offline  
    Reply With Quote Quick reply to this message
Old 08-07-2013, 04:19 PM   #5
TKM3RD
Focus Rookie
 
Join Date: Apr 2013
Fan#: 113139
Location: Chambersburg, PA
What I Drive: 2013 Performance Blue SE

Posts: 2
FF Reputation: 1 TKM3RD Good Standing Member
Buy-Sell-Trade Rating: (0)
Screen Dead

When I had the same issue, I tried everything I could think of. Then I realized I had a CD in the player. I ejected it, shut down the car, and restarted it without the CD. Worked like a champ.
TKM3RD is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:11 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat