Traction control question - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Discussions > Ford Focus & General Car Chat

Ford Focus & General Car Chat Discussion Forum relating to nonspecific Ford Focus models, car purchasing, auto industry news and any car talk.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-15-2013, 06:34 PM   #1
freeman700
Focus Rookie
 
Join Date: May 2013
Fan#: 115083
Location: Martinsville, IN
What I Drive: 2003 red zx3

Posts: 7
FF Reputation: 1 freeman700 Good Standing Member
Buy-Sell-Trade Rating: (0)
Traction control question

I just picked up an 03 zx3 2.0...
my question is do i have traction control? I dont have the button by the gearshift but the light does come on from time to time, always on start-up.

Is it possible that it was ordered with tc and just no way to shut it off??
Thx in advance-Gary



Last edited by freeman700; 06-15-2013 at 07:18 PM. Reason: more to question
freeman700 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 06-15-2013, 07:38 PM   #2
Darthenstein
Focus Enthusiast
 
Darthenstein's Avatar
 
Join Date: Mar 2009
Fan#: 63587
Location: Moorhead, MN
What I Drive: 2009 Ford Focus SES

Posts: 541
FF Reputation: 4 Darthenstein Good Standing Member
Buy-Sell-Trade Rating: (0)
Welcome aboard! Could you post a pic of your dash/gearshift setup so we can get a look at the buttons you have?
__________________
"It isn't what you drive that matters, it's how you drive it" - Jeremy Clarkson, Top Gear

Ford: Taurus ('91, 01) Focus ('09); Mercury: Sable ('95); Dodge: Neon ('95); Trek: 1000SL ('07) Yamaha: VStar 650 ('03)
Darthenstein is offline  
    Reply With Quote
Old 06-15-2013, 07:45 PM   #3
mainest
Focus Addict
 
mainest's Avatar
 
Join Date: Oct 2008
Fan#: 60163
Location: DownEast, ME
What I Drive: '04 Red Euro SVT

Posts: 1,108
FF Reputation: 7 mainest Good Standing Member
Buy-Sell-Trade Rating: (11)
Unless the center console isn't the original, it is unlikely you have T/C. Try a hard launch on wet or sandy pavement. If it has T/C, you will know it.
mainest is offline  
    Reply With Quote
Old 06-15-2013, 08:00 PM   #4
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,392
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
If it has rear disc brakes, you have T/C.
If not, you don't have it,,, or shouldn't.
iminhell is offline  
    Reply With Quote
Old 06-15-2013, 08:59 PM   #5
freeman700
Focus Rookie
 
Join Date: May 2013
Fan#: 115083
Location: Martinsville, IN
What I Drive: 2003 red zx3

Posts: 7
FF Reputation: 1 freeman700 Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks,
It has drums in the back..
As for the orange light its on the bottom part of the dash and it looks like a car is skidding.
The light comes on when we first start it then the other day it came on while it was raining and stayed on a minute or so, it also has came on while cornering. I did not feel any difference in the way it drove but i wasnt going too fast
It will slightly break traction from a stop with no signs of the light.
Thanks
freeman700 is offline  
    Reply With Quote
Old 06-16-2013, 11:50 AM   #6
mainest
Focus Addict
 
mainest's Avatar
 
Join Date: Oct 2008
Fan#: 60163
Location: DownEast, ME
What I Drive: '04 Red Euro SVT

Posts: 1,108
FF Reputation: 7 mainest Good Standing Member
Buy-Sell-Trade Rating: (11)
In the '05 ST that I recently sold, and my current '04 SVT, the T/C is always on below 20 or 25 mph. It activates the front brake on the wheel/tire that HAS traction. Very frustrating.
mainest is offline  
    Reply With Quote
Old 06-22-2013, 10:37 AM   #7
freeman700
Focus Rookie
 
Join Date: May 2013
Fan#: 115083
Location: Martinsville, IN
What I Drive: 2003 red zx3

Posts: 7
FF Reputation: 1 freeman700 Good Standing Member
Buy-Sell-Trade Rating: (0)
well i have checked into this and im 100% sure this doesnt have traction control.....But the light is on almost all the time now so im gonna check the brakes and see if that has someting to do with it.. i do have a bad rotor on the frt so ill let you guys know if i ever find the cause.... wish me luck
freeman700 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:45 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.