Electrical issue - Page 2 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-01-2013, 08:33 PM   #11
SWEGER
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
I'm doing the grounds soon...there was a great write up on here but I can't find it. There's also one in the how-tis called "the big 3" or something to that effect. Hopefully redoing my grounds helps my situation.
__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 03-22-2013, 07:07 PM   #12
baldyredtx
Focus Enthusiast
 
baldyredtx's Avatar
 
Join Date: Jan 2011
Fan#: 82344
Location: San Antonio, TX
What I Drive: 2003 Sonic Blue SVT 4 dr

Posts: 61
FF Reputation: 1 baldyredtx Good Standing Member
Buy-Sell-Trade Rating: (0)
I ran a new ground from my battery to the body and one to the motor and then a ground from the motor to the body. This fixed all of my issues so far. I spent probably $25 from autozone for the ground wires.
__________________
2003 Sonic Blue 4dr SVT
HFC, 2.5" Borla exhaust, drop in K&N, STS
baldyredtx is offline  
    Reply With Quote
Old 03-22-2013, 08:40 PM   #13
Insaniac
Focus Enthusiast
 
Insaniac's Avatar
 
Join Date: Apr 2006
Fan#: 34327
Location: Altoona, PA
What I Drive: 2003 ZX5 SVT

Posts: 182
FF Reputation: 5 Insaniac Good Standing Member
Buy-Sell-Trade Rating: (3)
I've read elsewhere that the actual headlight dimmer switch itself can be the cause of a lot of flickering issues. On my car I have to turn my dimmer dial back like 1/16" to get max brightness without flickering. If I turn it the entire way to full brightness my gauges flicker like crazy.
__________________
2003 ZX5 SVT #1345
CD Silver; Red Interior; Audiophile; Moonroof; HID's
Insaniac is offline  
    Reply With Quote
Old 03-25-2013, 11:23 AM   #14
SvviftSVT
Release the Kraken!!
 
SvviftSVT's Avatar
 
Join Date: Aug 2008
Fan#: 58277
Location: Houston, TX
What I Drive: Green-Eyed 2004 Black SVT #0461

Posts: 15,823
Points 11,387, Level 70
Points: 11,387, Level: 70 Points: 11,387, Level: 70 Points: 11,387, Level: 70
Level Up 35% Completed
Level up: 35% Level up: 35% Level up: 35%
Forum Activity 83%
Activity: 83% Activity: 83% Activity: 83%
FF Reputation: 10 SvviftSVT Great Standing Member
Buy-Sell-Trade Rating: (6)
its really just a common thing with svt's...
the doing the big 3 helps alot.. (battery ground, engine block ground, and power cable to the alternator)
but it won't necessarily fix it all..
mine has done it for 4 years... so i turned the dial back a tad, like others have said, and it works..
it doesnt even really dim it much at all. that is how little i have it turned back.. and no flickers for 6 months so far.
__________________
TeamFOCALIZE!// HATCH NATION #45// October '12 ROTM

Track build has begun.
slow and steady.. but its going
SvviftSVT is online now  
    Reply With Quote
Old 04-04-2013, 07:41 PM   #15
ainokea808kine
Focus Rookie
 
Join Date: Oct 2011
Fan#: 90773
Location: kunia, HI
What I Drive: 01, grey, zx3 svt swap

Posts: 17
FF Reputation: 1 ainokea808kine Good Standing Member
Buy-Sell-Trade Rating: (0)
i have the same issue but as far as i know its just a flickering it hasnt given me any other issues other then that... i also have NO idea how to fix that.... i dobt its a ground... i think its just how they are... my svts done it since i bought it...
ainokea808kine is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:43 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.