Is this really normal? - Page 24 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-07-2013, 04:59 PM   #231
kltye
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108532
Location: Chicago, IL
What I Drive: 2012 Red Candy Focus SEL

Posts: 3
FF Reputation: 2 kltye Good Standing Member
Buy-Sell-Trade Rating: (0)
I've been lurking these forums since July 2012, which is when my girlfriend and I bought a used (Red Candy) Focus SEL, manufactured in May 2011. Long story short, we soon experienced clutch slipping when taking off from standstill, and going up the slopes in parking garages was downright embarrassing with the loss of power and shuddering, and at times almost felt like the car was going to stall.

We took it in to Golf Mill Ford here in Chicago (am I allowed to mention dealer names?), who proceeded to tell my gf (who drives the car for her work) that it's normal. Four. Different. Times. The last time back in February, I even called them up to talk to the head tech, and liaised with FordCustomerCare here in the forums - we were given conflicting info on whether or not the mechanics had taken a look at the bell housing or the clutch. At the advice on area CS rep, we took it to Arlington Heights Ford, who immediately asked a mechanic to raise the car. He took one look at the bell housing, and beckoned me over. The moment of truth: https://skydrive.live.com/redir?resi...Drkt6dOMhlVsLM

Finally, we had the clutch pack replaced, and they told my gf that the clutches were pretty badly contaminated, and that "there's no reason why the previous dealer wouldn't have caught this". The car now drives like new, feels really responsive, and doesn't slip its way out of first gear.

Also, Golf Mill replaced our wiper blades with 22 and 19" blades, instead of 28" ones, because they had mistaken our car for a 2011 MY. In other words, try taking your cars to other dealers, and ask your area CS rep if they have one they could recommend in the area.

Last edited by kltye; 03-07-2013 at 09:38 PM.
kltye is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 03-07-2013, 05:21 PM   #232
Sprint
Focus Enthusiast
 
Join Date: Jun 2011
Fan#: 87069
Location: OTTAWA, Canada
What I Drive: 2012, Black, Focus Titanium Sedan

Posts: 88
FF Reputation: 1 Sprint Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by kltye View Post
I've been lurking these forums since July 2012, which is when my girlfriend and I bought a used (Red Candy) Focus SEL, manufactured in May 2011. Long story short, we soon experienced clutch slipping when taking off from standstill, and going up the slopes in parking garages was downright embarrassing with the loss of power and shuddering, and at times almost felt like the car was going to stall.

We took it in to Golf Mill Ford here in Chicago (am I allowed to mention dealer names?), who proceeded to tell my gf (who drives the car for her work) that it's normal. Four. Different. Times. The last time back in February, I even called them up to talk to the head tech, and liaised with FordCustomerCare here in the forums - we were given conflicting info on whether or not the mechanics had taken a look at the bell housing or the clutch. At the advice on area CS rep, we took it to Arlington Heights Ford, who immediately asked a mechanic to raise the car. He took one look at the bell housing, and beckoned me over. The moment of truth: https://skydrive.live.com/redir?resi...Drkt6dOMhlVsLM

Finally, we had the clutch pack replaced, and they told my gf that the clutches were pretty badly contaminated, and that "there's no reason why the previous dealer wouldn't have caught this". The car now drives like new, feels really responsive, and doesn't slip it's way out of first gear.

Also, Golf Mill replaced our wiper blades with 22 and 19" blades, instead of 28" ones, because they had mistaken our car for a 2011 MY. In other words, try taking your cars to other dealers, and ask your area CS rep if they have one they could recommend in the area.
Another successful clutch replacement story (mine is similar). For all those still getting the "it's normal" lame response from their dealer, here's more evidence to the contrary. Any dealer still balking on this warranty repair is really pushing the envelope.
Sprint is offline  
    Reply With Quote
Old 03-07-2013, 07:05 PM   #233
2008 Ford Focus
Focus Enthusiast
 
Join Date: Nov 2011
Fan#: 91826
Location: Philadelphia Area, PA
What I Drive: 2008 Focus SES 5 speed

Posts: 256
FF Reputation: 0 2008 Ford Focus Newbie
Buy-Sell-Trade Rating: (0)
Good job kltye! I am glad your gf's car is running right. Persistence pays.
2008 Ford Focus is offline  
    Reply With Quote
Old 03-08-2013, 02:05 PM   #234
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,193
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by kltye View Post
... The car now drives like new, feels really responsive, and doesn't slip its way out of first gear...
This is fantastic news, kltye. I'm so happy to hear that you and your girlfriend are enjoying your Focus again!

Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote
Old 03-09-2013, 10:02 AM   #235
snow12
Focus Enthusiast
 
Join Date: Jan 2013
Fan#: 108999
Location: Not Ava, United States
What I Drive: Car

Posts: 247
FF Reputation: 1 snow12 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by kltye View Post
I've been lurking these forums since July 2012, which is when my girlfriend and I bought a used (Red Candy) Focus SEL, manufactured in May 2011. Long story short, we soon experienced clutch slipping when taking off from standstill, and going up the slopes in parking garages was downright embarrassing with the loss of power and shuddering, and at times almost felt like the car was going to stall.

We took it in to Golf Mill Ford here in Chicago (am I allowed to mention dealer names?), who proceeded to tell my gf (who drives the car for her work) that it's normal. Four. Different. Times. The last time back in February, I even called them up to talk to the head tech, and liaised with FordCustomerCare here in the forums - we were given conflicting info on whether or not the mechanics had taken a look at the bell housing or the clutch. At the advice on area CS rep, we took it to Arlington Heights Ford, who immediately asked a mechanic to raise the car. He took one look at the bell housing, and beckoned me over. The moment of truth: https://skydrive.live.com/redir?resi...Drkt6dOMhlVsLM

Finally, we had the clutch pack replaced, and they told my gf that the clutches were pretty badly contaminated, and that "there's no reason why the previous dealer wouldn't have caught this". The car now drives like new, feels really responsive, and doesn't slip its way out of first gear.

Also, Golf Mill replaced our wiper blades with 22 and 19" blades, instead of 28" ones, because they had mistaken our car for a 2011 MY. In other words, try taking your cars to other dealers, and ask your area CS rep if they have one they could recommend in the area.
Great job getting it taken care of! There is no reason for these service departments to be so lazy...I mean its their freaking job
snow12 is offline  
    Reply With Quote
Old 03-09-2013, 10:26 AM   #236
snow12
Focus Enthusiast
 
Join Date: Jan 2013
Fan#: 108999
Location: Not Ava, United States
What I Drive: Car

Posts: 247
FF Reputation: 1 snow12 Good Standing Member
Buy-Sell-Trade Rating: (0)
UPDATE:

Hello all! I know i've been away for a while but here is a quick update.

The transmission is working much better as I stated earlier. I have also noticed the mileage has went up dramatically. From 24 to 31! The car definitely has that "click" into gear now rather than the "slide" feeling it used to. So much better on that front.

Other things have started to happen though. The first and most annoying one is the MyFord Touch system skipping songs randomly, right in the middle of me jamming and shiz!!! Not cool That thing is always wonky so I guess I will just have to deal with that.

There is also this weird noise coming from the front when I go over bumps; which is apparently a common issue according to the thread on FF

I have some things planned for her now

OEM rear wing, FSWorks Exhaust, Intake and a tune if its ever available. Definitely some new wheels too!
snow12 is offline  
    Reply With Quote
Old 03-09-2013, 10:40 AM   #237
snow12
Focus Enthusiast
 
Join Date: Jan 2013
Fan#: 108999
Location: Not Ava, United States
What I Drive: Car

Posts: 247
FF Reputation: 1 snow12 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by PratoN View Post
Sounds like I need to find a better service department.
Come visit me and you can go to my dealer

It took like 6 trips for them to even realize there was a problem though. They did change my oil for free and apologized for not getting it fixed for me earlier. So the dealer themselves are not on my shit list now, Ford however well...
snow12 is offline  
    Reply With Quote
Old 03-11-2013, 02:23 PM   #238
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,193
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by snow12 View Post
UPDATE:

Hello all! I know i've been away for a while but here is a quick update.

The transmission is working much better as I stated earlier. I have also noticed the mileage has went up dramatically. From 24 to 31! The car definitely has that "click" into gear now rather than the "slide" feeling it used to. So much better on that front...

There is also this weird noise coming from the front when I go over bumps...
Great news about your transmission, snow12! I recommend mentioning the noise to your dealer the next time you drop by; they can get it diagnosed and repaired for you.

Regarding MyFord Touch concerns, I suggest contacting my colleague, Jaclyn, who is on these forums under the name FordIVTTeam. She assists with all in-vehicle technology concerns.

Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:06 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.