XCAL2 Data Log issues, now PATs - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > Focus Tuning Chat

Focus Tuning Chat Discuss performance tuning options for your Ford Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 03-10-2013, 08:04 PM   #1
USARice
Focus Addict
 
USARice's Avatar
 
Join Date: May 2008
Fan#: 56127
Location: LaCrosse, WI
What I Drive: 2005 Silver ST, DD and AutoX

Posts: 621
FF Reputation: 1 USARice Good Standing Member
Buy-Sell-Trade Rating: (4)
XCAL2 Data Log issues, now PATs

So I got this unlocked XCAL2 previously used on another 2.3L 5spd, bought it with my F2 header and K&N FIPK. When I installed the FIPK I loaded the tune file just for schitts and grins. It downloaded my stock ecm program fine and uploaded the tune. Took it for a spin for a couple miles and turned around because it was bucking in the 4k to 5k range, plus I wasn't too happy about the fact that the tune included perm TC disable. My guess is the bucking was becasue it was tuned for the header and without it the exhaust wasn't being expelled fast enough. So I returned it to stock and just last night contacted Tom for a new tune. While I am waiting for a response I decide to try some data logging. I finally got things to link up but LiveLink said "Loading Stock Parameters......" in the lower corner and stayed that way awhile. I canceled the program and decided to try to load the tune file again to see what would happen if I tried to datalog that file. The program loaded fine but this time when I went to start the car the PATs light was blinking like crazy and the car wouldn't start. Okay, wierd, so I returned to stock with the same results. Disconnected the battery for awhile and tried again. Same results. Tried a couple more times to return to stock and basically I have a dead car in the garage. Sent SCT a message to see if they can help me and sent a PM to our SCT contact on here. I really don't want to pay to have this thing towed into Ford to be reflashed because there goes my money for my tune from Tom. I looked online and the instructions for restoring the stock tune which was supposedly backed up on my computer and the Dump.exe file didn't exist in my LiveLink folder.

So lets say I have no interest in ever returning the car to stock; can Tom just write me a program and include PAT's disable? I tried pulling the PATs fuse but that did absolutely nothing (wishful thinking I suppose).

Please help, while a beautiful one, my Focus doesn't make a good paperweight. Interestingly enough I am not getting any DTCs from this.


__________________
No, my avvy isn't a B&W photo....meet Jaz, the car that makes any pic look monochromatic!
USARice is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 03-11-2013, 10:28 AM   #2
USARice
Focus Addict
 
USARice's Avatar
 
Join Date: May 2008
Fan#: 56127
Location: LaCrosse, WI
What I Drive: 2005 Silver ST, DD and AutoX

Posts: 621
FF Reputation: 1 USARice Good Standing Member
Buy-Sell-Trade Rating: (4)
Just thought I would update this since someone else may end up having to search for this in the future. I was able to contact SCT this morning and first they sent me a new stock file which didn't work either, but then they sent me a stock file with PATS disabled and it worked just fine. I even went and had a generic key cut just to make sure and it worked fine. So, while I didn't like not having my car for 18 hours, I saved quite a bit of money by not having to pay dealer price for a new key to be made, I didn't have to pay to have the car towed in for a reflash and I didn't have to pay for a reflash. I cannot speak highly enough about SCT Technical Support. As much as I hate to say it though, our rep here on the forums told me that SCT wouldn't be able to do anything for me and I would have to find someone to write me a stock tune with PATS disable and did not mention that SCT could do it themselves. Thankfully I called them anyways.

SCT FTW!
__________________
No, my avvy isn't a B&W photo....meet Jaz, the car that makes any pic look monochromatic!
USARice is offline  
    Reply With Quote
Old 03-11-2013, 11:26 AM   #3
USARice
Focus Addict
 
USARice's Avatar
 
Join Date: May 2008
Fan#: 56127
Location: LaCrosse, WI
What I Drive: 2005 Silver ST, DD and AutoX

Posts: 621
FF Reputation: 1 USARice Good Standing Member
Buy-Sell-Trade Rating: (4)
Originally Posted by USARice
Hi,

I sent an email to SCT directly but I'm hoping you get this before business hours. I tried to return my car to stock with my XCAL2 and it said it was successful but now the car won't start and the PATs light just blinks rapidly. I tried reloading the old tune but the same thing happens. So now I've got a dead car. Please help.

Cory Janda


Response:


Unfortunately there is nothing we can do remotely with the X2. This is part of the reason we no longer sell this device. Was this device only used on your vehicle? Was this the first time you had returned it to stock using the device?

From me:

No, but I had previously used the device with the tune that was on it from another 2.3l manual Focus and had no issues with PATS and returned to stock with no issues with PATS. Oh and it arrived partially unlocked and I found the instructions on a Powerstroke forum on how to finish unlocking it. Only then was I allowed to load the tune in my car but after a short drive I returned it to stock because there was a major hole between 4 and 5k.

Response:

Depending on how the device was used (if it was unlocked or not..the X2 required multiple steps for it to be truly unlocked) incorrect PATS information may have been copied over. You can try getting a custom tune file with PATS turned off but not all Focus allow this. How many tune files were on the device? Just a random question but when you try to start it, what is shown on the odometer? Is it just dashes? theft light blinking? Do you have the device connected to the obdII port or not when you try to start the car?

Unfortunately we are dealing with hardware that is close to 10 years old that we stopped supporting and updating probably 5 year ago.

Wish there was more that I could do. Your best bet at this time would be to get a pats disabled tune.

From me after getting the issue resolved through SCT Tech Support:

Mark at SCT wrote me a stock tune with PATS disabled. Worked great. I don't care that its disabled, the light still flashes on the dash when the car is off so that's a theft deterrent. I went and had a generic key cut just to make sure and it worked fine. Thanks for your help and much kudos to Mark.

Cory

Sent from Gods Country


Response:

So you thank me here then call me out on the forums publicly...appreciate that...

Nothing I stated was incorrect. We do not typically send out any sort of custom tune file. That is what our dealer network is for. I didn't offer or mention sending a file as there were still some unanswered questions and I didn't want to put you in a situation where you would have to have pats disabled from now on with any tune file you get from one of our dealers.


I will let our members be the judge of whether I was calling our rep out publically or not. He asked alot of questions and was helpful in that respect which is why I thanked him (although the Tech Support rep asked none of these questions and just helped me) but his solution as he stated a couple times was that I should find someone to write me a tune with PATS disable, not that SCT themselves could help me with a "piece of equipment that is 10 years old and we stopped supporting almost 5 years ago".
__________________
No, my avvy isn't a B&W photo....meet Jaz, the car that makes any pic look monochromatic!
USARice is offline  
    Reply With Quote
Old 03-11-2013, 08:56 PM   #4
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,392
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
I don't follow any of this...


You mess up a car buy thinking you can tune 2 with the same tool. 'Unlocked' isn't what most think it is. It's not simply flashing 1 car back to stock to flash another, it needs to be 'formatted' also; which is software most don't have anymore (only people who do are those who had/have and old PRP disc ;) and SCT.

So ghost data from the old car gets written to the new one, Car bricks, you go into panic mode. I don't know where this public callout comes from. I've seen the same thing happen before and SCT has bent over backwards to help, for free mind you. Actually happened to a buddies truck as we where tuning it. Sucked and we had to tow it home. He got lucky and had an X3 and the tech just did a remote reflash and it was back to normal.
Thing is, he's also using a tuner that was used. IIRC he said they also reformatted the X3, so it should be good now.


Anyways, always be wary of used electronics. That's just common sense.
iminhell is offline  
    Reply With Quote
Old 03-11-2013, 09:25 PM   #5
USARice
Focus Addict
 
USARice's Avatar
 
Join Date: May 2008
Fan#: 56127
Location: LaCrosse, WI
What I Drive: 2005 Silver ST, DD and AutoX

Posts: 621
FF Reputation: 1 USARice Good Standing Member
Buy-Sell-Trade Rating: (4)
The previous owner returned to stock. It came in what's referred to as "partially locked". I finished unlocking it. The PATs issue actually stemmed from when I was trying to datalog. In an attempt to fix the situation I reloaded the "Tune" that was in there from before that my car did run on with no PATS issues, just didn't run "right". Still had PATS problem. "Return to Stock".....still had PATS issue. I didn't do anything that hadn't worked before. But yes, obviously some ghost data was stored. Sucks, lesson learned. The tech I got on the phone this morning, Mark A, was VERY helpful. He unbricked my ECU by sending me a "stock" program. First we tried a regular one which didn't work, then we tried the same program with PATS disabled. Car started right up no issues. I cannot thank that tech enough for saving me the money of having to tow the thing in and have Ford do it. The point of all of this (and the callout) was this; I also sent a PM to our SCT rep here on the forums and he told me that SCT could not help me. Had I just listened to him and not also contacted SCT directly I would have had the thing towed in today because I was told SCT could not help me but that I would have to have someone else write me a custom tune with PATS disable. I was planning on getting a custom tune anyways (which I did from Tom today) but I didn't know Tom would be that fast and I needed my car back on the road today.

I have nothing but love for SCT as a whole and I give their tech support two thumbs up, but our rep here on the forums was not overly helpful. He responded to my cry for help over something that obviously wasn't SCT's fault, yes, and for that I am thankful, but he did nothing to actually help me solve the problem. Mark A did. That's what that last post was about.

Now off to send Tom my datalogs so we can get the beast running right. :)
__________________
No, my avvy isn't a B&W photo....meet Jaz, the car that makes any pic look monochromatic!
USARice is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:37 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.