List a lesson learned - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Discussions > Ford Focus & General Car Chat

Ford Focus & General Car Chat Discussion Forum relating to nonspecific Ford Focus models, car purchasing, auto industry news and any car talk.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-19-2013, 10:54 PM   #11
miklosszoke
Focus Rookie
 
Join Date: Feb 2011
Fan#: 83043
Location: Salt Lake City, UT
What I Drive: 2010 Blue SES

Posts: 7
FF Reputation: 1 miklosszoke Good Standing Member
Buy-Sell-Trade Rating: (0)
Could not find a better thread, this is about how to fix an issue when Advance Trac icon pops up on the dashboard for seemingly no reason. To put it short: clean your ABS sensor!

I have a 2010 Focus SES that has Advance Trac. This is Ford's ESP + anti-slip system, works well on ice for me. When the system thinks one of the wheels is turning faster/slower than the rest it assumes the hell will break loose soon, so it tries to help by dropping engine power, breaking the wheel it thinks make sense, etc. I felt like the ABS is far more sensitive as well.

Anyway, on a sunny day for no reason it kicked into action while I was taking a 90deg turn with normal, slow speed, say 15mph. The road was dry, so I was surprised. The icon was on, power lost, heavy stuttering from everywhere. I had to turn the engine off to get rid of it. This fun reoccured again, so I drove to an empty parking lot and tried to figure out what exactly triggers it. Turns out, no matter which direction, but a 90+ degree turn with 5+ mph starts it.
I've read several articles about it, could not find anything meaningful, hence my post. Some mentioned the mechanic reprogrammed the ABS, some had to replace the whole ABS unit, some could not fix it ever.
Before I went to a dealership I have dismounted and cleaned all 4 ABS sensors and the issue is gone, did not cost me a $.

Better remove the wheel, you will have easier access. Then find the sensor, which is at the end of a thin black cabel. Unscrew the single bolt holding the sensor, apply some gentle force to remove it and clean the sensor, especially the metal part. Put is back. Do it on the drum brakes as well of course. My sensors were not really dirty, at least I was expecting worse, but seemingly the sensor is a very sensitive electromagnet, probably some small metal dirt could disturb it.

Hope it helped.
miklosszoke is offline  
    Reply With Quote
 

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.