Scariest Moment Yet - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-09-2013, 05:26 PM   #1
cjanderson629
Focus Enthusiast
 
cjanderson629's Avatar
 
Join Date: Nov 2011
Fan#: 91376
Location: Amherst, OH
What I Drive: 2012 Sterling Grey Focus Ti

Posts: 148
FF Reputation: 1 cjanderson629 Good Standing Member
Buy-Sell-Trade Rating: (0)
Thumbs down Scariest Moment Yet

Driving home at 2am this morning on the turnpike, the MFT screen froze. A flash showed up on the screen. It was an error message that looks like it would appear on a Windows PC. That quickly disappeared. Instantly, the MFT screen went black. No power, no music, nothing. All shut off. After that, the mini screen in the gauge cluster went black, followed by the LED backlights of the gauges, followed by the ambient lighting. I quickly pulled over thinking something was seriously wrong. I shut the car down, waited a few minutes, turned it back on and the MFT screen said Sync, then performed "Scheduled system maintenance." The loading bar did not finish, the screen went black for 5 minutes, then Sync reappeared, then the system maintenance completed. The rest of the way home was fine. This is the second time this week that the MFT screen has frozen and performed this update. But this is the first time everything turned off on me. Any ideas why this happened?


cjanderson629 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-09-2013, 09:09 PM   #2
Kabigon
Focus Fanatic
 
Join Date: Jul 2011
Fan#: 88299
Location: Torrance, CA
What I Drive: 2012 sterling gray Titanium

Posts: 3,174
Points 4,070, Level 40
Points: 4,070, Level: 40 Points: 4,070, Level: 40 Points: 4,070, Level: 40
Level Up 60% Completed
Level up: 60% Level up: 60% Level up: 60%
Forum Activity 29%
Activity: 29% Activity: 29% Activity: 29%
FF Reputation: 11 Kabigon Great Standing Member
Buy-Sell-Trade Rating: (0)
Hmmm...

I can tell you this much: MFT and the IPC (Instrument Panel Cluster) have nothing in common with the exception that they are connected to the same data (CAN) bus (and of course both require +12V).
__________________
I am Kabigon and I approve this message.
Kabigon is offline  
    Reply With Quote Quick reply to this message
Old 02-09-2013, 11:03 PM   #3
AZfocus2012
Focus Addict
 
AZfocus2012's Avatar
 
Join Date: Dec 2011
Fan#: 92484
Location: Apache Junction, AZ
What I Drive: 2012 White Platinum SEL 303A Focus

Posts: 658
FF Reputation: 2 AZfocus2012 Good Standing Member
Buy-Sell-Trade Rating: (0)
My MFT did the same scheduled maintenance reboot/black screen twice in the last week also. The driver info center didn't do anything out of the ordinary. I figure this is Microsoft's way of saying you need to install the update that just came out.
AZfocus2012 is offline  
    Reply With Quote Quick reply to this message
Old 02-10-2013, 12:04 AM   #4
84Camaro_L69
Focus Enthusiast
 
Join Date: Nov 2012
Fan#: 105844
Location: Augusta, GA
What I Drive: 2012 Diamond Tri Coat White SEL HB

Posts: 125
FF Reputation: 1 84Camaro_L69 Good Standing Member
Buy-Sell-Trade Rating: (0)
Interesting. Mine screen did the same thing back in December, but it didn't affect anything else on the car. I just got the letter in the mail about the update. I guess I'll do it to ensure I don't have another Sync reboot. What sucked was it was giving me directions in the middle of rebooting. Needless to say I got lost in an unfamiliar downtown city that I had never been in before until the system came back online. I'm glad to see someone else have it happen.
__________________
Stock with factory Sony 10-speaker HD stereo and 4-wheel disc brakes.
84Camaro_L69 is offline  
    Reply With Quote Quick reply to this message
Old 02-10-2013, 11:21 AM   #5
cjanderson629
Focus Enthusiast
 
cjanderson629's Avatar
 
Join Date: Nov 2011
Fan#: 91376
Location: Amherst, OH
What I Drive: 2012 Sterling Grey Focus Ti

Posts: 148
FF Reputation: 1 cjanderson629 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have the new update installed. But like I said, the system maintenance loading screen has come on twice in 3 days. No one else with the update is having this issue?
cjanderson629 is offline  
    Reply With Quote Quick reply to this message
Old 02-10-2013, 11:24 AM   #6
AZfocus2012
Focus Addict
 
AZfocus2012's Avatar
 
Join Date: Dec 2011
Fan#: 92484
Location: Apache Junction, AZ
What I Drive: 2012 White Platinum SEL 303A Focus

Posts: 658
FF Reputation: 2 AZfocus2012 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by cjanderson629 View Post
I have the new update installed.
Oh, maybe I will wait then before updating mine?
AZfocus2012 is offline  
    Reply With Quote Quick reply to this message
Old 02-11-2013, 11:24 AM   #7
Pendarus
Focus Enthusiast
 
Pendarus's Avatar
 
Join Date: Jan 2012
Fan#: 94411
Location: Fullerton, CA
What I Drive: 2012 Sonic Blue Titanium 5dr

Posts: 136
FF Reputation: 2 Pendarus Good Standing Member
Buy-Sell-Trade Rating: (0)
Sounds like some kind of low voltage situation. The MFT failed first, possibly because it is more sensitive to voltage drops. I would take it to the dealer and get the charging system checked.
__________________
Sonic Blue Titanium 5dr Titanium Handling Package
Ordered: 01/28/12
Vin: 02/20/12
Build Date: 03/06/12
Delivery Date: 03/30/12
Pendarus is offline  
    Reply With Quote Quick reply to this message
Old 02-12-2013, 09:10 PM   #8
OakvilleFocus
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108912
Location: Oakville, Canada
What I Drive: 2012 Grey Titanium

Posts: 7
FF Reputation: 1 OakvilleFocus Good Standing Member
Buy-Sell-Trade Rating: (0)
Welcome to MFT, Ford took a big risk putting this much tech into a car. Sadly it did not pay off. I've had MFT since day one in my 2011 Edge. Have recently purchased a 2013 Focus Ti, I'm obviously not that disturbed by it.

It took them 3 major revisions to get it anywhere near stable. As a professional software developer, I still notice significant platform issues that shouldn't exist in such a heterogeneous environment. Microsoft really screwed them over on this one, and I where Ford I'd be looking to sick some lawyers and see if I can partner with Google and have a major PR win both ways.

If anyone from Ford is listening, its time to release this to the real innovators of any platform - the open source community. They'll save your bacon, or what's left of it when it comes to the MFT system.
OakvilleFocus is offline  
    Reply With Quote Quick reply to this message
Old 02-12-2013, 09:34 PM   #9
Kabigon
Focus Fanatic
 
Join Date: Jul 2011
Fan#: 88299
Location: Torrance, CA
What I Drive: 2012 sterling gray Titanium

Posts: 3,174
Points 4,070, Level 40
Points: 4,070, Level: 40 Points: 4,070, Level: 40 Points: 4,070, Level: 40
Level Up 60% Completed
Level up: 60% Level up: 60% Level up: 60%
Forum Activity 29%
Activity: 29% Activity: 29% Activity: 29%
FF Reputation: 11 Kabigon Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by OakvilleFocus View Post
Welcome to MFT, Ford took a big risk putting this much tech into a car. Sadly it did not pay off.
The problem with the OP's car was clearly not caused by the MFT system.

"...the mini screen in the gauge cluster went black, followed by the LED backlights of the gauges, followed by the ambient lighting."



Quote:
Originally Posted by OakvilleFocus View Post
Microsoft really screwed them over on this one,
Why would you say that considering that MFT is not a Microsoft product? That doesn't make sense.
__________________
I am Kabigon and I approve this message.
Kabigon is offline  
    Reply With Quote Quick reply to this message
Old 02-12-2013, 09:52 PM   #10
OakvilleFocus
Focus Rookie
 
Join Date: Jan 2013
Fan#: 108912
Location: Oakville, Canada
What I Drive: 2012 Grey Titanium

Posts: 7
FF Reputation: 1 OakvilleFocus Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Kabigon View Post
Why would you say that considering that MFT is not a Microsoft product? That doesn't make sense.
Well it is - It uses Windows CE as its base operating system, a Microsoft product. Many of the stability issues arise from a poor Bluetooth stack, and many other general issues with the Windows CE kernel.

Moreover you'd think Microsoft would be keen on helping Ford get a reasonable UI up and running to showcase their mobile platform, instead they where left to linger with a 3rd party solution on top of CE which just compounded issues.

End of the day Microsoft's PR machine will try to distance themselves from this whole debacle. To me that just screams - when you choose Microsoft anything - expect this level of support when something this major falls apart.

If I was Balmer, I would put my best engineers on this and make damn sure Ford had the best telematics experience bar none.

Anyways if there are any Ford folks monitoring this thread, PLEASE add a soft reset button buried in the options. I'm really getting tired of having to pull Fuse 29 in my Edge. So far its been fine on my Focus, but I don't see how a soft reset would hurt things.
OakvilleFocus is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:46 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.