Wrong SVT Coolant Temp Sensor? - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-05-2013, 07:15 PM   #1
dross03focus
Focus Enthusiast
 
dross03focus's Avatar
 
Join Date: Mar 2009
Fan#: 63537
Location: Maysville, KY
What I Drive: 2004 Sonic Blue SVT Focus

Posts: 152
FF Reputation: 1 dross03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
Wrong SVT Coolant Temp Sensor?

My old sensor broke when I was persuading it back into the thermostat housing after replacing the O-Ring. I went to Advance and told them it was an SVT and they gave me part number BWD WT5067. It looks right, but from what I am seeing online it is for the SOHC not the SVT DOHC. Is this the wrong sensor?

What throws me off is it says this is for the SOHC in 2004, but fits the 2002-2003 SVT DOHC. Did the motors change some over the year?


__________________
Bagged 93 Ranger
Bagged and Bodied 72 Datsun PL521
99 S10 6/7 Static Drop
04 SVT Focus
Follow Me on Instagram @dross93ranger
dross03focus is online now  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 02-06-2013, 06:22 AM   #2
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,556
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
zetecDon is offline  
    Reply With Quote
Old 02-06-2013, 10:02 AM   #3
dross03focus
Focus Enthusiast
 
dross03focus's Avatar
 
Join Date: Mar 2009
Fan#: 63537
Location: Maysville, KY
What I Drive: 2004 Sonic Blue SVT Focus

Posts: 152
FF Reputation: 1 dross03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
I installed it, started the car and let it run in the garage for about 20 minutes and the cooling fan kicked on twice and temperature gauge was pointed straight up. I have not driven it yet due to clutch being out. Should I get the other sensor or will this one hurt anything to run? I will have the clutch installed in 2 weeks and start daily driving the car again.
__________________
Bagged 93 Ranger
Bagged and Bodied 72 Datsun PL521
99 S10 6/7 Static Drop
04 SVT Focus
Follow Me on Instagram @dross93ranger
dross03focus is online now  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:30 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.