Help me diagnose this engine problem? - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-30-2013, 04:51 PM   #1
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
[SOLVED] Help me diagnose this engine problem?

2004 ZTS Sedan, 2.3L PZEV, auto-trans

A couple weeks ago I did the Stealth CAI mod based on BlazingCopper's writeup here: http://www.ineedawebsite.com/Blazing...lth%20CAI.html

It has been great!

However just today I fired up the car and it was sputtering & puttering - and the Check Engine light started BLINKING. I had not left the driveway, so I pulled it into the garage, shut it off, and looked up the blinking. A misfire condition... great. :(

I checked when I last changed the spark plugs - over 40k miles ago. I had a box of Autolite XP103s on hand, so I checked the gaps at .050~.055-ish, disconnected my battery, and installed the new plugs.

I reconnected the battery, fired it up - no Check Engine light at all - not solid, not blinking. I let it idle for a few minutes, then drove it to my nearest Advance Autoparts. It still had the sputter during the drive, but no Check Engine light, there & back round trip about 8 miles.

The guy at Advance plugged into my diagnostic port - no static codes (I had cleared them evidently when I disconnected the battery) and the live data all checked OK with the car sitting, at idle and held at 3k rpm for a minute or so.

He asked me to pop the hood with it running, and he stated it sounded like something was sucking air where it shouldn't - a vacuum line, intake manifold, etc. I noticed the hissing too - it seems to be coming from the passenger side of the engine compartment, so I guess it's not the sound of air moving thru the new Stealth CAI setup.

I took these three videos when I returned home, idling in my driveway.

Inside the car watching the tach:
http://www.youtube.com/watch?v=1ghUNjJcE6I

At the tailpipe - oh yah sputtering!
http://www.youtube.com/watch?v=CXKsr9alzy4

Hood up, engine compartment:
http://www.youtube.com/watch?v=DedTOAHzNeo

Any ideas on what I should do next?

Thanks!

-Jake



Last edited by JakeTheSnake; 02-02-2013 at 02:44 PM. Reason: Changed title to indicate problem solved
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-30-2013, 05:33 PM   #2
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,918
Points 12,814, Level 73
Points: 12,814, Level: 73 Points: 12,814, Level: 73 Points: 12,814, Level: 73
Level Up 91% Completed
Level up: 91% Level up: 91% Level up: 91%
Forum Activity 19%
Activity: 19% Activity: 19% Activity: 19%
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat" to better help you.
zetecDon is offline  
    Reply With Quote Quick reply to this message
Old 01-30-2013, 06:58 PM   #3
Fattie
Focus Addict
 
Join Date: Apr 2007
Fan#: 46016
Location: rockland, ME
What I Drive: 6 Duratec Focus

Posts: 1,477
Points 8,431, Level 61
Points: 8,431, Level: 61 Points: 8,431, Level: 61 Points: 8,431, Level: 61
Level Up 94% Completed
Level up: 94% Level up: 94% Level up: 94%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 5 Fattie Good Standing Member
Buy-Sell-Trade Rating: (6)
im guessing the COP is bad.
__________________
6 Duratec Focus

3 04 zx4's
2 05 zx3's
1 03 zx3
Fattie is offline  
    Reply With Quote Quick reply to this message
Old 01-30-2013, 07:07 PM   #4
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
One (or more) of the 4 Coil-On-Plug packs eh? I'm going to check those tomorrow - definitely buying new boots for them at least.
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 07:30 AM   #5
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
Today I'm going to replace the COP boots, and clean the MAF sensor with CRC MAF Sensor Cleaner.

/fingerscrossed
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 11:57 AM   #6
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
I just bought this on Amazon:

http://www.scantool.net/obdlink-mx.html

I'll use it with my Windows PC and/or my Android devices via Bluetooth to help diagnose my car. It will be handy to have for all three of our vehicles.

I should have it tomorrow.
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Old 01-31-2013, 06:09 PM   #7
6SPD_soul
Focus Addict
 
6SPD_soul's Avatar
 
Join Date: Feb 2008
Fan#: 53637
Location: Soldiers Grove, WI
What I Drive: 2003 Comp Orange EAP SVT

Posts: 1,468
Points 2,489, Level 30
Points: 2,489, Level: 30 Points: 2,489, Level: 30 Points: 2,489, Level: 30
Level Up 26% Completed
Level up: 26% Level up: 26% Level up: 26%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 24 6SPD_soul Great Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by JakeTheSnake View Post
I just bought this on Amazon:

http://www.scantool.net/obdlink-mx.html

I'll use it with my Windows PC and/or my Android devices via Bluetooth to help diagnose my car. It will be handy to have for all three of our vehicles.

I should have it tomorrow.
Did you buy any add-on software? I don't know how useful that's going to be without it. It looks like without software you're only able to read/clear codes. I think I might buy from them also, but get the wired USB version and spend more on software add-ons.

EDIT: Nevermind, it looks like the base software package should be pretty useful.
6SPD_soul is offline  
    Reply With Quote Quick reply to this message
Old 02-01-2013, 02:27 PM   #8
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
VERY useful!

I've only just used the OBDLink Android app during my lunch break, and I have a distinct path to follow now.

P2004 IMRC stuck open.

Doing some searches around here and the internet in general, this seems a very common problem that crops up shortly after installing a stealth CAI modification.

So when I get home this evening I'll check the IMRC according to my Ford Workshop Manual - Powertrain Control/Emissions Diagnosis 2004:On Board Diagnostics, Section 4, sub-sections HU15 thru HU41, IMRC troubleshooting steps.
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Old 02-02-2013, 02:40 PM   #9
JakeTheSnake
Focus Enthusiast
 
Join Date: Apr 2012
Fan#: 97620
Location: Battle Creek, MI
What I Drive: 2004 Twilight Blue ZTS, 2.3L PZEV

Posts: 71
FF Reputation: 1 JakeTheSnake Good Standing Member
Buy-Sell-Trade Rating: (0)
Fixed!

The Intake Manifold Runner Control is supposed to move the tumble flaps in one position at under 3k rpm, and the other position at 3k rpm and up.

My IMRC was sitting in the "relaxed" > 3k rpm position even at idle.

On top of the intake manifold are two solenoids - the driver's side solenoid turns vacuum on & off to the IMRC.

When the solenoid is open, the IMRC energizes, and puts the tumble flaps in the low RPM position. When engine RPM hits 3000, the PCM closes that solenoid, the IMRC loses vacuum, and it relaxes.

My IMRC wasn't energizing at low RPM for some reason.

I disconnected and checked vacuum lines in the system, reseated them; then checked and cleaned electrical connectors at the IMRC solenoid, the IMRC itself, and the Intake Air Control valve.

I reconnected everything, cleared codes in Key-ON Engine-OFF, & started it up.

The IMRC energized, the idle smoothed right out - I took her for a drive about 10 miles, all is well.

The ODBLink was the key - with that + the ODBLink Android app on my smartphone I had the data I needed to properly troubleshoot.

I'm an IT professional - gimme some data about what's happening and I'll fix anything.


EDIT:
I wanted to change the Topic Title to "[SOLVED] Help me diagnose this engine problem?" - but I don't see the control for that... am I missing something?
I managed to change the Title of my first post, good enough I guess! Thanks all!
JakeTheSnake is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:33 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat