Electrical issue - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-09-2013, 06:51 PM   #1
SWEGER
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
Electrical issue

I've searched on this issue before, but everything I have found to be a cause of it I have already fixed.

I have a flickering-type issue with my 03 SVT. While at idle, my lights on my dash, map lights, brake lights, etc flicker (kind of, they never actually go out, but they pulsate between bright and dim). I have replaced my battery, alternator (new, not rebuilt), alternator connector (pigtail), and battery terminal connectors. I had Auto Zone check out my battery and alternator, and they said both were good. All my grounds seem to be tight and clean. I am at a dead end on this...any insight would be greatly appreciated.


__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-09-2013, 11:25 PM   #2
SVTFOCI03
Focus Rookie
 
SVTFOCI03's Avatar
 
Join Date: Aug 2012
Fan#: 103052
Location: Fresno, CA
What I Drive: 2003 Silver Svt Focus

Posts: 4
FF Reputation: 1 SVTFOCI03 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have the same issue and replaced the alternator twice and put an optima in it... I heard if you turn the dimmer switch down a little from the max it fixes it but it didn't change mine...
SVTFOCI03 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2013, 01:44 AM   #3
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,930
Points 12,824, Level 73
Points: 12,824, Level: 73 Points: 12,824, Level: 73 Points: 12,824, Level: 73
Level Up 94% Completed
Level up: 94% Level up: 94% Level up: 94%
Forum Activity 24%
Activity: 24% Activity: 24% Activity: 24%
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
zetecDon is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2013, 12:04 PM   #4
SWEGER
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
I am thinking that it might be a grounding issue since I redid those at the same time the rest of the electrical work was done. I'm going to redo the main grounds in the engine bay (battery to chassis, engine to chassis, and the other one) and see if that helps. Any suggestions on the gauge and type of wire needed for this?
__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote Quick reply to this message
Old 01-11-2013, 12:59 PM   #5
cbf1989
Focus Rookie
 
Join Date: Dec 2012
Fan#: 106860
Location: Louisville, KY
What I Drive: 2004 Ford Focus ZTS 2.4L

Posts: 8
FF Reputation: 1 cbf1989 Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm actually going through the same exact issue right now. I havnt changed anything out yet except the battery and ofcourse it still does the flickering. Thanks for letting us know what you did so far. Saves me from having to change all that out myself.
My next step was going to change out all the ground and such as well, but like you asked, what is the best gauge to use?
cbf1989 is offline  
    Reply With Quote Quick reply to this message
Old 01-12-2013, 08:40 PM   #6
NSTSVT
Focus Rookie
 
Join Date: Jun 2004
Fan#: 9552
Location: Maryland
What I Drive: 2004 P-Blk. SVT 5-DR

Posts: 15
FF Reputation: 1 NSTSVT Good Standing Member
Buy-Sell-Trade Rating: (0)
Wow. I thought I was on my own w this, as I thought it to be possibly due to a previous fender bender.
SYMPTOM:My dash lights (not radio or dials lighting) will flicker or drain or almost no lighting, again only speedo/ rpm location. As stated if I catch while it starts, I can turn down the illumination potentiometer or dial and it usually holds. I have also a problem with the horn going in op ( perhaps electrically related? )
QUESTION: What/where is the wiring or junction related to the power for the dash and the interior dials? Has anyone figured it to be tied to the illumination dial (potentiometer)?

Any assistance appreciated
__________________
Acts1:7-11 " in like manner" :-)
NSTSVT is offline  
    Reply With Quote Quick reply to this message
Old 01-18-2013, 12:22 PM   #7
smallblockfever
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 210
Points 2,229, Level 28
Points: 2,229, Level: 28 Points: 2,229, Level: 28 Points: 2,229, Level: 28
Level Up 53% Completed
Level up: 53% Level up: 53% Level up: 53%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
not meaning to thread jack here, but im like the rest of you guys and have the same issue.
It used to do it really bad, then i replaced the alternator and it was clearly flickering with the stereo, so i replaced the battery. Fixed a majority of the problem, but its still flickering.
My mechanic says its the ECU playing tricks because of my broken 02 sensors.
But I have an inkling that its the plethora of wires going to my battery.


see my svt wasnt exactly cared for when i bought it.... shes getting the love she needs now but im having to piece it back together. On that note, theres about 6 wires running to my battery, three at each terminal, and half of the wires are crudely spliced together. My thought here is that I need to fish down these wires and make sure it's all solidly connected.

Im gonna suggest that y'all do the same and just make sure your battery connections are solid and wont give you any problems at any end of the cables.
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Old 01-18-2013, 05:58 PM   #8
svtguy88
Focus Fanatic
 
svtguy88's Avatar
 
Join Date: Sep 2004
Fan#: 13476
Location: Menomonee Falls, WI
What I Drive: 2003 Infra Red SVT

Posts: 2,984
Points 8,577, Level 62
Points: 8,577, Level: 62 Points: 8,577, Level: 62 Points: 8,577, Level: 62
Level Up 43% Completed
Level up: 43% Level up: 43% Level up: 43%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 17 svtguy88 Great Standing Member
Buy-Sell-Trade Rating: (2)
Replace your grounds (battery to chassis and engine to chassis) with something less meh than factory cables. I have this problem on mine, but it only shows up when my system is up pretty loud.
svtguy88 is offline  
    Reply With Quote Quick reply to this message
Old 01-29-2013, 12:30 AM   #9
Ptreezx3
Focus Enthusiast
 
Ptreezx3's Avatar
 
Join Date: Apr 2012
Fan#: 97773
Location: Lorain, OH
What I Drive: 2003 red svt, 06 blue escape,

Posts: 63
Points 61, Level 1
Points: 61, Level: 1 Points: 61, Level: 1 Points: 61, Level: 1
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Ptreezx3 Good Standing Member
Buy-Sell-Trade Rating: (2)
Same issue here. Yet to figure out and it kills me. Sure is something stupid.
Ptreezx3 is offline  
    Reply With Quote Quick reply to this message
Old 02-01-2013, 08:46 PM   #10
baldyredtx
Focus Enthusiast
 
baldyredtx's Avatar
 
Join Date: Jan 2011
Fan#: 82344
Location: San Antonio, TX
What I Drive: 2003 Sonic Blue SVT 4 dr

Posts: 61
FF Reputation: 1 baldyredtx Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm having the same issue. My started after I installed Mach headlights. It is completely random. I have tried the dimmer switch and that does not work. I have a new alternator and battery. I was going to work on the grounds. Where is the engine ground?
__________________
2003 Sonic Blue 4dr SVT
HFC, 2.5" Borla exhaust, drop in K&N, STS
baldyredtx is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:40 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat