HELP!!!!! Turn over, but engine wont start!!!!! - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-14-2012, 05:16 PM   #1
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Philadelphia, PA
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 69
Points 197, Level 3
Points: 197, Level: 3 Points: 197, Level: 3 Points: 197, Level: 3
Level Up 94% Completed
Level up: 94% Level up: 94% Level up: 94%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Exclamation HELP!!!!! Turn over, but engine wont start!!!!!

I was driving my focus earlier today and it would start to sputter on me a lot, and tried to cut out several times. It never did but once i parked it the check engine light came on and i turned the car off. Later when i went to head to work, i tried to start my car and it would turn over, and try to start, but will not fully start.

I have recently replaced the spark plugs, wires, distributer cap, battery, and starter.
I also recently had the alternator checked and it was working perfectly fine. When i turn it to AUX all my lights and accessories come on and work, and the car will turn over, but wont start.

I think this could be a bad fuel pump or pump relay, but I am pretty sure it is fuel system related.

ANY help or input would be greatly appreciated!


__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals
jlawlax1344 is offline  
    Reply With Quote
 

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:50 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat