Engine runs like crap and battery lights on - Page 2 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-27-2012, 04:12 PM   #11
swagfocuswagon
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by jlawlax1344 View Post
Best i have topped my sedan out at thus far was XXX, and I have a 5sp with all the stuff I told you was on it.
I see. Well that aint bad for a 4 cylinder like this one.

Last edited by 1sloho; 11-27-2012 at 07:24 PM.
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-27-2012, 04:14 PM   #12
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Salisbury, MD
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 68
Points 191, Level 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by swagfocuswagon View Post
I see. Well that aint bad for a 4 cylinder like this one.
Noooo not at all, my brothers 2012 3.7l V6 mustang has a hard time hitting XXX and he has a 6spd, aluminum 1 piece driveshaft and more lol. So me hitting the XXX range is amazing to me. But once i get the engine straight, i want to burry the needle and his mustang <3 lol
__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals

Last edited by 1sloho; 11-27-2012 at 07:23 PM.
jlawlax1344 is offline  
    Reply With Quote Quick reply to this message
Old 11-27-2012, 07:24 PM   #13
1sloho
12 years strong
 
1sloho's Avatar
 
Join Date: Jun 2003
Fan#: 111
Location: VA. Beach, VA
What I Drive: '02 zx5

Posts: 6,882
Points 14,413, Level 77
Points: 14,413, Level: 77 Points: 14,413, Level: 77 Points: 14,413, Level: 77
Level Up 91% Completed
Level up: 91% Level up: 91% Level up: 91%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 17 1sloho Great Standing Member
Buy-Sell-Trade Rating: (3)
posts edited. please refrain from posting illegal speed limits.
1sloho is online now  
    Reply With Quote Quick reply to this message
Old 12-01-2012, 09:55 AM   #14
swagfocuswagon
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Okay so I pulled the coil pack the other day and noticed there is a crack in it. Not a big large one but I small one, but its still a crack. I wonder if this could be causing my miss and other problems?
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-01-2012, 01:43 PM   #15
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Salisbury, MD
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 68
Points 191, Level 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Replace that
Quote:
Originally Posted by swagfocuswagon View Post
Okay so I pulled the coil pack the other day and noticed there is a crack in it. Not a big large one but I small one, but its still a crack. I wonder if this could be causing my miss and other problems?
Yes, this very well could be your problem. Replace your coil pack and possibly wires if need be, and that should fix your problem.
__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals
jlawlax1344 is offline  
    Reply With Quote Quick reply to this message
Old 12-01-2012, 05:29 PM   #16
swagfocuswagon
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Alright as soon as I get 75 dollars Im getting a coil pack! Woohooo!
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-01-2012, 05:35 PM   #17
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Salisbury, MD
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 68
Points 191, Level 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by swagfocuswagon View Post
Alright as soon as I get 75 dollars Im getting a coil pack! Woohooo!
Yeah, at least its something simple, and not some ECU issue. Hope it all works out and im in the same boat, i have to wait for my brakes to come in, cause i needed new rotors and pads, so i figured id splurge a little and upgrade them while im at it.
__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals
jlawlax1344 is offline  
    Reply With Quote Quick reply to this message
Old 12-03-2012, 09:21 AM   #18
swagfocuswagon
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Lol Nice. And shit I hope so too. And Shit that reminds me I gotta re-do my front brakes.
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-05-2012, 05:26 PM   #19
jlawlax1344
Focus Enthusiast
 
Join Date: May 2012
Fan#: 99464
Location: Salisbury, MD
What I Drive: 2003-CD Silver-SPI-5spd

Posts: 68
Points 191, Level 3
Points: 191, Level: 3 Points: 191, Level: 3 Points: 191, Level: 3
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jlawlax1344 Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by swagfocuswagon View Post
Lol Nice. And shit I hope so too. And Shit that reminds me I gotta re-do my front brakes.
Yep, i have cross drilled and slotted rotors and ceramic pads, and doing the rear drum to disc conversion soon. Then either a NA build for fun or boost, havent decided....well more like my $$$ hasnt decided lol
__________________
2 12" rockford fosgate subs,1500w Hifonics amp, throttle spacer, performance chip, FSWerks 2.5" race exhaust, custom CAI w/Spectre 10.5x6 filter Blue leds all around pulsating in the trunk, smoked taillights and turn signals
jlawlax1344 is offline  
    Reply With Quote Quick reply to this message
Old 12-08-2012, 12:15 AM   #20
swagfocuswagon
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Okay so I got my coil pack, installed it, major improvement for sure. Still has the light and runs a bit rough still. Gonna say it needs an alternator still. But it does run a lot nicer though!
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:43 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.