HOW TO: IMRC Removal and Repair - Page 11 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-17-2012, 08:12 PM   #101
bbcobra
Focus Enthusiast
 
bbcobra's Avatar
 
Join Date: Aug 2011
Fan#: 88400
Location: Elkin, NC
What I Drive: 2003 SVT Competition Orange EAP ZX3

Posts: 149
Points 358, Level 7
Points: 358, Level: 7 Points: 358, Level: 7 Points: 358, Level: 7
Level Up 16% Completed
Level up: 16% Level up: 16% Level up: 16%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 bbcobra Good Standing Member
Buy-Sell-Trade Rating: (1)
I decided to finally fix mine today. Had it out and took the cover off. I have the cracked solder joints so I go looking for my solder iron. After searching for 2 hours I gave up and put the intake and battery back in. I guess I'll take the module with me to work Monday and get it finished. I'll just take it apart again next weekend.
I may also take that weight off of the trans. linkage while I'm in there and see how that feels.
__________________
03 SVT Focus, Comp Orange, EAP, Eibach sway bars, H&R Race Springs, Koni Sports, steeda shifter, Massive camber arms, toe links, engine mount bushings, sway bar end links.

other car: 2004 SVT Cobra Coupe, Screaming Yellow, 2.76/2lb lower...
bbcobra is online now  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-18-2012, 01:42 AM   #102
DarkSVT03
Focus Enthusiast
 
DarkSVT03's Avatar
 
Join Date: Sep 2012
Fan#: 104226
Location: Lehi, UT
What I Drive: 2003 black SVT focus

Posts: 152
FF Reputation: 2 DarkSVT03 Good Standing Member
Buy-Sell-Trade Rating: (0)
Ok so my SVTf runs like ass some days and runs great other days. I have 139k on mine, and I was wondering if this could be the issue? No cel, but I believe I did get the code once last month, but it went away. Some days I have great torque, and other days I have nothing. I work at Oreilly auto parts, so the imrc is cheaper for me. Would it be worth replacing? I can't solder or I would try and take a look.
DarkSVT03 is offline  
    Reply With Quote
Old 11-18-2012, 09:10 AM   #103
MDCalvert
Focus Enthusiast
 
MDCalvert's Avatar
 
Join Date: Jun 2011
Fan#: 87161
Location: Huntingtown, MD
What I Drive: 2002 ford focus svt

Posts: 65
FF Reputation: 1 MDCalvert Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by DarkSVT03 View Post
Ok so my SVTf runs like ass some days and runs great other days. I have 139k on mine, and I was wondering if this could be the issue? No cel, but I believe I did get the code once last month, but it went away. Some days I have great torque, and other days I have nothing. I work at Oreilly auto parts, so the imrc is cheaper for me. Would it be worth replacing? I can't solder or I would try and take a look.
Seems most likely to be it. I would still take it apart and look around its not to hard at all to do. You can always find a friend to solder for you. Also big thing is the copper contact point can be dirty and be making it run funny. Be yes I would replace it if not taking apart lol.
MDCalvert is offline  
    Reply With Quote
Old 11-19-2012, 02:00 AM   #104
jimmy03svt
Focus Rookie
 
Join Date: Nov 2012
Fan#: 105918
Location: north ridgeville, OH
What I Drive: black 03 5 door

Posts: 7
FF Reputation: 1 jimmy03svt Good Standing Member
Buy-Sell-Trade Rating: (0)
have a p1518 code pop up today..car still runs perfect no change in idle or power, also i cant where to get the imrc module(the box?). what is the dsi clip? and the scanner says nothing but p1518. i see many different explanations for it but im not sure how the component works so anyone who can explain it? thanks!

03 focus svt..stock
jimmy03svt is offline  
    Reply With Quote
Old 11-21-2012, 10:30 AM   #105
jvert
Focus Enthusiast
 
jvert's Avatar
 
Join Date: Nov 2010
Fan#: 80613
Location: West Suburbs, IL
What I Drive: 2004 Red ZX5 SVT

Posts: 59
Points 222, Level 4
Points: 222, Level: 4 Points: 222, Level: 4 Points: 222, Level: 4
Level Up 44% Completed
Level up: 44% Level up: 44% Level up: 44%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jvert Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by jimmy03svt View Post
have a p1518 code pop up today..car still runs perfect no change in idle or power, also i cant where to get the imrc module(the box?). what is the dsi clip? and the scanner says nothing but p1518. i see many different explanations for it but im not sure how the component works so anyone who can explain it? thanks!

03 focus svt..stock

I got the same code and just orderd my IMRC from Steve at Tousley Ford. My car too is stock and I have not noticed any loss in power or mpg's.
__________________
2004 Red ZX5 SVT #132 of 1079
jvert is offline  
    Reply With Quote
Old 01-05-2013, 04:51 PM   #106
jvert
Focus Enthusiast
 
jvert's Avatar
 
Join Date: Nov 2010
Fan#: 80613
Location: West Suburbs, IL
What I Drive: 2004 Red ZX5 SVT

Posts: 59
Points 222, Level 4
Points: 222, Level: 4 Points: 222, Level: 4 Points: 222, Level: 4
Level Up 44% Completed
Level up: 44% Level up: 44% Level up: 44%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 jvert Good Standing Member
Buy-Sell-Trade Rating: (1)
Finally fixed. Great write up!,,
__________________
2004 Red ZX5 SVT #132 of 1079
jvert is offline  
    Reply With Quote
Old 02-02-2013, 08:50 PM   #107
stanger19899ddr
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100097
Location: copperas cove, TX
What I Drive: 01 zx3, 2002 SVTF, 2004 Silver euro

Posts: 9
FF Reputation: 1 stanger19899ddr Good Standing Member
Buy-Sell-Trade Rating: (0)
Focus SVT IMRC

This is a great post
My SVT was getting the dreaded IMRC check engine light when I found this post
Figured I would try to fix my module today after I retuned from the salvage yard.
I found a unique thing today I think
While I was walking around I found a duratec 24 valve engine in and decided to look inside the IMRC Module The 99 and new have the short cable.
Took the screws loose fo the circuit board Wiggled the connector and the circuit board and the motor are easily removed.
Turned the gear with the cable on it and the cable slid out. It even had the same number on the box as my 02 foocus SVT. YOu can clean the contact and whatever else you need to do and dont have to unsolder anything.
ALSO found out a 96 Contour duratec 24 valve V6 engines module is a dirct replacemnt for the SVT. Just put one in mine and cleared the light
WORKS GREAT...
stanger19899ddr is offline  
    Reply With Quote
Old 02-04-2013, 08:53 PM   #108
IH84DZ
Focus Enthusiast
 
Join Date: Jul 2012
Fan#: 101801
Location: Champaign, IL
What I Drive: 03 CD silver SVT 5 door

Posts: 170
FF Reputation: 5 IH84DZ Good Standing Member
Buy-Sell-Trade Rating: (0)
Got a P1518 at 108K miles a few months ago when winter hit. Cleared it immediately - never had a driveability symptom so it was obviously an intermittent problem...until recently when it would come back within days... Saw the thread and decided to actually try and fix it instead of buying a new module.

It was pretty easy - thankfully I had a sharp soldering iron to keep hot spots small and it was interesting getting the holes in the IC board free from solder so I could align the connector pins... a little patience was the key.

48 hours later still no code. Thanks for the good writeup
IH84DZ is offline  
    Reply With Quote
Old 02-28-2013, 11:16 PM   #109
AlfPrev
Focus Jr. Enthusiast
 
Join Date: Sep 2012
Fan#: 104347
Location: town, ND
What I Drive: car

Posts: 25
FF Reputation: 1 AlfPrev Good Standing Member
Buy-Sell-Trade Rating: (0)
I did this fix to two separate IMRC actuators and fixed one. 50% aint bad, good tips
AlfPrev is offline  
    Reply With Quote
Old 02-28-2013, 11:45 PM   #110
stanger19899ddr
Focus Rookie
 
Join Date: Jun 2012
Fan#: 100097
Location: copperas cove, TX
What I Drive: 01 zx3, 2002 SVTF, 2004 Silver euro

Posts: 9
FF Reputation: 1 stanger19899ddr Good Standing Member
Buy-Sell-Trade Rating: (0)
IMRC fix still working

After a couple weeks the IMRC Is working great
NOW
I just need to figure out the last problem
A CODE 13 flashing AIRBAG Light
Had the AIrbag module re set , VIN put into the RCM and still a code 13, ANy thoughts.
stanger19899ddr is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Tags
dsi imrc

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:54 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.