Speedo doesnt work but replaced everything. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-19-2012, 10:56 PM   #1
CBC&MLGZX3
Focus Rookie
 
CBC&MLGZX3's Avatar
 
Join Date: Apr 2011
Fan#: 84819
Location: covington, GA
What I Drive: 2001 pitch black zx3

Posts: 3
FF Reputation: 1 CBC&MLGZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
Speedo doesnt work but replaced everything.

Ok, i figured out how to post finally. i have an 01 focus zx3 mtx-75. the car has minor mods. have been driving it for about 3 years and lately have been having alot of problems, my biggest being that the speedometer keeps jumping and then going to zero. odometer also blanks out occasionally. so i have replaces the vehicle speed sensor and the coil pack along with wires and plugs. checked the alternator and it is fine. battery is also fine and terminals are good. any help would be much appreciated.
I also have oil coming out of my oil filter which has been going on for a while. its ruined about 3 driver side motor mounts since i began driving the car. does anyone have an answer to this problem?


CBC&MLGZX3 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-19-2012, 11:14 PM   #2
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,226
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Quote:
Originally Posted by CBC&MLGZX3 View Post
my biggest being that the speedometer keeps jumping and then going to zero. odometer also blanks out occasionally. So I have replaced the Vehicle Speed Sensor, the coil pack along with wires and plugs.
Most times replacing those parts should fix this problem. The fact it didn't means it's probably in the wiring. Unfortunately there's no easy way to test it. What you'll probably end up having to do is replace the wiring from the VSS to the ECU.




Quote:
Originally Posted by CBC&MLGZX3 View Post
I also have oil coming out of my oil filter which has been going on for a while.
Umm.
What?
I surely hope you misspoke there and meant Valve Cover Gasket.
Any oil leaking from the oil filter is very bad and should be fixed immediately. Do not drive the car until it is fixed.



Quote:
Originally Posted by CBC&MLGZX3 View Post
Its ruined about 3 driver side motor mounts since i began driving the car. does anyone have an answer to this problem?

Many have had back luck with parts store brand motor mounts. But many have had good luck with Motorcraft mounts.
Solution, replace with factory mounts.
__________________
Don't "think outside the box".
There is no box.
Do it correct, or do it twice.
iminhell is online now  
    Reply With Quote
Old 11-20-2012, 08:22 AM   #3
CBC&MLGZX3
Focus Rookie
 
CBC&MLGZX3's Avatar
 
Join Date: Apr 2011
Fan#: 84819
Location: covington, GA
What I Drive: 2001 pitch black zx3

Posts: 3
FF Reputation: 1 CBC&MLGZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks for the reply. ill try the wiring next. and i did say the wrong thing. instead of oil filter i meant air filter.. its spitting up little amounts out of the air filter which is putting oil on top of the drivers side mount. i have an aem cold air intake. could this be the problem. ive heard it could be blow by but the car runs really good for it to be blow by. could anything else cause small amounts of oil to come out of the air filter. the amount must be small because im never low on oil when i check it
CBC&MLGZX3 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:18 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.