NO indicator for winshield wiper fluid - Page 18 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Third Generation > MK3 TSB, Recall & Problems Archive

MK3 TSB, Recall & Problems Archive The place to chat about TSB and Known Issues for the 2012 Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-16-2012, 10:06 AM   #171
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,537
Points 3,278, Level 35
Points: 3,278, Level: 35 Points: 3,278, Level: 35 Points: 3,278, Level: 35
Level Up 52% Completed
Level up: 52% Level up: 52% Level up: 52%
Forum Activity 16%
Activity: 16% Activity: 16% Activity: 16%
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Merrigan View Post
...That being said. A new or pretty new car should work right. If it's something as simple as the indicator isn't working correctly bring it to the dealership and tell them to fix the damn thing. Simple as that...
Quote:
Originally Posted by Some Guy From NY View Post
Of course. This is the first car I have ever had to have this indicator, never even heard of a car with one before. It really is no big deal, but like you said- It is a NEW car and ALL the features it has should work and work correctly. No matter how "small" or "insiginifcant" they may be.
Great advice, Merrigan and Some Guy From NY.

As always, if anyone is having this concern (or any other concern, for that matter) I'm happy to step in and assist. Send me a PM and we'll get started.

Thanks!
Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordServiceUS facebook.com/FordFocus

M - F 11 a.m. - 8 p.m. ET | Send a PM? Pls allow 2 business days for reply
FordService is online now  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-16-2012, 10:27 AM   #172
Tiger-Heli
Focus Addict
 
Join Date: Aug 2004
Fan#: 12379
Location: Georgia, United States
What I Drive: 2002 French Blue SE Sedan

Posts: 633
Points 742, Level 14
Points: 742, Level: 14 Points: 742, Level: 14 Points: 742, Level: 14
Level Up 43% Completed
Level up: 43% Level up: 43% Level up: 43%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 4 Tiger-Heli Good Standing Member
Buy-Sell-Trade Rating: (1)
If you have followed the thread from the beginning ...

Agreed it's a minor thing, but it should work, there is a TSB saying it sometimes doesn't work and how to fix it. That all is well and good.

The issue I have with this thread (and the other multiple issues with the car) is that we have members taking cars to the dealer for issues with a known TSB and being told either "Your particular car doesn't have that feature", or "Your car is supposed to stutter and grind and clunk like that".

It's taken 18 pages to verify that all Focuses are SUPPOSED to have this indicator and what the indication should look like when it appears.
Tiger-Heli is online now  
    Reply With Quote Quick reply to this message
Old 11-19-2012, 12:03 PM   #173
Some Guy From NY
Focus Enthusiast
 
Some Guy From NY's Avatar
 
Join Date: Jul 2012
Fan#: 101517
Location: Brooklyn, NY
What I Drive: 2012 SGM Focus SEL sedan DCT

Posts: 493
FF Reputation: 3 Some Guy From NY Good Standing Member
Buy-Sell-Trade Rating: (0)
Went to the dealer today for an oil change & tire rotation. While there they did the windshield wiper fluid TSB and updated my MFT with the new TSB related to that.

As for the windshield wiper fluid TSB, I will have to wait until I am out again to see if I get the warning message, since they refilled it for me.
__________________
Mods: Drop in K&N filter, Steeda RSB, MS3 RMM, Remote start, Llumar tint, Ti engine cover, Husky floor mats, OEM splash guards
Some Guy From NY is offline  
    Reply With Quote Quick reply to this message
Old 11-21-2012, 12:13 PM   #174
pablo94sc
Focus Enthusiast
 
pablo94sc's Avatar
 
Join Date: Oct 2012
Fan#: 104464
Location: Memphis, TN
What I Drive: 2012 Kona Blue SE Sport 5dr (5spd)

Posts: 155
Points 494, Level 9
Points: 494, Level: 9 Points: 494, Level: 9 Points: 494, Level: 9
Level Up 88% Completed
Level up: 88% Level up: 88% Level up: 88%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 pablo94sc Good Standing Member
Buy-Sell-Trade Rating: (0)
I ran out of fluid and no light, so I'll head up the dealership soon and have them reflash the computer. Thanks for this thread.
pablo94sc is offline  
    Reply With Quote Quick reply to this message
Old 01-03-2013, 03:47 PM   #175
Tonybaloney
Focus Enthusiast
 
Join Date: Jun 2011
Fan#: 87335
Location: Annapolis, MD
What I Drive: 2012 Candy Blue Metallic Hatch Sel

Posts: 54
Points 149, Level 2
Points: 149, Level: 2 Points: 149, Level: 2 Points: 149, Level: 2
Level Up 98% Completed
Level up: 98% Level up: 98% Level up: 98%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 1 Tonybaloney Good Standing Member
Buy-Sell-Trade Rating: (0)
So the real question is why are these cars going out with all these issues? If something breaks then fix it, however if its broken to begin with then that's the real problem.
__________________
Build date 02/17/2011
Tonybaloney is offline  
    Reply With Quote Quick reply to this message
Old 01-04-2013, 11:17 AM   #176
ransil
Focus Enthusiast
 
Join Date: Jun 2011
Fan#: 86614
Location: Pittsburgh, PA
What I Drive: 2012 Blue TI when it gets here..

Posts: 67
Points 38, Level 1
Points: 38, Level: 1 Points: 38, Level: 1 Points: 38, Level: 1
Level Up 76% Completed
Level up: 76% Level up: 76% Level up: 76%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 ransil Good Standing Member
Buy-Sell-Trade Rating: (0)
I had the TSB done a few weeks ago, apparently they did not verify even though the washer bottle was empty when I took it in, the indicator still does not work.

I have a 2013 escape ti and it does not show when low either.

Sent from my Galaxy Nexus using FF Mobile
ransil is offline  
    Reply With Quote Quick reply to this message
Old 01-04-2013, 02:53 PM   #177
blackraven456
Focus Addict
 
Join Date: Jul 2011
Fan#: 88061
Location: Jacksonville, FL
What I Drive: 2012 Black Focus Titanium Sedan

Posts: 967
FF Reputation: 1 blackraven456 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by hotleadsingerguy View Post
Yes, it's incorrect. I've run out, as well.

And I'm glad someone else noticed that the only people thinking it's not a big deal are people that it doesn't really affect. For those of us that live in areas where salt on a road is a necessity during the winter...this is downright dangerous. Getting onto the highway before finding out you have no windshield wiper fluid is a *big* deal. I usually carry a small reservoir in my trunk during the winter, but only because I realized the warning light doesn't work.


For people living in non-salty areas...imagine driving down the road and someone throwing white paint all over your windshield. Then realizing you have no way to wipe it off...and you're still traveling at 70mph with traffic all around. Now come back to this thread and think before posting.
Yup... having no fluid in winter can be deadly. Its not uncommon in my area to use an entire bottle of fluid going to and from your destination.

Sent from my Nexus 7 using FF Mobile HD
__________________
2012 Titanium Sedan, Ebony Black - 400A, Luxury Package
Ordered: July 14 VIN received: August 19 Sticker: Sept 3 Build Date: Sept 10 Delivered: Sept 21
blackraven456 is offline  
    Reply With Quote Quick reply to this message
Old 01-04-2013, 03:01 PM   #178
gsxrboy
Focus Enthusiast
 
Join Date: Sep 2012
Fan#: 103574
Location: Brampton, Canada
What I Drive: 2012 Black Focus Titanium

Posts: 175
FF Reputation: 3 gsxrboy Good Standing Member
Buy-Sell-Trade Rating: (0)
I agree with everyone about this possible issue and it should work as advertised. However regardless of the warning light or not, you are supposed to check the fluid levels on a regular basis. I was born and raised in Toronto, the standard practice is to fill up the washer fluid either weekly or monthly, depending on use. Waiting for a warning light is not good driving IMO.
__________________
2012 Focus Titanium Black Manual

http://www.fuelly.com/driver/gsxrboy/focus
gsxrboy is offline  
    Reply With Quote Quick reply to this message
Old 01-04-2013, 04:02 PM   #179
SaToX
Focus Enthusiast
 
Join Date: Jan 2012
Fan#: 94321
Location: Moncton, Canada
What I Drive: 2012 White Titanium Hatch

Posts: 124
FF Reputation: 4 SaToX Good Standing Member
Buy-Sell-Trade Rating: (0)
I had my dealer fix this a few months ago, I wish I knew what they had to do exactly to fix it. It does now work, albeit with not much room for error. The light comes on you got 5 or 6 more clearings of the winshield and your out. Aswell when the indicator only comes on when you start the car, not so informative when you use your remote starter, and only come out the the car once the notification is long gone. Sadly without a permanent indicator, it can still leave you in a hairy situation. Best bet is to top up before a long trip, and YES I live in Canada where there is salt on the roads 5 months of the year so I do feel your pain of it not working, I was there.
SaToX is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2013, 03:32 PM   #180
JimsterG
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 95184
Location: Tucson, AZ
What I Drive: 2012 5 dr SEL in Race Red

Posts: 249
Points 131, Level 2
Points: 131, Level: 2 Points: 131, Level: 2 Points: 131, Level: 2
Level Up 62% Completed
Level up: 62% Level up: 62% Level up: 62%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 JimsterG Good Standing Member
Buy-Sell-Trade Rating: (0)
I let my washer fluid run low just to see what happens and I received the low fluid warning. But normally I am under the hood every 2 weeks or so just checking stuff out and would normally fill it before it got that low. This is when I check the air in the tires also.
JimsterG is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:29 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat