Horn -It stopped working - fuses and relay good - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-15-2012, 02:26 PM   #1
2003focusowner
Focus Enthusiast
 
Join Date: Dec 2007
Fan#: 51939
Location: Maine, United States
What I Drive: 2003 Focus SE SPI

Posts: 361
Points 5,065, Level 45
Points: 5,065, Level: 45 Points: 5,065, Level: 45 Points: 5,065, Level: 45
Level Up 58% Completed
Level up: 58% Level up: 58% Level up: 58%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 2 2003focusowner Good Standing Member
Buy-Sell-Trade Rating: (2)
Horn -It stopped working - fuses and relay good

so the horn on my 2003 sedan stopped working....fuses are good and I can hear the horn relay clcik when I press the horn button........took the horn off and tested it.......thats good as well.......not sure what is going on.....anyone had this happen to them before.....


2003focusowner is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-15-2012, 11:01 PM   #2
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,941
Points 2,059, Level 27
Points: 2,059, Level: 27 Points: 2,059, Level: 27 Points: 2,059, Level: 27
Level Up 40% Completed
Level up: 40% Level up: 40% Level up: 40%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 88 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Since you've checked all the system components, it's got to be the wiring.
Check you're getting 12V at the horn wire connector when the button is depressed. Check the horn grounding wire at the horn. Clean any electrical connectors in the circuit and the horn chassis ground.

If that fails, you're looking for a wiring break in the orange/blue (12V power) or black (ground) wire. It's a simple circuit and problems should be self evident.
BC_ZX3 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:00 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat