electrical issues - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-15-2012, 10:19 AM   #1
cdhayes77
Focus Rookie
 
Join Date: Nov 2012
Fan#: 106075
Location: Columbus, OH
What I Drive: 2005 silver focus

Posts: 2
FF Reputation: 1 cdhayes77 Good Standing Member
Buy-Sell-Trade Rating: (0)
electrical issues

This morning I warmed up the car, I noticed that my rear defroster watosn't working. I get to the stop sign and notice my turn signals aren't working, when a pushed on the gas a loud squeal came from radio, I then noticed my speedometer wasn't working or my temp gauge. When I pulled over I noticed a smell coming from the vents, I popped my hood and noticed gas/smoke coming from the battery.. I just replaced the battery and alternator five months ago.. Any one have any ideas?


cdhayes77 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-15-2012, 03:29 PM   #2
Magus2727
Focus Fanatic
 
Magus2727's Avatar
 
Join Date: Feb 2009
Fan#: 62897
Location: Salt Lake City, UT
What I Drive: 2001 Malibu Blue ZX3

Posts: 4,348
Points 8,146, Level 60
Points: 8,146, Level: 60 Points: 8,146, Level: 60 Points: 8,146, Level: 60
Level Up 98% Completed
Level up: 98% Level up: 98% Level up: 98%
Forum Activity 21%
Activity: 21% Activity: 21% Activity: 21%
FF Reputation: 9 Magus2727 Good Standing Member
Buy-Sell-Trade Rating: (2)
Smoke coming from the battery? Battery should still be under warranty, take it there to get it tested. the Focus has some weird wiring tied into the rear defroster. I cant recall right now what all else is tied to that fuse bank. But check the fuses and relays. Both under the hood and those in the cabin. the push on the gas and the radio may be just from poor grounding perhaps? feedback/noise from the motor is coupling on to the ground or to the antenna.

How long have you had the car? has anything changed since this happened?
__________________
2001 ZX3 2.0L Zetec-
Hatch Nation #42

Going through Rebuild See "The TICK Build Thread" for details (http://www.focusfanatics.com/forum/showthread.php?t=289168&referrerid=62897)
Magus2727 is offline  
    Reply With Quote Quick reply to this message
Old 11-15-2012, 03:37 PM   #3
cdhayes77
Focus Rookie
 
Join Date: Nov 2012
Fan#: 106075
Location: Columbus, OH
What I Drive: 2005 silver focus

Posts: 2
FF Reputation: 1 cdhayes77 Good Standing Member
Buy-Sell-Trade Rating: (0)
Had it since 05, the only issues I have had is a bad alternator and battery which I'm sure the alternator caused, she's been parked since it.happened
cdhayes77 is offline  
    Reply With Quote Quick reply to this message
Old 11-15-2012, 06:29 PM   #4
Magus2727
Focus Fanatic
 
Magus2727's Avatar
 
Join Date: Feb 2009
Fan#: 62897
Location: Salt Lake City, UT
What I Drive: 2001 Malibu Blue ZX3

Posts: 4,348
Points 8,146, Level 60
Points: 8,146, Level: 60 Points: 8,146, Level: 60 Points: 8,146, Level: 60
Level Up 98% Completed
Level up: 98% Level up: 98% Level up: 98%
Forum Activity 21%
Activity: 21% Activity: 21% Activity: 21%
FF Reputation: 9 Magus2727 Good Standing Member
Buy-Sell-Trade Rating: (2)
Possibly a failed battery, go get it checked out first. and Check all your ground connections to the battery and to the motor. go from there....
__________________
2001 ZX3 2.0L Zetec-
Hatch Nation #42

Going through Rebuild See "The TICK Build Thread" for details (http://www.focusfanatics.com/forum/showthread.php?t=289168&referrerid=62897)
Magus2727 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:22 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat