help - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-13-2012, 04:35 AM   #1
anita
Focus Rookie
 
Join Date: Nov 2012
Fan#: 105969
Location: ireland, Ireland
What I Drive: 2008 grey focus zetec

Posts: 2
FF Reputation: 1 anita Good Standing Member
Buy-Sell-Trade Rating: (0)
help

my car 08 ford focus zetec diesel displays power steering malfunction the sensor and power steering pump have been replaced, the mechanic has advised that he cannot find any electrical problem and has "no idea" what the issue is..the car is in a ford garage what other possible issues could be causing this?


anita is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-13-2012, 04:50 AM   #2
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,057
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
If the sensor is new, and the pump is new, then there might be some blockage in the steering rack unless your steering felt fine. If you had blockage there, or in one of the lines, then it would be difficult to steer the car. Most likely it's an electrical problem, and he just didn't find it.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 11-13-2012, 04:54 AM   #3
anita
Focus Rookie
 
Join Date: Nov 2012
Fan#: 105969
Location: ireland, Ireland
What I Drive: 2008 grey focus zetec

Posts: 2
FF Reputation: 1 anita Good Standing Member
Buy-Sell-Trade Rating: (0)
HI

the sensor was new and the pump was a reconditioned one.. they thought the pump could be faulty so tried another and this still did not fix the issue :( would i be right in saying that if the two pumps fitted did not retify the problem then the original pump can be put back in?

the steering was not effected by this issue.. i just think it is crazy that a ford garage cannot fix this issue.

Thabnks for your reply
anita is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:09 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.